#foswiki 2012-04-15,Sun

↑back Search ←Prev date Next date→ Show only urls(Click on time to select a line by its url)

WhoWhatWhen
***gac410 has left [04:48]
..................................................................................................................................................................... (idle for 13h42mn)
aatlemI updated Foswiki today, and now I'm having authentication problems.
Kind of expected, given the nature of the update, but I'm running into some strange problems.
[18:30]
gac410what version were you on before the update, and what type of authentication do you use? [18:32]
aatlemI was on 1.1.4, I believe. I use the fosiki repository under Ubuntu, so I did an apt-get update.
Symptoms:
(BTW, I ditched my LocalConfig, though the old one is backed up.)
[18:32]
gac410oh. hm. I don't use the .deb packages. I'll try to help but really, no idea about how they were built. [18:33]
aatlem1) I can log in, and I can add myself to the admin group using the configure password.
Whatever help is appreciated. :)
I then try to remove someone from another group, and am told that I don't have permission, even while logged in as admin.
I went to edit the WikiGroups page, and it's all code now.
I'm also seeing some strange WYSIWYG formatting, without line breaks.
[18:33]
gac410wow, this doesn't sound very good. Do you use expires to have client caching. Have you cleared your browser cache?
The javascript for wysiwyg editing has changed with 1.1.5.
[18:37]
aatlemSorry, not the WikiGroups page, the Site Permissions page.
Hmm. That could be it right there. I hope. :)
[18:38]
gac410(as well as a lot of other pages. So any caching of jS or CSS might cause strangeness. [18:38]
aatlemLet me try deleting the cache. Hold on.
That was definitely some of the problem. My list of permitted webs in the left column is correct now. Let me try to do stuff.
[18:38]
gac410keep fingers crossed :) [18:41]
aatlemI'm going to declare it good enough fixed for the moment. :)
I probably need to do some deeper testing, but thanks!
[18:45]
gac410great! I'd actually hope that it all goes smoothly. I definitely wouldn't say that issues are expected. All of the upgrades to foswiki.org from 1.1.4 through all the betas and RCs to 1.1.5 went pretty well.
If you choose to take advantage of some of the new features - migrating to a different encryption for passwords, etc. (which we did on foswiki.org as well) that should be okay as well.
[18:46]
aatlemCool. I'll look into it. Thanks! [18:48]
gac410Touching .htpasswd though is always tricky, so be sure to back up just in case :) [18:48]
***aatlem has left [18:52]
........ (idle for 37mn)
gac410gac410 wonders if any mere mortal can get EditChapterPlugin to work. [19:29]

↑back Search ←Prev date Next date→ Show only urls(Click on time to select a line by its url)