#foswiki 2012-05-19,Sat

↑back Search ←Prev date Next date→ Show only urls(Click on time to select a line by its url)

WhoWhatWhen
gac410I think in hindsight, we should not have integrated the trunk WysiwygPlugin into 1.1.5, but what's done is done. The 1.1.9 version in Foswiki:Extensions/Testing.WysiwgyPlugin is close, but still corrupts <blockquote> blocks. [00:00]
FoswikiBothttp://foswiki.org/Extensions/Testing.WysiwgyPlugin [00:00]
gac410Foswiki:Extensions/Testing.WysiwygPlugin Why on earth to I keep spelling that wrong. [00:01]
FoswikiBothttp://foswiki.org/Extensions/Testing.WysiwygPlugin [ WysiwygPlugin < Extensions/Testing < Foswiki ] [00:01]
.......... (idle for 46mn)
***AlexisHazell has left "QUIT :Leaving." [00:47]
............................................................. (idle for 5h1mn)
GithubBot[foswiki] foswiki pushed 1 new commit to Release01x01: http://git.io/Mbc5Og
[foswiki/Release01x01] Item11801: replace dependency on Digest::SHA1 with Digest::SHA - its perl core since 5.10, and otherwise installable (D::SHA1 is not in ubuntu and will be gone from Debian soon - SvenDowideit
[05:48]
***GithubBot has left [05:48]
FoswikiBothttp://foswiki.org/Tasks/Item11801 [ Item11801: Unable to install foswiki 1.1.5 debian package on ubuntu 12.04 due to unmet dependency ] [05:48]
SvenDowideitwell Babar looks like the perltidy thing is a problem
use Foswiki::Configure::Load ();

-use 5.006; # First version to accept v-numbers.
-require v5.8.8; # see http://foswiki.org/Development/RequirePerl588
+use 5.006; # First version to accept v-numbers.
+require v5.8.8; # see http://foswiki.org/Development/RequirePerl588
[05:53]
FoswikiBothttp://trunk.foswiki.org/System/PerlDoc?module=Foswiki::Configure::Load [05:53]
SvenDowideit
# Site configuration constants
and if i change the commit to what its telling me, it then wants the other version
seems that its unable to make up its mind
lets try a tab
mmm, one more hack
freaky
this time it worked
[05:53]
GithubBot[foswiki] foswiki pushed 2 new commits to master: http://git.io/ZpjtYA
[foswiki/master] Item11878: require perl 5.8.8 for 1.2.0 - SvenDowideit
[foswiki/master] Item11801: remove mention of D::SHA1 and FileCache - its replaced with new code - SvenDowideit
[06:03]
***GithubBot has left [06:03]
FoswikiBothttp://foswiki.org/Tasks/Item11878 [ Item11878: require perl 5.8.8 for 1.2.0 ] [06:03]
.......... (idle for 45mn)
pharveySvenDowideit, Babar - perltidy has a known bug with comments where the layout will oscillate http://perltidy.sourceforge.net/BUGS.html [06:48]
SvenDowideitboooooo :)
lets shoot the messenger
[07:01]
.... (idle for 15mn)
oh boy, foswiki 1.2.0 being minimum 5.8.8 gives me all sorts of fun [07:16]
.... (idle for 17mn)
GithubBot[foswiki] foswiki pushed 1 new commit to master: http://git.io/_eRjGA
[foswiki/master] Item11879: Development.MeasureAndReportScriptTiming - Time::HiRes is perl core ... at least in 5.8.8, which is the new minimum - SvenDowideit
[07:33]
***GithubBot has left [07:33]
FoswikiBothttp://foswiki.org/Tasks/Item11879 [ Item11879: Development.MeasureAndReportScriptTiming ] [07:33]
........................................................ (idle for 4h35mn)
***ChanServ sets mode: +o OliverKrueger [12:08]
OliverKruegerHi
Given the ACLs set in http://foswiki.org/Community/Board/WebPreferences, why can everybody still see this web?
[12:08]
ArthurClemensas guest I can see the web [12:14]
OliverKruegeryep. - thats what I do not understand.
I even added WikiGuest to the DENY list.
[12:14]
.... (idle for 19mn)
foswiki_irc3Hi all! I want to try the virtual machine image to test foswiki. The guide does not seem to be correct though. When I boot the VM I can not find a web interface. 127.0.0.1:8888 does not seem to work. Any ideas? [12:34]
............... (idle for 1h10mn)
ArthurClemenshow come that with a rest call the 'die' errors don't write to the screen?
in the end the only error I see is: ERROR: (404) Invalid REST invocation
[13:44]
.......... (idle for 47mn)
gac410ArthurClemens: Thanks for the update on the TMCE... By any chance were you testing with Safari? [14:31]
ArthurClemensno, chrome
webkit with differences
[14:31]
gac410The reports seemed more related to TMCE operatiion. What I've been working on has been strangeness when converting from TML -> HTML -> TML
The behavior of TMCE itself. ... I think that's mostly upstream, we pretty much take what's available from moxicode.
[14:32]
ArthurClemensalso the marking of "do not touch" areas? [14:34]
gac410That's both. Wysiwyg inserts a div or span for the block. CSS applies the markup. I have no idea how TMCE controls work.
Wysiwyg converts TML to HTML, inserting special spans for newlines, white space, etc. that would normally be lost to HTML. And when TMCE is done, tries to convert it back. The test/unit/Wysiwyg/TranslatorTests.pm verifies the conversions.
The loss of newlines, disappearing blockquotes, etc. have been because WysiwygPlugin generates invalid HTML that Wysiwyg "sanitizes". Biggest issue was insertion of extraneous <p> ... </p> tags across other block markup. <p><blockquote></p>....<p></blockquote></p>
[14:36]
.... (idle for 16mn)
ArthurClemens: I'm trying to recreate your issues to better understand them. First one - Multiple blockquotes. I entered multiple lines, Highlighted and pressed ["] blockquote button. It worked fine. Then hit return inside. All seemed fine in both Firefox and Chrome on linux. So need more info on that one.
Blockquotes and de-indent button ... yup. Confirmed, but I don't think that's our code.
De-indent makes blockquote indent Can't recreate. But Indent does indent a paragraph inside the blockquote, and that is "lost" by wysiwyg. Probably because I'm testing release11 though which doesn't have indent.
Hm. All my blockquotes have gray backgrounds.
re Links. All links should make the unlink button become active. New Wysiwyg converts all linking text to real html links, You can use unlink button to remove the link, or link button to edit the link
Missing format in dropdown ... yeah, I was not sure how to do that.
[14:57]
ArthurClemens"All my blockquotes have gray backgrounds" - the "real" ones have a darker left border. the semi one doesn't [15:07]
gac410hm. If you click the html button, that will show you how the markup is actually entered by the editor. Any differences? [15:07]
ArthurClemensthis is the semi one: <blockquote style="margin-top: 0px; margin-right: 0px; margin-bottom: 0px; margin-left: 40px; border-width: initial; border-color: initial; border-image: initial; border-style: none; padding: 0px;"> [15:09]
gac410Oh... that's my test topic. That was the blockquote that you reported as lost by save. :)
It was manually entered as HTML in the TML
[15:10]
ArthurClemensit is the style generated by current tmwiki [15:10]
gac410Oh. ugh. No CSS i guess. I don't think we want to do that do we? (emit styled html?) [15:11]
ArthurClemensno [15:11]
gac410If you want foswiki blockquotes to look like tmwiki, probably need to override our css to have the same style? [15:11]
ArthurClemensI don't. but when editing it is inexplicable why that blockquote looks different
I guess there is not much to do about that
if there was an option to "Reset styling"...
[15:12]
gac410Maybe there is. Need to look at the moxicode documentation, there may be a toolbar button you could enable.
tmce has a lot of features that we have not enabled.
So for me, good news I think is you did not see any strangeness where the topic was gaining or loosing lines, or markup in the topic inexplicably disappeared.
[15:13]
ArthurClemensmultiple block quotes: still occurring, also in firefox. move the pointer to block blah blah / a / c (inside) and press enter [15:16]
gac410Topic? [15:16]
ArthurClemenshttp://trunk.foswiki.org/Sandbox/TestWysiwyg
and the second blockquote (tmwiki one), press enter after the first paragraph and the blockquote gets split in 2
(firefox)
[15:17]
gac410This is really strange. Hm [15:18]
ArthurClemensdo you see it? [15:19]
gac410Damn.... okay I've recreated it.
Really strange. If I create a new topic, it doesn't happen.
[15:19]
I think TMCE is getting confused by the stylings. It doesn't happen to me in a topic with plain old blockquotes.
Something about that topic.
[15:26]
......... (idle for 44mn)
ArthurClemens: The difference is whether or not the blockquote contents is on the same line as the blockquote. OR... if the blockquote contains spans for hidden white space.,
I have no idea how to fix it. I think it's more upstream TMCE related than a Wysiwyg issue.
I am guessing that from TMCE's perspective, a span encoding hidden newlines vs. no white space is causing the same behavior. So pressing "enter" - creating a new paragraph in a blockquote that consists only of a single paragraph breaks things.
[16:14]
ArthurClemensmost of the time it works out [16:32]
gac410Yeah. Unfortunately it seems to be more a TMCE issue. I'm not sure what I could do to fix it. I could force a <p> after a blockquote, but that would probably trigger creeping whitespace. [16:33]
ArthurClemensyep, don't
another minor annoying thing with the tmwiki syntax: if you select all text in that blockquote and press "remove formatting" (eraser), you get a lot of blockquotes
[16:33]
gac410I tried the moxicode fiddle page to test the new version. Pasted in the topic with the broken blockquotes. It seemed to work a bit better until it crashed. But my attempt at running TMCE 3.5 with foswiki failed- they changed the tmce plugin api.
What are your thoughts on actually releasing Wysiwyg 1.1.10, and updated TMCE for production extensions. I think it fixes more than it breaks.
The complete loss of whitespace on 1.1.5 is a huge issue IMHO
(On 1.1.5 TMCE generates empty spans to protect the whitespace. TMCE removes empty spans. Doh...
Sorry... Wysiwyg generates empty spans, tmce removes them.
The other thing I could do is change <blockquote> blocks into "Protected blocks". So they they are treated more like verbatims by tmce. But given that they work most of the time, and only fail when html markup gets complicated, I'd say no.
[16:35]
ArthurClemensI agree
and no big problems as far as I can see
[16:42]
gac410okay. great. thank. [16:43]
ArthurClemenshmm, I cannot edit links [16:46]
gac410No? Put cursor in link and press the sideways 8 link button? [16:46]
ArthurClemensok, I can edit them if I have the pointer inside
not if I select the link test
[16:46]
gac410Oh... okay good. [16:46]
ArthurClemenstext
which is unexpected
[16:46]
gac410Right, not sure why tmce seems to work that way. That's an upstream bug I guess.
The link handling should hopefully be much better with the new Wysiwyg. All linking text should generate real <a> html links for tmce to edit. and round-trip back to TmL [[]] links if supported. noautolink and * Set NOAUTOLINK, ! and <nop> escaping should all be honored.
The only thing that is missing, is if you change autolink or escapes while in TMCE, it takes a save/edit cycle for the changed link status to be recognized in the editor.
The only link type rendered as stylized non-linking markup is the old [[Spaced wiki word format]] style link.
[16:47]
ArthurClemenson http://www.tinymce.com/tryit/full.php you can select the full link text AND edit it [16:52]
gac410Probably a newer version. We are at 3.4.9, 3.5 is out.
But I could not get 3.5 to work. The foswiki plugins (edit tml for ex.) don't function.
[16:52]
ArthurClemensah [16:54]
gac410From what I could see in release notes, they appear to have changed their API [16:55]
ArthurClemenshard to find [16:57]
gac410yeah. I tried it, it didn't work, so I figured that could wait for 1.2. I wanted to get the 1.1.5 issues fixed asap.
Either that or it was a beta bug ... I last tested 3.5b3 ... didn't have time to dig back into it. The vast majority of the 1.1.5 issues were caused by the "improvements" to whitespace handing in WysiwygPlugin.
[16:57]
***lastcoolnameleft has left [17:10]
.......................................... (idle for 3h26mn)
gac410ArthurClemens: I think in looking at various posts, pressing "return" is expected to create a new element of whatever you are in. Paragraph / new Paragraph. List item / New list item. so blockquote -> new Blockquote is consistent, if maybe unexpected behavior.
Ensuring that the contents of a blockquote is a paragraph seems to resolve things. but it does cause an extra line to appear. So I don't think it's a desirable behavior.
Verbatim blocks had the same behavior, but the HTML2TML process will merge consecutive verbatims.
[20:36]
ArthurClemensplaying on http://www.tinymce.com/tryit/full.php - enter creates <p>s inside the same blockquote [20:40]
foswiki_irc7if I'm doing a query search what's the best way to search if a specific form contains a specific field that is blank? "FormName.Formfield= ' '" is what I'm thinking but it doesn't work. [20:43]
gac410But it starts out with an initial p. Use HTML button to actually create <blockquote>asdf</blockquote> and you get the split behavior
ArthurClemens: So the difference, when you create an initial blockquote in wysiwyg, you get <blockquote><p>whatever</p></blockquote> If it comes from native TML you get <blockquote>whatever</blockquote>
Of course Wysiwyg converts <p>s to blank lines So it just appears as a blank line after the <blockquote...>
[20:43]
ArthurClemenshm [20:48]
gac410I've got a hack that always creates a <p></p> container for the blockquote contents. ... but the blasted blank line shows up. we don't have any class that says "eat this <p> please" [20:48]
ArthurClemensJani_H: did you check QuerySearch? [20:48]
Jani_HArthurClemens: I did but I can't seem to find out how to tell the query to only find blank fields
actually if i can do it with a formatted search that would be helpful for me.
[20:51]
ignore my comment about formatted search. creating nice output in query search seems easy enough. [21:00]
ArthurClemensJani_H: it looks like this gives you the topics with empty fields:
"value!='*'"
[21:06]
Jani_HArthurClemens: Thanks - it seems to be giving me every topic even if it doesn't include a form or formfield but I think I can narrow down the search using Topics=" " [21:13]
ArthurClemensI don't think you can get a list of field names from that [21:14]
Jani_HI'm using the autoincrementing feature when creating topics. The topic names I want to search are all DesignRequest##### [21:16]
gac410I wonder if you could use the length( ) operator to check the length of value ... not sure of syntax though. [21:19]
Jani_Hgac410: I was heading towards learning about %CALC% but hopefully I can get what ArthurClemens suggested to work.
The Querysearch provides an example of: length(fields[NOT lc(attributes)=~'h']) - the number of fields that are not hidden
but I'm not sure how to manipulate that into what I would like.
[21:20]
gac410yeah I was looking at that, puzzling it over as well. [21:22]
Jani_HArthurClemens: it seems that "value!='*'" also returns fields that are not blank :( [21:23]
ArthurClemensah, it finds topics without a form [21:24]
Jani_Hyes and it also returns topics that have the formfield that is not blank :( [21:25]
ArthurClemensdoesn't seem so useful indeed [21:25]
Jani_HMy goal was to search for fields that are not assigned but I think I'll go ahead and just add "Unassigned" as a value when I create every form. [21:28]
ArthurClemenstheoretically you could use FormFieldListPlugin, but it doesn't let you find empty values either
I will see if I can make a quick fix
[21:37]
gac410pharvey is on ... any ideas paul - how to query for an "empty" field. I'm sure that there must be a solution for something simple like that. [21:39]
DavidMarshalli've got a topic with a CalendarPlugin on it
the table has class="calendar May 2012" in it
and the page loads calendar-system.css (from JSCalendarContrib)
so the table, which is in classes calendar, May, and 2012
picks up the display:none from calendar-system.css
i have other pages with %CALENDAR{ ... }% on them
not sure why some are hitting calendar-system.css and others are not
[21:45]
Jani_Hwhen editing a form is it possible to prevent specific usergroups from editing specific fields?
I'm working on a form that tracks requests. The form fields are initially filled out with an HTML form by the requester. Then the intent is to have the boss go in and assign someone to complete the request.
I'd like the original requester to also be able to go into the form and make corrections if necessary but also want them to be unable to modify the fields that the boss should only have the authority to assign.
[21:58]
ArthurClemensyou cannot set access permissions per field [22:04]
Jani_HArthur: thanks. I'll go about making an HTML form for editing and base available fields on user permissions unless there's an obvious better way [22:07]
ArthurClemensthe only way I know is to hide the original topic (to which both groups would have access) and create a html form for each user group
FlexFormPlugin could come in handy
[22:07]
Jani_HThanks. I'll have a look at the plugin. [22:08]
ArthurClemensotherwise split up in 2 data forms
so each topic would have 1 additional topic with boss data
[22:08]
Jani_HArthurClemens: Thanks for the insight. I think I'll try the additional topic approach first. [22:11]
..... (idle for 22mn)
gac410DavidMarshall: I have no idea about your specific issue, but you might try disabling other plugins. Sometimes plugins can interact with each other and cause stuff to not be rendered. See Foswiki:Support.Faq68 [22:33]
FoswikiBothttp://foswiki.org/Support.Faq68 [ How can I determine which plugin might be causing me an issue ] [22:33]
gac410Also if things are inconsistent, and you are using persistent perl, try running the same pages under CGI. That can make a difference. [22:33]
....... (idle for 33mn)
GithubBot[foswiki] foswiki pushed 1 new commit to Release01x01: http://git.io/1Pvt5w
[foswiki/Release01x01] Item11880: remove unexpanded TML line - ArthurClemens
[23:06]
***GithubBot has left [23:06]
FoswikiBothttp://foswiki.org/Tasks/Item11880 [ Item11880: Print view shows unexpanded TML line ] [23:06]
GithubBot[foswiki] foswiki pushed 1 new commit to master: http://git.io/5CDuVA
[foswiki/master] Item11880: remove unexpanded TML line - ArthurClemens
[23:07]
***GithubBot has left [23:07]
..... (idle for 21mn)
BabarArthurClemens: another PDF plugin?!
we only already have like 25... ;)
[23:28]
ArthurClemensyes, the other ones crash on me
because they don't render css3
it seems that htmldoc is not that up to date
[23:28]
Babarprince doesn't? [23:30]
ArthurClemensis not free [23:30]
Babarwhat did you use btw?
I didn't even check
[23:30]
ArthurClemenswkhtmltopdf
from http://code.google.com/p/wkhtmltopdf/
[23:31]
GithubBot[foswiki] foswiki pushed 2 new commits to master: http://git.io/U3pLpA
[foswiki/master] Item11881: first release - ArthurClemens
[foswiki/master] Item11881: correct plugin name - ArthurClemens
[23:32]
***GithubBot has left [23:32]
FoswikiBothttp://foswiki.org/Tasks/Item11881 [ Item11881: Create PdfPlugin ] [23:32]
ArthurClemensc'mon let me upload that plugin
ArthurClemens hates 500s
[23:41]
gac410Upload with trunk!
And make sure there is no edit lock held.
[23:41]
***gac410 has left [23:45]
ArthurClemenslet me first upload without attachments
it falls over a pdf
[23:46]

↑back Search ←Prev date Next date→ Show only urls(Click on time to select a line by its url)