#foswiki 2012-05-31,Thu

↑back Search ←Prev date Next date→ Show only urls(Click on time to select a line by its url)

WhoWhatWhen
GithubBot[foswiki] foswiki pushed 3 new commits to Release01x01: http://git.io/nR0Xsw
[foswiki/Release01x01] Item11814: Remove url entity decode. - GeorgeClark
[foswiki/Release01x01] Item11906: Avoid corrupting links - GeorgeClark
[foswiki/Release01x01] Item11906: Fix linking, ready for release. - GeorgeClark
[01:04]
***GithubBot has left [01:04]
FoswikiBothttp://foswiki.org/Tasks/Item11814 [ Item11814: HTML2TML breaks hrefs with URI encoding ]
http://foswiki.org/Tasks/Item11906 [ Item11906: Wysiwyg badly breaks MACRO variables ]
[01:04]
gac410Anyone who has updated to the recent Extension or Extension/Testing versions of WysiwygPlugin, I've uploaded a new release to Foswiki:Extensions.WysiwygPlugin .. hopefully the link corruption issues are fixed. [01:11]
FoswikiBothttp://foswiki.org/Extensions.WysiwygPlugin [ WysiwygPlugin ] [01:11]
gac410howdy pharvey
I just uploaded 1.1.12 of WysiwygPlugin ... hopefully the link issues are all fixed.
[01:17]
pharvey_great stuff. I think your fix looks good. [01:22]
gac410Great. Thanks. I just installed it on foswiki.org.
grrr... cell phones. (Did you ever get internet?)
[01:23]
pharvey_I did, after almost 7 weeks [01:24]
gac410wow. Torture [01:24]
pharvey_four applications to the incumbent telco were rejected, but one of them was my ISP's
fault
The incumbent doesn't tell the other ISPs what equipment is available to the customer, so they just keep applying for various configurations until one of them sticks. When they privatized Telstra, the competition guidelines required that Telstra should action these applications "within two weeks", so of course... each application takes two weeks
[01:25]
gac410Yeah the telcos can be really tough to deal with. [01:28]
.............. (idle for 1h7mn)
***chriswerry has left [02:35]
.............. (idle for 1h6mn)
gac410 has left [03:41]
................................. (idle for 2h42mn)
JulianLevensSvenDowdeit: I've rejected my own XyzStore proposal, but I'd like more feedback on AttachmentVaults SVP [06:23]
.......................... (idle for 2h7mn)
***ChanServ sets mode: +o OliverKrueger
OliverKrueger sets mode: +oooo SvenDowideit JulianLevens CDot AndreU
[08:30]
........... (idle for 51mn)
MichaelLorI do track about 1000 topics with WorkflowPlugin in a process which repeats ervery year. Is there a simple way to reset all topics to the inital state?
Just to remove the META:WORKFLOW lines from the txt-files does not do the trick, I need to edit & save the topic to get the effect.
[09:23]
JulianLevensMichaelLor: Do you mean that when you view a topic it does not reflect the initial state, or when you perform a query you cannot find the topics in the initial state? [09:37]
OliverKruegerMichaelLor: maybe (just guesing) WFP uses the caching of DBCache. If so, you may want to clear/rebuild those caches. (remove the DBCache folder below the working/ directory). [09:42]
MichaelLorJulianLevens: I can find the topics with a search - searching for all topics without the META:WORKFLOW lines. The topic shows the old state before the txt file edit.
A query of the WORKFLOW state also shows the old state.
[09:46]
OliverKrueger?refresh=dbcache
Maybe WFP has its own caching?!
[09:47]
MichaelLorOliverKrueger: There is no DBCache directory below working, so I think there must be some kind of caching in WFP. [09:49]
JulianLevensHave you tried changing the META:WORKFLOW to reflect the initial state rather than removing them?
I'm at an earlier version but WFP does not have it's own caching, and looking on foswiki.org for the latest info about WFP I cannot anybody has added caching
Therefore, whilie it does look like a potential caching issue, but if so I would be looking for a generic cache, not a WFP specific one
[09:52]
OliverKruegerI cannot see any caching either...
in WFP
[09:55]
JulianLevensAnother possibility is whether WFP in the absense of META:WORKFLOW looks at the latest META:WORKFLOWHISTORY or similar [09:56]
MichaelLorJulianLevens: It's the same if I add a META:WORKFLOW line with the name of the inital state. I deleted all lines from WFP, so there is no history info in the txt any more.
I also touched txt,v
There is no cache installed in foswiki, I don't believe this could be a webserver cache or something.
[10:03]
JulianLevensDid you try with a ?t=454634868 url parameter [10:06]
CDotWFP does not do any cacheing [10:10]
MichaelLorJulianLevens: Does not change anything. Is this parameter requesting a special time or revision? [10:11]
CDotit does, however, use the WORKFLOWHISTORY [10:11]
MichaelLorCDOT: There is no WORKFLOWHISTORY anymore in the txt files [10:11]
CDothave you reset the META:WORKFLOW to the initial state? [10:11]
MichaelLorI tried to remove all lines from WFP and also tried to set META:WORKFLOW to the inital state. If I reload the page (also with another browser), I get the old state. If I edit & save, I get the new state. Confusing. [10:13]
***nick_ has left [10:14]
CDotstrange. Sounds like a cache problem, for sure. Removing the worflow meta tags should work.
CDot just checked the code and WFP does not read any part of the topic except the latest (.txt)
^part^version
it does, however, have a cache......
y, if you are running with an accelerator (e.g. fcgi) then modifying the .txt file won't work unless you restart the server
[10:14]
JulianLevensCDot: If the WFP cache in perl memory? [10:23]
CDoty [10:23]
***ChanServ sets mode: +o Babar [10:30]
MichaelLorHm, stopping and restarting apache did not do the trick :-(, but it's pure cgi anywhere. [10:30]
CDotMichaelLor: well, the WFP cache is in memory, so there's no way it can persist between sessions then [10:31]
...... (idle for 28mn)
MichaelLorWhich parameter is used to show meta information in the browser? [10:59]
JulianLevensraw=debug [11:02]
..... (idle for 20mn)
MichaelLorI poked a little bit around with my WFP problem: If I delete the txt,v history file the topic is shown correct. Maybe my WFP (1.12.5, $Rev: 13783 (2012-01-22) $) has a problem here.
Nope, 1.12.7 has the same behaviour.
If I move the txt,v file back, the old state is shown again: Maybe I found a bug here?
[11:22]
Can I use the save script on command line to force a save cycle? [11:37]
JulianLevensy [11:39]
.... (idle for 17mn)
pharveyMichaelLor: what version of Foswiki? We recently fixed .txt,v vs .txt meta edge-cases in ~1.1.4 or 1.1.5
(or was it 1.1.3, I forget)
[11:56]
AlexanderStHi there, i have a short question regarding the WebStatistics: Is it possible to cumulate the whole "wiki statistics" within a topic in an easy way? [12:00]
...what i mean is to cumulate all WebStatistics within one topic... [12:06]
MichaelLorpharvey: foswiki 1.1.4 [12:10]
......... (idle for 40mn)
pharveyMichaelLor: sounds like Item10993 but that was fixed in 1.1.4 [12:50]
FoswikiBothttp://foswiki.org/Tasks/Item10993 [ Item10993: FORMFIELD does not read values from txt file ] [12:50]
..... (idle for 20mn)
MichaelLorI don't know how WFP reads his values exactly, I'm going to use a shell script, which uses foswikis save command to update all topics. [13:10]
jasthmm, when running extensions installers from the console, it looks like it's not possible to pass a username/password for the extensions repository. are there any plans to change that? or is there a semi-easy workaround? [13:17]
pharveyjast: afaik that's configured via configure
I could be wrong
SvenDowideit would know (or gac410, or cdot)
g'night
[13:24]
***ChanServ sets mode: +o OliverKrueger [13:34]
.... (idle for 15mn)
jastyeah, but not for installers run from a terminal :) [13:49]
in other news, I just got a perl taint error in VC/Handler.pm, in the open call in saveFile [14:02]
MichaelLorI filed Item11914 on my WFP problem [14:10]
FoswikiBothttp://foswiki.org/Tasks/Item11914 [ Item11914: WorkflowPlugin reads state from txt,v file after editing the txt file ] [14:10]
ArthurClemenswow, 45 people+bots in the channel [14:16]
***OliverKrueger sets mode: +oooo Lynnwood ArthurClemens AlexanderSt terceiro [14:17]
Babaryeah impressive [14:17]
OliverKrueger:) [14:17]
Babarwe're gaining momentum :)
or clones
[14:17]
OliverKruegertime to fork. ;) [14:17]
jastmore impressive if someone would fix all my problems ;) [14:17]
GithubBot[foswiki] foswiki pushed 1 new commit to master: http://git.io/tu6lmw
[foswiki/master] Item11913: minor doc fix: - OliverKrueger
[14:19]
***GithubBot has left [14:19]
FoswikiBothttp://foswiki.org/Tasks/Item11913 [14:19]
Babarjast: perl taint error?
paste it here
cause we got rid of all of them, so it's surprising
[14:25]
jastthis seems to be in 1.1.5
hang on a sec
http://dpaste.org/7e8T1/
it's particularly interesting because this is the first installation I've ever had this happen in
[14:27]
Babarthat's 1.1.5 you said? [14:33]
jastyes... Foswiki.pm (Version: Foswiki-1.1.5, Tue, 10 Apr 2012, build 14595) found
and I'm fairly sure it's straight out of the release tarball from sourceforge
[14:33]
Babarweird... [14:37]
jasttell me about it [14:38]
Babarwe could try something...
in lib/Foswiki/Store/VC/Handler.pm
[14:39]
jastthat sounds good
my first thought was just randomly dragging it through untaintUnchecked. :}
[14:39]
Babarin _controlFileName ... even though that sounds totally silly
just before the return $fn, try to untain it
like: return ($_ =~ /(.*)/)[0];
sorry
like: return ($fn =~ /(.*)/)[0];
[14:40]
jastyeah, that eliminates the error [14:45]
Babarok
now let's figure out how this file can be tainter :)
*tainted
[14:47]
jasthmm, seems like I spoke too soon, the error seems to show up somewhere else, too
but same cause, probably
[14:48]
Babaryes. THat's normal
if the file is tainted, then it will blow up anyway
[14:48]
jastyeah, found where it's coming from [14:49]
Babarsome plugin? :) [14:49]
jastno, I mean the second instance of the error
I still have no idea what causes the whole thing
[14:50]
Babarah
then please...
remove the hack
[14:50]
jasteverybody loves removing hacks! :) [14:51]
Babarand then we should just enable ASSERTS
you're using apache? cgi?
[14:51]
jastI don't really think any plugin is messing with the editing flow (other than an alternative WYSIWYG editor, but that shouldn't influence leases etc.)
apache, cgi, yeah
[14:52]
Babarthen edit your bin/setlib.cfg and uncomment $ENV{FOSWIKI_ASSERTS} = 1; [14:52]
jastyeah, the $web (at least) is tained in Prefs.pm -> loadSitePreferences (line 378)
+t
[14:57]
no idea why that is happening now and not before [15:03]
Babarweird
no funny web name?
nah, it looks like Main :)
but maybe something is now generic
[15:08]
........ (idle for 36mn)
CDottaint errors can be caused if {UseLocale} is enabled, so first thing to try is disabling that [15:47]
jastwon't that make UTF-8 explode around me or something?
anyway, I'll keep it in mind for tomorrow
[15:47]
CDotno, shouldn't. Some sort orders may be a bit.... strange, but nothing should explode. [15:53]
jastright... I'll give that a go then. thanks.
I suppose {UseLocale
} breaking untainting isn't intentional, though? :)
[15:58]
..... (idle for 23mn)
CDotit's a known problem with locales in perl. Not something FW can control. [16:22]
Babarhum, in can, but it's a real pain :)
basically, when you use locales, then every regex class is tainted
so if you use \w, \s, etc... to try and untaint a string, it won't work
worse, it will taint the result even if the first string wasn't tainted
[16:28]
PsychoTrahehillll, is there a best practice to profile foswiki rendering/transport?
seems I have a terminal problem sorry
[16:40]
................................................. (idle for 4h3mn)
***nick_ has left [20:44]
....................... (idle for 1h52mn)
GithubBot[foswiki] foswiki pushed 1 new commit to Release01x01: http://git.io/lPA6RQ
[foswiki/Release01x01] Item11917: Update simplemodal to 1.4.2 - ArthurClemens
[22:36]
***GithubBot has left [22:36]
FoswikiBothttp://foswiki.org/Tasks/Item11917 [ Item11917: Update simplemodal to 1.4.2 ] [22:36]
GithubBot[foswiki] foswiki pushed 1 new commit to master: http://git.io/RcFrrw
[foswiki/master] Item11917: Update simplemodal to 1.4.2 - ArthurClemens
[22:37]
***GithubBot has left [22:37]
..... (idle for 22mn)
ArthurClemensit's just impossible to upload an extension to f.o.
the server bails, after a long time
[22:59]

↑back Search ←Prev date Next date→ Show only urls(Click on time to select a line by its url)