#foswiki 2012-06-17,Sun

↑back Search ←Prev date Next date→ Show only urls(Click on time to select a line by its url)

WhoWhatWhen
bailey86actually - i'm having problems running the configure script - how can i run this script? [00:26]
Babaryou go to bin/configure? :) [00:31]
bailey86ok - thanks - needed to check - my normal login as admin is not working
thanks - i needed to log in twice
[00:36]
on the secondary copy of the site the admin login is not working to allow me to run the configure script - how do i reset the admin login/password? [00:49]
gac410bailey86: Is it a http auth prompt? Need to check how configure script is protected in your apache configuration [00:51]
bailey86i get an http auth prompt
does using bin/login?sudo=sudo help or make any sense?
[00:51]
gac410So that is controlled either by your apache configuration, or the bin/.htaccess file ... depends on how your server is configured. We don't supply a "standard" way to protect configure.
no - completely unrelated.
bin/login ... for the sudo login, uses the password defined in LocalSite.cfg ... originally saved from configure.
But access TO configure doesn't use that password.
Do you have access to your apache configuration?
[00:52]
bailey86yep [00:53]
gac410Look for the block labeled FilesMatch "configure.*" [00:54]
bailey86actually - i don't think i've run 'configure' yet - this foswiki is a secondary copy - and the data/pub files are copied from the live server....
so no admin/configure password has been set yet
will look for the block
[00:55]
gac410In that block, it will generally specify which IP addresses can access configure, and which users can access
Allow from <ip addresses> Require user someadminuser
[00:56]
bailey86found the FilesMatch block
just checking it
[00:56]
gac410It might also specify the Auth user file. (or that will be specified in the directory block above) [00:58]
bailey86ok - i'll add one of the wiki users to the filesmatch block [00:58]
gac410Yeah, either that or add your IP to the "Allow from" statement. [00:59]
bailey86bingo - thanks - I added one of the site users wiki names to the filesmatch block and i'm now at the configure page [01:00]
gac410Excellent. [01:01]
bailey86now i need to try to sort out the error with 'Warning: Can't find topic .WebLeftBarWebsList' [01:03]
gac410Hm. That's come up before. [01:03]
bailey86i've upgraded the debian server and the foswiki package was one of the packages upgraded
i googled and think it might be related to the fact that our wiki used to be a Twiki
[01:03]
gac410There should be a topic shipped with Foswiki. System.WebLeftBarWebsList. Ah... See if it is looking for "TWiki.Web... vs. System.WebLeft... [01:05]
bailey86there's mention of it at http://irclogs.foswiki.org/bin/irclogger_log/foswiki?date=2012-03-14,Wed
ok
[01:05]
gac410You upgraded Foswiki by installing the new .deb Packages? [01:07]
bailey86All I get is: Warning: Can't find topic .WebLeftBarWebsList - how do i know if it's calling TWiki. or System. ? [01:07]
gac410From your irc reference. "I believe the issue is that it wouldn't override my existing WebLeftBar.txt which had hardcoded references to a TwikiWeb in it. " [01:08]
bailey86i upgraded foswiki by running apt-get dist-upgrade [01:08]
gac410So check your "WebLeftBar" topic. which %INCLUDES the WebLeftBarWebsList [01:08]
bailey86I can't see any hard-coded references in that file
ok
i've gone to the page foswiki/bin/view/Main/WebLeftBar
[01:08]
gac410Make sure that Foswiki:System.WebLeftBarWebsList?raw=on exists on your system. Then check Foswiki:System.WebLeftBar?raw=on. The last line is the %INCLUDE Compare your topics to those. [01:10]
FoswikiBothttp://foswiki.org/System.WebLeftBarWebsList?raw=on [ WebLeftBarWebsList ] http://foswiki.org/System.WebLeftBar?raw=on. [ WebLeftBar ] [01:10]
bailey86part of this page is %INCLUDE{ "%SYSTEMWEB%.WebLeftBarWebsList" }% [01:10]
gac410Yup. That sounds correct. So make sure that System.WebLeftBarWebsList exists. If not, you can copy the example above to it. [01:11]
bailey86foswiki/bin/view/System.WebLeftBarWebsList?raw=on does exist [01:11]
gac410Is it the Main.WebLeftBar causing the error, or is it some of your other webs? [01:12]
bailey86and contains * *%MAKETEXT{"Webs"}%*
%WEBLIST{" * <span style=\"white-space:nowrap\"><a href=\"%SCRIPTURLPATH{"view"}%/$name/%HOMETOPIC%\"><img src=\"%ICONURL{web-bg}%\" border=\"0\" alt=\"\" width=\"16\" height=\"16\" style=\"background-color:%$markerVAR{\"WEBBGCOLOR\" web=$qname}$marker%\" />&nbsp;<nop>$indentedname</a></span>"}%
[01:12]
gac410Yeah. MAKETEXT is just how we ship translated topics in other languages. [01:13]
bailey86System.WebLeftBarLeft - does not exist [01:13]
gac410System.WebLeftBarLeft ??? It's just System.WebLeftBar or System.WebLeftBarWebsList [01:14]
bailey86System.WebLeftBar does not exist - what do i paste into it? [01:14]
gac410This is what ships with Foswiki: http://foswiki.org/System/WebLeftBar?raw=on [01:15]
bailey86not fixed yet - i should have said - the left web bar shows fine when i'm at foswiki/bin/view/Main/WebHome
but the left web bar does not show when i click on a web
[01:20]
gac410Okay. So each web probably has it's own WebLeftBar. Can you look at the contents of Whatverweb/WebLeftBar?raw=on (ie for a web that is not working) [01:21]
bailey86i've created the WebLeftBar page
ok - will look
ah - looks like the issue - the web's individual WebLeftBar contains the line
%INCLUDE{"%IF{"context can_login" then="%TWIKIWEB%.WebLeftBarLogin" else="<nop>"}%" warn="off"}%
* <b>[[%INCLUDINGWEB%.%HOMETOPIC%][ %ICON{"home"}% <nop>%MAKETEXT{"[_1] Web" args="%INCLUDINGWEB%"}%]]</b>
* [[%SCRIPTURLPATH{"view"}%/%BASEWEB%/WebTopicCreator?parent=%BASETOPIC%][ %ICON{"newtopic"}% %MAKETEXT{"Create New Topic"}%]]
* [[WebTopicList][ %ICON{"index"}% %MAKETEXT{"Index"}%]]
* [[%INCLUDINGWEB%.WebSearch][ %ICON{"searchtopic"}% %MAKETEXT{"Search"}%]]
* [[WebChanges][ %ICON{"changes"}% %MAKETEXT{"Changes"}%]]
* [[WebNotify][ %ICON{"notify"}% %MAKETEXT{"Notifications"}%]]
* [[WebStatistics][ %ICON{"statistics"}% %MAKETEXT{"Statistics"}%]]
* [[WebPreferences][ %ICON{"wrench"}% %MAKETEXT{"Preferences"}%]]
---
%INCLUDE{ "%TWIKIWEB%.WebLeftBarWebsList" }%
the last line - TWIKIWEB etc - i assume that's the problem?
[01:21]
gac410Okay... So in your SitePreferences, * Set TWIKIWEB = System and that should fix it.
(3-spaces, asterisk, Set ... )
[01:24]
bailey86ok - are SitePreferences at: foswiki/bin/view/Main/WebPreferences [01:25]
gac410I thought that the TwikiCompatibilityPlugin would handle some of this automaticallly, but maybe not
No. It's Main.SitePreferences
[01:26]
bailey86thanks - just going to foswiki/bin/view/Main/SitePreferences [01:26]
gac410That is the global settings for the site. It overrides the defaults in System.DefaultPreferences (A shipped topic, so you should not update that one)
bailey86: sorry, I'm on a socks proxy over a cell phone connection. ... thing's are not very reliable.
[01:26]
bailey86Thanks gac410
So the rough answer is:
Create a System.WebLeftBar page with content from http://foswiki.org/System/WebLeftBar?raw=on
In foswiki/bin/view/Main/SitePreferences add
* Set TWIKIWEB = System
(don't forget the starting 3 spaces)
to the end
Thanks again gac410 - maybe there is a wiki page I could add this to - will look tomorrow
[01:31]
gac410Okay ... good luck with it. [01:33]
bailey86thanks - knacked for one night - it's 0230 here - catch you later [01:34]
....... (idle for 31mn)
***VickiBrown has left [02:05]
.................. (idle for 1h27mn)
pharveyDidn't realise there was an apache 2.4 [03:32]
............ (idle for 55mn)
***gac410 has left [04:27]
............................................................................................................................................ (idle for 11h37mn)
bailey86Thanks again to gac410 - for reference - anyone with the 'Warning: Can’t find topic .WebLeftBarWebsList' problem can be fixed by only adding the ‘ * Set TWIKIWEB = System’ to the site preferences - I've blogged it here http://www.freewayprojects.com/2012/06/foswiki-error-warning-cant-find-topic-webleftbarwebslist/ [16:04]
............... (idle for 1h10mn)
***zelazny.freenode.net sets mode: +o ChanServ [17:14]
............... (idle for 1h14mn)
ArthurClemenshaven't seen this interesting view before: http://trunk.foswiki.org/System/WebHome
that is a lot of SVN numbers
[18:28]
..... (idle for 22mn)
***Cervator has left [18:50]
..................... (idle for 1h41mn)
GithubBot[foswiki] foswiki pushed 1 new commit to master: http://git.io/WqES_g
[foswiki/master] Item11891: Complete example; fix for multiple grids on same page. - KipLubliner
[20:31]
***GithubBot has left [20:31]
FoswikiBothttp://foswiki.org/Tasks/Item11891 [ Item11891: Make SqlGridPlugin CRUD forms more generic ] [20:31]
........................... (idle for 2h14mn)
GithubBot[foswiki] foswiki pushed 1 new commit to master: http://git.io/tVqibw
[foswiki/master] Item11891: fix commas - KipLubliner
[22:45]
***GithubBot has left [22:45]
FoswikiBothttp://foswiki.org/Tasks/Item11891 [ Item11891: Make SqlGridPlugin CRUD forms more generic ] [22:45]
...... (idle for 28mn)
gac410Hm. Re Foswiki:Support.Question1111 it would be a pretty simple enhancement to add a $Foswiki::cfg{Htpasswd}{ManageEmails} so that users could force the old style TopicUserMapping email address management. [23:13]
FoswikiBothttp://foswiki.org/Support.Question1111 [ Non-secret emails not working ] [23:13]
GithubBot[foswiki] foswiki pushed 1 new commit to master: http://git.io/CBGefg
[foswiki/master] Item11891: bump SqlGridPlugin.pm for release - KipLubliner
[23:15]
***GithubBot has left [23:15]

↑back Search ←Prev date Next date→ Show only urls(Click on time to select a line by its url)