#foswiki 2012-08-03,Fri

↑back Search ←Prev date Next date→ Show only urls(Click on time to select a line by its url)

WhoWhatWhen
***Cervator has left [00:18]
...................... (idle for 1h49mn)
kip has left [02:07]
kip3fHello, I'm playing with templates
trying to disable buttons if not logged in,
%TMPL:DEF{"topicactionbuttons"}%%IF{"context authenticated" then="$percentTMPL:P{\"topicactionbuttons\"}$percent"}%%TMPL:END%
... that doesn't work
I found pharvey's comment from June 8th, but I'm not quite clear about it:
http://irclogs.foswiki.org/bin/irclogger_log/foswiki?date=2012-06-08,Fri&sel=8#l4
[02:17]
eh, I 'solved' the problem but it's very inelegant
http://pastebin.com/1yDMrwCU
[02:32]
gac410kip3f: I think it's done as a conditional template, not %IF. %TMPL:P{context="authenticated" then="activatable_subscribe"}% [02:32]
kip3fhi gac410 [02:32]
gac410hi kp
er. Hi kip3f
(Autocomplete doesnt's also auto-spell-correct-and-complete :)
[02:32]
kip3fthe conditional stuff is applicable for TMPL:P, not TMPL:DEF [02:33]
gac410Right. Don't you want to conditionally expand the edit buttons? [02:33]
kip3fI want to remove the buttons at the bottom if not logged in [02:34]
gac410Right. So expand the buttons only when authenticated. [02:34]
kip3fbut I couldn't figure out how to do it, without having to copy / paste to the original definition [02:34]
gac410Hm. I'd have to think about it and look through the template structure. Cant' keep my eyes open. Long day :( [02:37]
kip3fdon't worry about it to much, I solved my problem
even though I don't like the solution
did you see the pastebin URL?
I just redefined the whole patterntopiccontents
using the conditional P
[02:37]
gac410yeah. That works :) [02:38]
................................................................................................................. (idle for 9h24mn)
foswiki_irc2Hello there! I have a quick question about names of macro parameters.
I have pairs of the form param!="value", and when I try to get them from the params reference of the handler, they do not seem to be parsed properly.
Is there any restriction about what chars can be used in the names?
[12:02]
.... (idle for 16mn)
flexibeastYou have exclamation marks in the param names? [12:19]
CDotfoswiki_irc2: IIRC the set of characters is limited by the URL protocol, but I can't remember offhand what the set of characters is. [12:23]
kip3ffoswiki_irc2: the keys must have characters that perl considers 'normal word characters'
[0-9a-zA-Z_]
[12:24]
foswiki_irc2They are passed in the _RAW parameter, there the string looks just as it was writen in the wiki. The problem occurs when I try to query the $params for the parameters.
Seems that the ! breaks the parsing in that Attr function if i remember correctly
Is there any way to get around this?
[12:25]
kip3fsounds like you are trying to create your own 'little language'. you could do something like %FOO{"param!='value'"}% - use the default parameter
or, you can parse _RAW yourself
and do whatever you want with it
[12:29]
foswiki_irc2alright, thank you! [12:32]
kip3fyou're welcome! [12:33]
........ (idle for 37mn)
Hi, I'm trying to use a plugin that throws and catches Error::Simple. When the error is thrown, somehow Foswiki process keeps on spinning and never returns anything. I can see the same error printed over and over in the log
http://pastebin.com/a787qq5C
this is in the 1.1 branch, bleeding edge
I can see that the 'writeDebug("CAUGHT EX");' line is getting executed
[13:10]
laenGuys.. is there a possibility, maybe by plugin, for anonymous users to have broken links dissapear and just leave the text (plain, unclickable) behind? [13:15]
kip3faha! I tried removing the code that nicely formats the error message
the error message incldues the stack trace which includes the macro calls that CAUSED the error
[13:17]
........ (idle for 37mn)
Hi laen I just recently learned about a setting called NEWLINKFORMAT
you can read about it in System.DefaultPreferences
perhaps you can set it in the WikiGuest topic, maybe that would work
[13:57]
....... (idle for 30mn)
MichaelDaum: I checked in fixes to SqlPlugin, hope that's OK with you [14:28]
MichaelDaumhi kip3f [14:29]
kip3fhi [14:29]
MichaelDaumany bug item? [14:29]
kip3fItem12029 and Item12030 [14:29]
FoswikiBothttp://foswiki.org/Tasks/Item12029 [ Item12029: SqlPlugin database parameter needs improved error handling ] http://foswiki.org/Tasks/Item12030 [ Item12030: SqlPlugin error handling can cause recursive calls to SQL macro ] [14:30]
MichaelDaumnow seen the diff you checked in ... good catch [14:30]
kip3fI didn't catch them ... they caught me :-) [14:31]
MichaelDaumhaha [14:31]
GithubBot[foswiki] foswiki pushed 1 new commit to master: https://github.com/foswiki/foswiki/commit/9b03f5ab7c593e2605d5206065b5b6cdb259ff26
[foswiki/master] Item12029: database parameter needs improved error handling Item12030: error handling can cause recursive calls to SQL macro - KipLubliner
[14:31]
***GithubBot has left [14:31]
MichaelDaumlet me know when you are done. don't forget to update the SqlPlugin.txt changelog incl your credits.
I'll fire an upload then
[14:31]
kip3fok will do [14:32]
MichaelDaum:) [14:32]
kip3fthere is another bug report from DavidKramer
I asked him to try again with the latest, lets see what happens with that
http://foswiki.org/Tasks/Item12018
Item12018
[14:32]
FoswikiBothttp://foswiki.org/Tasks/Item12018 [ Item12018: SqlPlugin generating errors for queries spread across multiple lines ] [14:33]
MichaelDaumstrange one, yes. [14:33]
kip3fit might be related to Item12030 [14:33]
..... (idle for 21mn)
AlexanderStMichaelDaum: Hey Michael, it seams that deleting a topic and re-index with mode=delta doesn´t delete the index entry. The index is getting cleaned only with mode=full. Do you have the same behaviour? [14:54]
MichaelDaumAlexanderSt, hey Alex. checking ..
yes thats correct but it won't show up in the search results
theres a topic exists check
sort of late binding
[14:54]
AlexanderStyes i thought so... [15:00]
MichaelDaumhm no it does delete it not sure why
could be as simple as a missing print STDERR
[15:01]
AlexanderSthmmm....
have to leave...have a nice weekend!
[15:02]
ModAcOstIs there a way to find out in beforeSaveHandler, if the save will create a new revision? [15:08]
.... (idle for 15mn)
jastMichaelDaum: StringifierContrib seems to be missing test/unit/StringifierContrib/StringifierTest.pm (referenced by all the other .pm files in that dir, and in the MANIFEST). at the very least, that makes it impossible to build the extension without errors... [15:23]
MichaelDaumjast, checking it in ... lost in space [15:26]
jastdon't we all sometimes get lost in space :) [15:26]
MichaelDaumchecked in [15:29]
laenI don't! Never been in space :(. [15:29]
jastthanks! [15:30]
GithubBot[foswiki] foswiki pushed 1 new commit to master: https://github.com/foswiki/foswiki/commit/14e540958482e7b7c85d19501c55c24a089ab5a4
[foswiki/master] Item12031: missing file - MichaelDaum
[15:30]
***GithubBot has left [15:30]
FoswikiBothttp://foswiki.org/Tasks/Item12031 [ Item12031: missing base class in unit tests ] [15:30]
............................... (idle for 2h34mn)
***kip3f has left [18:04]
..... (idle for 22mn)
verne.freenode.net sets mode: +o gmc [18:26]
verne.freenode.net sets mode: +oovo julian_work ColasHome FoswikiBot SvenDowideit
verne.freenode.net sets mode: +o Babar
[18:39]
..................................... (idle for 3h2mn)
damasterHELP: I've forgotten something somewhere. I made a copy of my wiki and set it up to be available on the same server as the original. Everything seems to work *except* the translation of userID to WikiName. In the old wiki, it works. In the new wiki, the translation does not occur. Can someone tell me how to debug this problem?? [21:41]
.... (idle for 19mn)
ping? [22:00]
............... (idle for 1h13mn)
gac410damaster: If you check back later in the logs. userid to WikiName is done by the WikiUsers topic .. assuming you are using TopicUserMapping. [23:13]

↑back Search ←Prev date Next date→ Show only urls(Click on time to select a line by its url)