#foswiki 2013-01-14,Mon

↑back Search ←Prev date Next date→ Show only urls(Click on time to select a line by its url)

WhoWhatWhen
gac410MichaLorenz Thanks for the feedback about the version dependency in 1.1.7. I've updated the release notes and download page to make the requirement more obvious. [02:13]
GithubBot[foswiki] FoswikiBot pushed 1 new commit to Release01x01: http://git.io/Tg8AxQ
foswiki/Release01x01 086ba7b GeorgeClark: Item12310: Bigger warning about new dependency...
[02:13]
***GithubBot has left [02:13]
FoswikiBothttp://foswiki.org/Tasks/Item12310 [ Item12310: Documentation updates for 1.1.7 ] [02:13]
SvenDowideit<SvenDowideit> [16:52:22] pharvey, thats what i thought, but there seems to be an interesting twist.
<SvenDowideit> [16:52:24] _allDeveloper means you have a submodule first, then update it, and so you don't get a .git dir in the submodule dir
<SvenDowideit> [16:52:27] whereas (i think?) when you use submodules from pseudo-install that then try to link to svn
<SvenDowideit> [16:52:29] that the submodule link is added afterwards
<SvenDowideit> [16:53:03] but tbh, i am so not sure what is going on, and am also not sure if there are major differences when using different versions of git
i've commited what i think is your approach to git-foswiki
and i've started using it a little
though of course, atm, i'm working on sapstuff
ARGH!
and for the millionth time am getting crashes due to my scalar being a PVIV when the xs demands it only be a PV
stupid mess
[02:23]
pharveyI thought I could get used to win8 [02:27]
SvenDowideitgiggle [02:27]
pharveyit seems jarring no matter how much I use [02:28]
SvenDowideiti was ok, until that x61 developed hw /driver issues
the colour palet seems to flicker between 2 different colour sets
[02:28]
pharveynot a vid. cable thing? [02:29]
SvenDowideittbh, i'm not motivaed to look :)
my new toy is 3-5 days away, and i'm getting hit by sap perl xs details
when i need to have complicated report aggregations working
[02:30]
......................... (idle for 2h0mn)
argh!
perl dualvar
the problem i've been stuck on for 2 years is because of dualvars?
perl is mad.
[04:30]
gac410SvenDowideit: What's the magic formula to get CPAN::version rpm package name. Debian is libversion-perl
Trying to update the SystemRequirements for Foswiki
[04:31]
SvenDowideitthere is none
even in perl its not true
even in debian its not true
if only i could recal the canonical eg :/
[04:32]
gac410Huh? libversion-perl does exist for debian and ubuntu, [04:33]
SvenDowideity, for that simple library
turns out i don't have an rpm system atm
something is very very wrong down in the server rack
[04:33]
gac410Hm. That's not good. [04:34]
SvenDowideitand tbh, i don't care, i've just worked out why i could not progress with the generalised sap reporting tool
but wrt rpm
there was somewhere a web site - a perl one iirc
[04:35]
gac410Using an rpm search tool I found /usr/share/bitbake/org.openembedded.stable/packages/perl/libversion-perl-native_0.6701.bb but I assume that is not right. [04:35]
SvenDowideitthat helped you work out what modules to install [04:35]
gac410Plus 0.6701 is way way too old. [04:35]
SvenDowideitwow [04:35]
http://wikidata.org/wiki/Q93853 [04:41]
...... (idle for 28mn)
harlanhey [05:09]
SvenDowideito? [05:09]
harlan:) [05:09]
..... (idle for 20mn)
GithubBot[foswiki] FoswikiBot pushed 1 new commit to Release01x01: http://git.io/NmOlAA
foswiki/Release01x01 c70e79b GeorgeClark: Item12310: Better dependency info....
[05:29]
***GithubBot has left [05:29]
FoswikiBothttp://foswiki.org/Tasks/Item12310 [ Item12310: Documentation updates for 1.1.7 ] [05:29]
.................... (idle for 1h38mn)
***ChanServ sets mode: +o MichaelDaum [07:07]
..................... (idle for 1h43mn)
foswiki_irc9How to intigrate foswiki to joomla 2.5 , before it was working on Joomla 1.5
I am using joomla user contrib plugin but its support only joomla 1.5
[08:50]
......... (idle for 42mn)
MartinKaufmannHi! What is the recommended way of adding translation strings to locale? I guess editing a language.po file directly is not recommended due to problems when upgrading. [09:33]
.... (idle for 16mn)
jastwe use a patched version of Foswiki::I18N that reads .po files from subdirs of locale/, too [09:49]
FoswikiBothttp://trunk.foswiki.org/System/PerlDoc?module=Foswiki::I18N [09:49]
jastthis feature will be part of 1.2, too [09:49]
MartinKaufmannjast: Sounds like a good idea. But right now, it's not possible to add strings safely? [09:52]
jastI don't see how, unless you patch Foswiki::I18N [09:54]
SvenDowideitjoomla 2.5? wow, i wonder how often they've changed their auth table [09:57]
MartinKaufmannjast: Is this patched version available somewhere? [09:58]
SvenDowideitpharvey am i right wrt how you use submodules? [10:00]
jastMartinKaufmann: good question. I don't really know where we got it from. you *could* try just using the version from trunk with 1.1.x. if that doesn't work, let me know. [10:02]
ModAcOstMartinKaufmann: http://foswiki.org/Development/Enhancei18nArchitecture [10:08]
.... (idle for 19mn)
MartinKaufmannModAcOst: Thanks. Is the attached patch the solution that will be implemented in 1.2? [10:27]
.... (idle for 18mn)
ModAcOstMartinKaufmann: Yes, I believe it is [10:45]
MartinKaufmannModAcOst: OK, thanks. I will test it.
Anyone familiar with the following error?
Foswiki Installation Error
Incorrect format of searchformat template (missing sections? There should be 4 %SPLIT% tags)
[10:49]
....................................................... (idle for 4h32mn)
foswiki_irc9anyone here? need to understand why perl installation of imagemagick is being dumb :P [15:22]
when i try to install imageplugin .... i get that the CPAN dependancies are missing ... ie Graphics::Magick, Image::Magick
running on redhat 6
[15:27]
.................. (idle for 1h25mn)
gac410foswiki_irc9: Image::Magick and Graphics::Magick are somewhat strange modules
They are not actually installed using CPAN, they are built as part of the imagemagic package if appropriate build options are specified.
So for rpm / debian system, there is probably a separate .rpm or .deb that has the perl component, or it might just be installed with the base imagemagick.
[16:52]
I think it's ImageMagick-perl rpm package, but I don't use an rpm based system so I can't really say for sure. [16:58]
foswiki_irc9the thing is... i installed imagemagick and graphicsmagick [16:59]
gac410Babar, I think I've fouled up the version string comparison stuff. Sigh.. This is so damn confusing. [16:59]
foswiki_irc9this is Christy btw... and it just doesnt work hehe [16:59]
gac410foswiki_irc9: I think you want one or the other.
What OS are you running foswiki_irc9
[16:59]
foswiki_irc9i used yum to install em .. but they dont seem to wanna work hmm
redhat 6
[17:00]
Babarhum.. wait
so, you've installed ImageMagick-perl ?
[17:00]
gac410graphicsmagick is a replacement for imagemagick. So I don't think you want both installed, but I'm not sure. [17:01]
foswiki_irc9hmm [17:01]
Babarit's a fork. And I don't know how they package the additional librairies like perl [17:01]
foswiki_irc9when i try to use cpan to install imagemagick ... i get errors and it wont install
in the shell
[17:03]
gac410right, if you install ImageMagick-perl rpm, you should not need to use CPAN to install Image::Magick [17:07]
foswiki_irc9ya hmm
one other error that i get while tryin to install some perl rpms is this "requires libc.so.6 (GLIBC_2.14)"
yum says it doesnt need to update glibc .... but i keep gettin this ... and stuck
[17:08]
gac410googling around a bit, that libc.so.6 says that glibc library (AKA. "libstdc") version 2.1.4 is required.
Seems to be others complaining about that missing version of libc.
[17:17]
foswiki_irc7Hello [17:20]
foswiki_irc9ya : / [17:21]
foswiki_irc7I have a quick question, I hope... When I create a Web in Foswiki, How do I redirect the access denied page to go to a different Web besides the MainWeb? [17:22]
gac410foswiki_irc9 are you trying to install the official red-hat binary rpm of ImageMagick-Perl? That might explain the library issues. [17:22]
foswiki_irc9thats already installed [17:23]
foswiki_irc7No. I created a different WebHome to keep users from the MainWeb. [17:23]
foswiki_irc9that wasnt directed to u :D [17:23]
jasteasy to get confused with all these similar names :O)
you can do "/nick somethingsomething" to choose a different name
[17:23]
ChristyFthere
i forgot the irc commands... feels like forever since i sued it
used
[17:24]
foswiki_irc7Ok [17:25]
gac410foswiki_irc7: hm. Not sure. I think Foswiki:Extensions.HomePagePlugin can make the default page configurable. [17:25]
FoswikiBothttp://foswiki.org/Extensions.HomePagePlugin [ HomePagePlugin ] [17:25]
jastin the end, the error message redirects you to the homepage. if you change that, a bunch of other links will change, too...
I gotta go, though. time to head home.
[17:25]
gac410seeya jast
Babar, My confusion comes from how version compares the _nnn alpha versions. The alpha designator is only "newer" when compared to the *same* version without the _. Ie 1.1.7_1 will be newer than 1.1.71, but not 1.1.7. :(
[17:26]
ChristyFso what i have installed is "ImageMagick" it doesnt have the perl at the end
that was installed a while ago
[17:28]
gac410Right. You need to install ImageMagick-Perl to get the perl bindings.
Babar, so 1.1.7_001 1.1.7_002 as an "alpha" sequence will not compare as older than 1.1.7. It needs to be 1.1.6_001 1.1.6_002 releasing as 1.1.7
I think I've described it correctly now at Foswiki:Development/ReleaseNumbering#Alpha_44_Beta_and_RC_40Release_Candidate_41_versions
[17:29]
FoswikiBothttp://foswiki.org/Development/ReleaseNumbering#Alpha_44_Beta_and_RC_40Release_Candidate_41_versions [ ReleaseNumbering ] [17:31]
ChristyFhmmmmmm
interesting stuff....
[17:40]
........ (idle for 35mn)
i think i am either missing some c library stuff
or i have to recompile the library all together
damn my head is gonna explode lol
[18:15]
gac410You are trying to install ImageMagick-Perl? [18:16]
ChristyFya
i get
[18:16]
gac410If its a lot of output, please use http://pastebin.com [18:17]
ChristyFwell i am on a different machien for irc
hehe
[18:17]
gac410I'm not sure I'll be much help. I don't have anything that's rpm based. [18:18]
ChristyFwell one of the erros is LibImath.so.4 (64 bit) is missing
stuff like that
[18:19]
gac410Unfortunately I have no idea. [18:21]
ChristyFheh its cool :)
just gotta bang away on google :S
[18:22]
jastthat's all any of us ever do, so don't worry ;) [18:33]
............................ (idle for 2h15mn)
ChristyFgeorge
so after a while of fiddling around with some c library stuff
the imagemagick-perl instlal worked
and it finally works now
gotta restart computer
[20:48]
....... (idle for 34mn)
gac410great ChristyF [21:24]
ChristyF:) [21:27]
....... (idle for 32mn)
hmm
is it possible to allow foswiki to retrive an image on the server ... but that file requires svn access atm for a user to see it
[21:59]

↑back Search ←Prev date Next date→ Show only urls(Click on time to select a line by its url)