#foswiki 2013-04-21,Sun

↑back Search ←Prev date Next date→ Show only urls(Click on time to select a line by its url)

WhoWhatWhen
***ChanServ sets mode: +o gac410 [01:33]
ChanServ sets mode: +o pharvey
ChanServ sets mode: +o pharvey
[01:44]
.................... (idle for 1h38mn)
gac410 has left [03:23]
........................................................................ (idle for 5h55mn)
ChanServ sets mode: +o pharvey
ChanServ sets mode: +o pharvey
[09:18]
............................................... (idle for 3h54mn)
ChanServ sets mode: +o pharvey
ChanServ sets mode: +o pharvey
[13:13]
ChanServ sets mode: +o pharvey
ChanServ sets mode: +o pharvey
[13:21]
............. (idle for 1h2mn)
ChanServ sets mode: +o pharvey [14:24]
............... (idle for 1h11mn)
TarboxHi, I need help figuring out why NatSkin isn't displaying the Create New Topic button when you try to go to a page that does not exist. Also, possible red herring, I'm confused by templates. The NatSkinTopicDoesNotExistTemplate includes WebCreateNewTopic, and makes some template definitions that refer to it, but WebCreateNewTopic has some parameters that are provided (overwritten?) in NatSkinTopicDoesNotExist.. What order do those [15:35]
................................ (idle for 2h35mn)
zipperhello - I installed the irc comment plugin from rpm
but it doesn't seem to show up at all in the comment examples
sorry not "irc" lol
it just shows the plain text
[18:10]
in the CommentPluginExampels topic, at the bottom it says "No such template def TMPL:DEF{PROMPT:example}" [18:24]
.... (idle for 19mn)
ugh i can't get this plugin working [18:43]
TarboxI've never used it and I'm new to foswiki in general, but if you haven't already, turn debug on for the plugin. Then you can check your error log for clues. [18:46]
....... (idle for 32mn)
zippersorry got disconnected...where would I enable debugging for the comment plugin? [19:18]
also in the foswiki error log: | 2013-04-21T18:57:25Z warning | Foswiki::Plugins::CommentPlugin::Comment | Could not read template file 'comments' | [19:23]
FoswikiBothttp://trunk.foswiki.org/System/PerlDoc?module=Foswiki::Plugins::CommentPlugin::Comment [19:23]
TarboxDepend on how you installed that, that error might imply you have the wrong permissions on the plugin's files.
May want to make sure they're all set to your web server's user.
Another option is the file's just not there.
[19:24]
zipperok im not sure about permissions
but i know its owned by apache
and the file exists
it is def readable
[19:24]
TarboxTurn on debug by going from your foswiki root to lib/Foswiki/Plugins/YourPlugin/ - There should be one or more .pm modules, you can edit them and look for a debug flag, it's usually near the top. [19:25]
zipperls -l | grep comments.tmpl -r--r--r--. 1 apache apache 160 Dec 2 10:48 comments.tmpl
ok
looking for the plugin directory...
[19:26]
TarboxWell a potential point of confusion is that it's off lib, which is off your Foswiki root. So your path may be Foswiki-1.1.6/lib/Foswiki/Plugins [19:30]
zipperyeah im not seeing it [19:30]
Tarboxpoop [19:30]
zipperits an environmental path?
i'll check in configure
[19:30]
Tarboxgood idea. [19:31]
zipperi guess its not
in general path settings
weird
[19:32]
TarboxI'm sorry, I don't know then. I only got into this a little while ago. [19:34]
zipperi'll do a find for it
ah ok i found it
my path was weird
it was /var/lib/foswiki/lib/Foswiki/Plugins
[19:34]
Tarboxyeah
that's the confusion I mentioned
the root is often foswiki
but the path for plugins is off the root, lib/Foswiki/Plugins
[19:37]
zipperk [19:37]
TarboxSo I suspect 99% of installations have foswiki in the path twice like that. [19:37]
zippermost likely
ok so enabling debugging
im in that file and searched debug
but didn't find anything
do you know what i should search for
[19:38]
Tarboxprint
That's going to be how messages end up in your error log
If it's wrapped in a function you're going to have to look for what enables the function
otherwise it may be used directly an dyou need to uncomment it.
[19:39]
zipperyeah i dont know where to look in there
im going to try google lol
[19:45]
TarboxSorry. [19:47]
zipperfrom seraching, someone else resovled it by re-installed with the tar package [19:52]
.... (idle for 15mn)
tried to run the installer for the comments plugin
but am getting errors
./CommentPlugin_installer -bash: ./CommentPlugin_installer: perl: bad interpreter: No such file or directory
oh
i had to use perl infront
lol
ok that didnt work
i give up for today
if anyone else has suggestions...I'll check the irc logs later
thanks
bye
[20:07]
....... (idle for 32mn)
***ChanServ sets mode: +o gac410 [20:45]

↑back Search ←Prev date Next date→ Show only urls(Click on time to select a line by its url)