#foswiki 2013-11-11,Mon

↑back Search ←Prev date Next date→ Show only urls(Click on time to select a line by its url)

WhoWhatWhen
timleggeHi - Is there anyone around who has gotten solrplugin to work lately? [00:40]
.............. (idle for 1h9mn)
pharveynot lately, sorry. [01:49]
timleggeThe most annoying part is it seems to refuse to write any errors - I can't tell whether it is even being called [01:54]
....................... (idle for 1h51mn)
pharveyCUBICLES SETTING FIRE TO MY SANITY
where are my headphones and bad techno
[03:45]
gac410Need to circulate selected dilbert cartoons
http://search.dilbert.com/comic/Loud%20Howard
[03:45]
[julian]very suitable... :) [03:48]
pharveyhaha
it's more the collective calamity
[03:48]
I keep forgetting ack-grep does perl regexes and not silly grep/pcre regexes [03:53]
......................... (idle for 2h2mn)
***gac410 has left [05:55]
................ (idle for 1h15mn)
ChanServ sets mode: +o CDot [07:10]
pharveyhey wow, since when did NYTProf have this nifty flame graph thingy [07:11]
...................... (idle for 1h49mn)
***ChanServ sets mode: +o MichaelDaum [09:00]
..... (idle for 22mn)
memichi
MichaelDaum_: is there an easy howto for the classification app?
and i have to problem that i lose the session quite often
[09:22]
ah ok found session problem [09:32]
........................................ (idle for 3h16mn)
apfiorottohi. i've just installed foswiki, and tried adding my user to the AdminGroup and it does nothing. what i did is: open the AdminGorup page, logged as admin in "internal admin login" correctly, and tried to add my user in the "adminsitration" section. the page reloads when i click the "add" button but the user was not added to the group.
no errors reported. it just reloads to the original "admingroup" page. any ideas? i've the the instructions and the forum, but i can't figure it out.
[12:48]
............... (idle for 1h12mn)
***ChanServ sets mode: +o gac410 [14:01]
................. (idle for 1h22mn)
foswiki_irc7Hello everyone! Sorry, I am having problem with EditRowPlugin, is there anyone who can help?
The problem is that once I click on the "Edit" button (either edit row or edit table), the row/table is open for editing but all the buttons disappear, i.e. no possibility to save, cancel etc.
I use Foswiki 1.1.8 on Ubuntu 12.04, Foswiki is installed from the source tar.gz
[15:23]
gac410New install or an upgrade? [15:25]
foswiki_irc7fresh install [15:26]
gac410I'll try it here. hold on a bit [15:26]
foswiki_irc7'Javascript editing' seems to work [15:27]
gac410Yes I have the problem here. I'm poking around a bit. [15:32]
tbh I don't know a lot about this plugin. Definitely seems broken though :( [15:40]
foswiki_irc7I posted a question on the support page: http://foswiki.org/Support/Question1377 [15:43]
gac410Yeah I saw that but didn't have any answers. I can confirm that it's broken, and it seems to be broken on 1.1.9-RC2 with the extensions installed from a SVN checkout too.
I'm not sure what to suggest. MichaelDaum_ might know better.
But he appears to be away.
It is also broken on a "trunk" checkout - the future foswiki 1.2.x
[15:46]
Also doesn't render save buttons using Chrome, :( [15:56]
foswiki_irc7It worked for me in 1.1.3 but older version of the plugin (Version: 12047 (2011-06-24) ) [16:00]
gac410I'm running out of ideas - I don't know the plugin well enough. I don't see any javascript errors, no 404's or other server side errors. I'm guessing it's might be a css issue, but I don't really know. [16:02]
foswiki_irc7Crawford Currie is mentioned as the author. Can I ask him directly? [16:02]
gac410Hm... CDot ... are you listening to this? [16:02]
CDotno :-/ [16:02]
gac410:P
On 1.1.8, 1.1.9-RC and trunk, EditRowPlugin doesn't seem to render save buttons after you click the pencil to edit a row
[16:02]
CDotdoes the user have rights to edit the page? [16:04]
gac410well I've recreated it as "admin" so I have rights.
:)
Hm... well I wondered if it was because I was admin and not a regular user. Nope... Fails as a normal user as well.
[16:04]
CDotlatest ERP? Do you have TablesContrib installed? [16:08]
gac410I installed it. Not listed as a dep though I don't think.
Same behavior on trunk.foswiki.org/Sandbox/TestEditTable that I'm seeing on 1.1.8 and 1.1.9-RC2 locally
http://trunk.foswiki.org/Sandbox/TestEditTable
[16:09]
CDotseems to be a CSS problem
the button is definitiely there, it's a foswikiIcon and has the right class. But it's not visible. JQuery changes, perhaps?
[16:11]
gac410Maybe. I've tried the 1.1.8 default 1.8.2, and 1.1.9RC 1.8.3
Let me try an older version
[16:13]
CDotdeffo a jquery-ui problem. When I turn the text-indent off (defined in jquery-ui) the buttons appear.
problem is in patternSkinTheme. It sets a width of "auto" on foswikiIcon, which screws up the jquery-ui icons.
[16:15]
gac410yeah, jquery version doesn't make a difference. I tried 1.7.2 no change. [16:17]
CDotthis is not going to affect only ERP, but anything that uses jquery-ui, I fear [16:18]
gac410hm. That sounds like a 1.1.9 blocker :( [16:18]
MichaelDaumhey guys [16:18]
gac410Hi MichaelDaum [16:18]
CDottry commenting out line 1954 in oub/System/PatternSkinTheme/style.css [16:19]
gac410hm... no such line on 1.1.8 [16:20]
CDotCDot is looking at 1.1.8
sorry, 1.1.9
[16:21]
gac410okay hang on... [16:21]
CDotRelease01x01/PatternSkin/pub/System/PatternSkinTheme/style.css [16:21]
gac410bah... on my 1.1.9 it's been uglified. :P Back to svn [16:22]
MichaelDaumis it a jquery-ui problem or a PatternSkin one? [16:22]
CDotI think it's an old PatternSkin problem. I vaguely recall it.
I *think* I had cured it by finagling the load order, so my CSS dimonated
dominated
so it may be the jquery changes have just opened an old wound
[16:22]
MichaelDaumcan't repro the problem with NatSkin [16:24]
CDotI'm pretty sure that width:auto in PatternSkin is a bad idea
in fact, I'm sure of it :-(
[16:25]
MichaelDaumnow is the chance to fixit
in Pattern
[16:26]
CDotI don't know why it's there [16:26]
gac410CDot: Line 1954? ??? input[readonly]:focus, [16:26]
CDotno, width:auto [16:26]
MichaelDaumhttp://trac.foswiki.org/browser/branches/Release01x01/PatternSkin/pub/System/PatternSkinTheme/style_src.css#L1954 [16:27]
CDotdamn, I have local mods
no, that was just my debug. deffo 1954 (in what Micha just showed)
[16:27]
MichaelDaumand http://trac.foswiki.org/browser/trunk/PatternSkin/pub/System/PatternSkinTheme/style_src.css#L1852 [16:28]
gac410Drats.... No wonder i'm lost - my switch to release11 left me on trunk ... looking again. [16:29]
CDotMichaelDaum: moz-radius? what's wrong with that? [16:29]
MichaelDaumnothing [16:30]
CDotoh, sorry, trunk :-8
so, why the width:auto, I wonder?
ah - because Arthur never used jquery icons
[16:30]
MichaelDaumit is more related to the css resets in pattern [16:31]
CDotof which there are rather a lot :-( [16:33]
gac410Confirm.. That fixes it. [16:33]
CDotso, I guess the question is, if we remove that line in PatternSkin, what breaks? [16:34]
MichaelDaumnothing to be serious [16:35]
CDotit's a pretty basic, low-level thing, affecting all inputs [16:35]
MichaelDaumauto is the default for those elements on a low priority [16:35]
CDotthat's what I understood [16:35]
foswiki_irc7In my case, if I change /pub/System/PatternSkinTheme/style.css from input[type="checkbox"]{width:auto;}select to input[type="checkbox"]select the buttons appear but .. [16:35]
CDotjquery forces 16px, and pattern wipes that back to auto :-( [16:35]
MichaelDaumArthur's rules raise the prio above normal level so overwriting them needs an even stronger prio [16:36]
foswiki_irc7the buttons do not act as expected, i.e. when I push "Save", the changes are not saved. [16:36]
CDotfoswiki_irc7: so what happens? [16:36]
foswiki_irc7the table closes without changes [16:36]
CDotworks for me..... [16:37]
gac410hm... It saved here okay on 1.1.9rc. foswiki_irc7 is JEditableContribPlugin enabled in your config?
When you installed EditRowPlugin, it should have installed JEditableContrib and TablesContrib
[16:37]
CDotit doesn't use JEditableContrib for that edit
that edit is done using a simple text field
[16:39]
gac410Oh... CDot Does EditTablePlugin need to be disabled? [16:39]
CDotno, don;t think so
no, it's not diabled here
foswiki_irc7: what changes did you make to the table? Are there any javascript errors in the browser console? Are there any errors reported in the server logs?
[16:39]
foswiki_irc7I have JEditableContribPlugin enabled and EditTablePlugin disabled [16:41]
in working/logs no errors, nothing what I can see in Chromium. Simple editing, just delete or add one character. [16:46]
CDotWhat about Apache error log? http://foswiki.org/Tasks/Item12132 says something similar (sadly they didn't bother to tell me about the error appearing again)
do you have ActionTrackerPlugin installed?
[16:46]
***gac410 has left [16:50]
foswiki_irc7No, ActionTrackerPlugin is not installed. Apache also does not give any error. Can confirm that in full table editing the situation is the same, i.e. changes are _not_ saved. [16:52]
CDotok, because http://foswiki.org/Tasks/Item12132 is caused by ActionTrackerPlugin, for sure.
so what you are seeing is new. I need more info......
no, red herring.... ATP is fine, I just hadn't run configure since installing it
[16:53]
CDot can't make it fail. Depending on foswiki_irc7 to provide enough information that I can debug.
done a quick check of inputs using icons elsewhere. That widthLauto seems superfluous. MichaelDaum, how can I make my rule take priority? Can I?
[16:59]
MichaelDaumjust remove it from pattern
I dont have it in NatSkin and things are fine
[17:02]
CDotwell, that was obvious. let's just say for a moment that it's in pattern and I can't remove it. Can I override it?
CDot is thinking of existing installs that have the rule there
[17:03]
MichaelDaumyes. add some width:16px !important; in your css [17:03]
CDot!important does nothing. First thing I tried. [17:03]
MichaelDaumwhere did you add it? [17:03]
foswiki_irc7I have also FS 1.1.3 and EditRowPlugin 2.2.5, I created same example table and editing link there looks like: TestEditRowPlugin?erp_active_topic=Sandbox.TestEditRowPlugin;erp_active_table=EDITTABLE_1;erp_active_row=2#erp_EDITTABLE_1_1 [17:03]
CDotin my .css [17:03]
foswiki_irc7while in FS 1.1.8 and latest EditRowPlugin, it is TestEditRowPlugin?erp_topic=Sandbox.TestEditRowPlugin;erp_table=EDITTABLE_0;erp_row=1#erp_EDITTABLE_0_1 [17:04]
CDotnot an exact match to the patternskin rule, though [17:04]
MichaelDaumas there are no other width rules with an !important on it, your !important should overrule every other rule without an !important, even Arthur's. [17:04]
CDotI did .foswikiIcon{width:16px !important; }
CDot tries again with input[type=""]
[17:04]
MichaelDaummake sure you removed the .gz and minified versions of your css
or recreate them whenever your src changes
MichaelDaum added !important to the erp.css using chrome dev tools and voila
tp .erpNoJS_button
^to
[17:05]
CDotyup
CDot was modifying the css on trunk. Shot self in foot.
ok, I'm going to take that on board as a fix to ERP. But it's really a PatternSkin bug IMHO.
[17:08]
MichaelDaumyep [17:10]
foswiki_irc7Sorry, I have to leave. Could you answer to http://foswiki.org/Support/Question1377, please? [17:18]
CDotthat's basically what you just reported here. As I said, there is not enough information to help you further :-(
all I can suggest is you restart your apache server and clear your browser cache (in case it's a caching problem) and try again
[17:19]
foswiki_irc7If you tell me, which info you need, I may watch for it ... [17:21]
CDotanything! server logs, browser console, a detailed description of how to reproduce the problem on a fresh foswiki install. [17:22]
foswiki_irc7GET http://localhost/foswiki/pub/System/EditRowPlugin/ui-icons-famfamfam.png 404 (Not Found) [17:25]
timleggeHi All - I seem to be having issues getting SolrPlugin to work. I am using the solr binary from the http://foswiki.org/Extensions/SolrPlugin and the svn version of the extension
I can connect to the http://localhost:8983/solr and get the admin page - I can also run solrindex for a page without any issues
[17:29]
GithubBot[foswiki] FoswikiBot pushed 1 new commit to master: http://git.io/uqflfA
foswiki/master 4b4b765 CrawfordCurrie: Item12132: workaround for CSS rule ordering problem caused by PatternSkin...
[17:31]
***GithubBot has left [17:31]
FoswikiBothttp://foswiki.org/Tasks/Item12132 [ Item12132: EditRowPlugin is unusable ] [17:31]
timleggeHowever the SolrSearch page does not show anyway to search
anyone know how to force it to show me error or debug?
[17:31]
CDotfoswiki_irc7: well, since that's all the icon images, I'm surprised any part of it worked :-( [17:38]
foswiki_irc8Does anyone know how to get the FormPlugin to save a form to the web its on? [17:39]
CDothmmm. Dunno what is including that. fam-fam-fam.png is *not* part of ERP, it's part of PatternSkin
sorry, part of JQueryPlugin
[17:40]
.................................................................. (idle for 5h29mn)
***ChanServ sets mode: +o Lynnwood [23:11]
.......... (idle for 46mn)
ChanServ sets mode: +o gac410 [23:57]

↑back Search ←Prev date Next date→ Show only urls(Click on time to select a line by its url)