#foswiki 2013-11-12,Tue

↑back Search ←Prev date Next date→ Show only urls(Click on time to select a line by its url)

WhoWhatWhen
***ChanServ sets mode: +o SvenDowideit [00:42]
............................................. (idle for 3h40mn)
gac410I can't see what is going on, but something has been hammering foswiki.org for hours. Every 2 minutes the load watcher kills apache. [04:22]
[julian]bots?
load watcher is an APP, or you mean oom killer?
[04:27]
gac410probably bots, but hard to say. a cron job watches the load .... Load high (1391 > 1000), kill apache.. [04:28]
[julian]rgr
I've had apache killed by random bots before
[04:28]
gac410yeah. Watching the logs, bingbot has been hitting it, but doesn't seem excessive just watching the log anyway.
I've tried reducing the Fcgid max processes, but no effect. Still hit 30-40 httpd processes anyway
[04:29]
[julian]does netstat give any clues? [04:33]
gac410hm... I wonder what we have using postgres. Lots of TIME_WAIT connections - fluctuating a lot. [04:36]
...... (idle for 26mn)
pharveyhitting trac? [05:02]
gac410no idea.
Ah... that's what uses postgres?
[05:02]
pharveyI think so [05:03]
gac410yeah ... log shows it getting hit pretty hard. > 1 meg access log for today already [05:05]
[julian]that's crazy
any pattern you can notice in your logs?
[05:05]
gac410bunch of spiders. googlebot, bingbot, sogou just in the last few seconds
Looks like it doesn't serve a robots.txt. tbh we should not be having bots indexing the trac database Why do we need that.
[05:06]
[julian]bots are good, but damn they can get annoying [05:09]
gac410Hm... it has a robots.txt on in the home htdocs directory But trac doesn't serve it.
If it was readable, it does a disallow all.
We need an Alias /robots.txt ... statement
Okay. trac now serves robots.txt
Hopefully that will help. Time to sleep.
g
g'night all
[05:10]
[julian]see ya! [05:17]
***gac410 has left [05:17]
................ (idle for 1h19mn)
pharveySQLite actually ... performs a lot better at JOINs than I thought it would.
Well... for small quantities of JOINs
[06:36]
....... (idle for 31mn)
***ChanServ sets mode: +o CDot [07:08]
.......... (idle for 49mn)
memicMichaelDaum: good morning, is there an easy howto for the classification app?
for usage
[07:57]
MichaelDaumGuten Morgen, memic
what's the problem? what did you install so far?
[07:57]
memicyes its working
problem is can i use the classification onyl within the app?
[07:58]
MichaelDaumwhat did you install so far? which skin, which other plugins are there?
oh foswiki.org seems to be under a DoS attack?
[07:59]
memicseems to down [08:00]
MichaelDaummemic, have a look at https://demo.michaeldaumconsulting.com/Knowledge/WebHome to get an impression of how ClassificationPlugin is supposed to work [08:01]
memicthx
where to add the categories
[08:02]
MichaelDaumat https://demo.michaeldaumconsulting.com/Knowledge/Category
see the Quicklinks section on the frontpage
[08:11]
memicah [08:11]
hm the Category links doent work at my wiki to i have to enabled this? [08:17]
hm when i create a new topic im missing the category choice [08:23]
MichaelDaumlet me know when you need further consulting services [08:24]
memicok thx so far [08:30]
.... (idle for 15mn)
whats wrong with the hp [08:45]
PeterSvendsenHi all, after I have updated a lot of extentions the button of all my pages suddenly looks like this "Topic revision: r29 - 31 May 2013, $percntIF{$quotistopic 'Main.PeterSvendsen'$quot then=$quotPeterSvendsen$quot else=$quot!PeterSvendsen$quot}$percnt" any good ideas what went wrong? [08:55]
..... (idle for 22mn)
memicMichaelDaum: its working now was missing some settings
when i add a class it says ERROR: can't parse query "=~ 'Klasse1'
[09:17]
................. (idle for 1h22mn)
PeterSvendsenIn the button of the pages the "Topic revision and date" is shown.. where is that defined? [10:39]
..... (idle for 21mn)
***ChanServ sets mode: +o Lynnwood [11:00]
MichaelDaumgmc, or any other foswiki.org admin present?
the site is pretty unstable // under heavy load
[11:05]
GithubBot[foswiki] FoswikiBot pushed 1 new commit to Release01x01: http://git.io/KG34qQ
foswiki/Release01x01 aa2111e MichaelDaum: Item12653: removed hard-coded dimensions as well as width:auto and height:auto where not required...
[11:17]
***GithubBot has left [11:17]
FoswikiBothttp://foswiki.org/Tasks/Item12653 [ Item12653: PatternSkin CSS rule makes jQuery icons disappear ] [11:17]
GithubBot[foswiki] FoswikiBot pushed 1 new commit to master: http://git.io/RyBOjg
foswiki/master 19af67b MichaelDaum: Item12653: removed hard-coded dimensions as well as width:auto and height:auto where not required...
[11:17]
***GithubBot has left [11:17]
........ (idle for 37mn)
ChanServ sets mode: +o MichaelDaum_ [11:54]
PeterSvendsenIn the button of the pages the "Topic revision and date" is shown.. where is that defined? [12:05]
......... (idle for 43mn)
ModAcOst@PeterSvendsen: For PatternSkin it is %TMPL:DEF{"topicinfo"}% in templates/view.pattern.tmpl [12:48]
cinchthe homepage is acting up [12:59]
JulianLevensIs there a doctor in the house? f.o is sick and needs some TLC
gmc: are you there?
[13:12]
***ChanServ sets mode: +o gac410 [13:13]
gac410Foswiki load watcher kills Apache every 2 minutes. And sends me an email :-( [13:15]
CDotJulianLevens: what's wrong with it? Seems fine to me [13:15]
gac410150 messages overnight [13:15]
CDotaha [13:15]
ValentinKozlov2 CDot: After re-installing the newest release of EditRowPlugin, I can now save my changes. However, other buttons "up","down","+" behave not as expected and button "-" causes Foswiki Error message.
More, including the log message on http://foswiki.org/Support/Question1377
[13:17]
gac410I'm. Away. Can't really help. Looked last night some
Bots were indexing trac
No robots.txt. I added but that takes a while to kick in
Anyway gotta run. Bye
[13:17]
CDotValentinKozlov: I'd recommend you uninstall EditRowPlugin and TablesContrib, and re-install. It looks like your installation has been corrupted somehow. [13:32]
***ChanServ sets mode: +o gac410 [13:34]
gac410Cdot. I saw same erp behavior
Fresh 118 install.
[13:36]
CDotyes, and so did I.... until I reinstlled.
I don't know why it does that, because the modules are there, in the right places, and permssions OK. But reinstalling fixed it for me.
[13:37]
PeterSvendsenHi, in my templates/view.pattern.tmpl the line "%TMPL:DEF{"topicinfo"}%<div class="patternInfo"><span class="patternRevInfo">%MAKETEXT{"Topic revision:"}% %REVINFO{format="$date, $percntIF{$quotistopic '%USERSWEB%.$wikiname'$quot then=$quot[[%USERSWEB%.$wikiname][$wikiname]]$quot else=$quot!$wikiname$quot}$percnt"}%</span>%TMPL:P{"cacheinfo"}%</div>%TMPL:END%%{" suddenly makes an error.... in the button of the pages it now writes
$percntIF{$quotistopic 'Main.PeterSvendsen'$quot then=$quotPeterSvendsen$quot else=$quot!PeterSvendsen$quot}$percnt
[13:41]
***ChanServ sets mode: +o gac410 [13:41]
PeterSvendsenAny idea what the reason of this could be... it happend after extention updates.... [13:42]
gac410Cdot I'll reinstall tonight and see what happens. This is strange. [13:45]
CDotPeterSvendsen: my best guess would be an unclosed " somewhere
try pasting %REVINFO{format="$date, $percntIF{$quotistopic '%USERSWEB%.$wikiname'$quot then=$quot[[%USERSWEB%.$wikiname][$wikiname]]$quot else=$quot!$wikiname$quot}$percnt"}% into a topic, just to make sure REVINFO is still working (I can't think why it wouldn't)
[13:50]
PeterSvendsen@CDot it returns "12 Nov 2013, $percntIF{$quotistopic 'Main.PeterSvendsen'$quot then=$quotPeterSvendsen$quot else=$quot!PeterSvendsen$quot}$percnt" [13:55]
CDotnot good [13:55]
PeterSvendsenbad news... [13:55]
ValentinKozlov2 CDot abot ERT: I just deleted the whole foswiki directory, de-archived foswiki.tgz I downloaded, moved my LocalLib.cfg and .htpasswd, installed ERT. Still the same behaviour ... [13:56]
CDotValentinKozlov: Im looking at the "-" button at the moment; there does seem to be a mismatch between the ERP and the TablesContrib.
PeterSvendsen: I know it's not what you want to hear, but it works fine for me. Therefore you have done something locally to break; such as mixing modules from two different releases
the modules in question would be Foswiki/Render.pm and Foswiki/Macros/REVINFO.pm
without knowing which extension you updated, it's hard to suggest anything else
I don't *think* any extensions implement %REVINFO, but one might
CDot can't find any extension that does.
ValentinKozlov: I can confirm there is a bug with the "-" deleteRowCmd command
[13:57]
PeterSvendsen@CDot would it be possible to "downgrade" all modules easily? [14:18]
CDotI can't think of a way to do that. Without knowing what you updated, it's hard to advise. [14:19]
PeterSvendsenOK I'm waiting for the files.. I dont have access to the server :/
Maybe I should "just" upgrade the wiki.. today we use Foswiki-1.1.3, Sat, 16 Apr 2011, build 11475, Plugin API version 2.1
[14:20]
gac410If you upgrade I'd suggest 119rc2.
There will be a couple of more fixes before 119 but nothing really major
[14:23]
PeterSvendsenbut 1.1.9 is under test as I see it... ?! [14:24]
gac410Cdot I sent an email to Arthur about that CSS issue.
Yes. But 119 has some very important fixes. Check Foswiki:System.ReleaseNotes01x01
[14:25]
FoswikiBothttp://foswiki.org/System.ReleaseNotes01x01 [ ReleaseNotes01x01 ] [14:27]
CDotoh duh. Move row N one place up movew row N-1 one place up. Changed from 1-based indices to 0-based, and didn't fix that function. My bad. [14:28]
gac410I'll build RC3 tonight. Hopefully I'll hear from AC soon [14:29]
CDothe's a busy bee with his new venture, so don't hold your breath [14:31]
gac410Knock on wood, looks like bot attack has subsided [14:37]
.... (idle for 18mn)
PeterSvendsenIn case I would make a new foswiki installation.. which version should be used?
1.1.8 or 1.1.9?
[14:55]
CDotI would install 1.1.9rc2 [14:56]
PeterSvendsenok where can I find that?
I looked in download without luck
[14:57]
CDotgac410 is the one who built it [15:04]
...... (idle for 29mn)
foswiki_irc2any core developers here? [15:33]
***foswiki_irc2 has left [15:41]
................ (idle for 1h19mn)
CDotfoswiki_irc2: yes :-) [17:00]
***ChanServ sets mode: +o gac410 [17:13]
.................................. (idle for 2h48mn)
GithubBot[foswiki] FoswikiBot pushed 1 new commit to master: http://git.io/kp0f3g
foswiki/master 0b3a383 CrawfordCurrie: Item12654: fix zero based indices and interactive row moving...
[20:01]
***GithubBot has left [20:01]
FoswikiBothttp://foswiki.org/Tasks/Item12654 [ Item12654: Interactive row moving is snafu ] [20:01]
***timlegge has left [20:10]
............... (idle for 1h13mn)
ChanServ sets mode: +o gac410 [21:23]
.................... (idle for 1h39mn)
ChanServ sets mode: +o SvenDowideit [23:02]
........ (idle for 38mn)
pharveyfound in /etc/mime.types - chemical/x-daylight-smiles smi
goodness
pharvey wonders why chemical peeps have their own namespace and bio punks don't
I nearly had to webify a SMILES renderer once. http://en.wikipedia.org/wiki/Simplified_molecular-input_line-entry_system
[23:40]
gac410better living through chemistry [23:41]
pharveythe weird thing is I don't remember storing smiles codes in a .smi file, haha
I guess that's why it's commented out
[23:42]

↑back Search ←Prev date Next date→ Show only urls(Click on time to select a line by its url)