#foswiki 2014-09-12,Fri

↑back Search ←Prev date Next date→ Show only urls(Click on time to select a line by its url)

WhoWhatWhen
gac4101RiskReward No such thing that I'm aware of. If you mean a shortcut to entering     you could use a macro Set %TS% =      [00:47]
RiskRewardThanks. I actually mean I'd just like to indent my lines nicely to make them more readable to me. There are lot's of examples on Foswiki.org of nicely cascading lines that make different parts of, say, a query easier to read. But for some reason the tab key doesn't work in the editor. Could it be that people on Foswiki.org just hit the spacebar multiple times? [00:49]
gac4101Ah... no Could you point to an example page. It may be manual spacing inside a <pre> block. Currently Foswiki doesn't have a paragaph indent markup. Though I think one is in the upcoming 1.2, [00:50]
RiskRewardOK, I'm looking for an example.
So, I can't find the example.Never mind. I'll just use the space bar. Thanks for your help.
[00:57]
........................... (idle for 2h11mn)
gac4101Hm. Well if nobody is working on ConfigurePlugin, I have a mega-commit ready to go. it merges ConfigurePlugin into "distro" preserving history. I'll wait until tomorrow to actually push to github.
It also restores CGISetup.pm, moves it from core into ConfigurePlugin, Renames it to DependencyReport and strips it down to do the dependency checks that we lost with cdot's restructure.
BTW.. finally figured out something. When moving / renaming / refactoring. Keep the steps simple. Move the file, commit, change name, commit, major changes, commit. That seems to help git actually track the file history.
[03:10]
.................. (idle for 1h26mn)
hm... forgot I'll be away. I'll plan to do the restructuring of ConfigurePlugin on the weekend. g'night all [04:41]
***gac4101 has left [04:41]
................ (idle for 1h18mn)
ChanServ sets mode: +o MichaelDaum [05:59]
................................................................ (idle for 5h18mn)
ChanServ sets mode: +o Lynnwood
ChanServ sets mode: +o Lynnwood_
[11:17]
.............................. (idle for 2h29mn)
IngridEbert2hi there
i have question about solrsearch
maybe someone of you can help me
[13:48]
MichaelDaumHi IngridEbert2 [13:49]
IngridEbert2I have a dataform with a textboxlist
but unfortunately only the first entry of the textboxlist is shown in the search result
[13:49]
MichaelDaumhow is it called and what's its content [13:50]
IngridEbert2<table border="1" cellpadding="1" cellspacing="1" class="Modac_Standard" style="width: 100%"> <thead><tr><th>Tool</th><th>Used for</th></tr></thead><tbody> %SOLRSEARCH{"parent:%BASEWEB%.%CALC{"$SUBSTITUTE(%BASETOPIC%, %WORKFLOWSUFFIX%,)"}%" format="<tr><td>[[%BASEWEB%.$topic][$field_TopicTitle_s]]</td><td>$percntFORMATLIST{\"$field_Used_for_lst\" split=\", \" separator=\"x\"}$percnt</td></tr>" separator="" sort="topic asc" row
The content of the field Used for is e.g %META:FIELD{name="Used_for" attributes="" title="Used_for" value="Product3, Product2"}%
[13:52]
MichaelDaumah Modell Aachen [13:54]
IngridEbert2hehe [13:54]
MichaelDaumthe best practice to debug a TML mud like this is ...
(1) use proper indenting
(2) disable makros one by one, inside ones first
e.g. write $percntFORMATLIST!{ ... just to see what the makro would be formated like
[13:55]
IngridEbert2ok, FormatList only get the first entry --> %FORMATLIST!{"Product3" split=", " separator="x"}%
what do solrsearch normally do with fields of the typ textboxlist?
btw. the content of them?
[13:57]
MichaelDaumit detects it to be a multi-value field and creates a field_..._lst for it [13:59]
IngridEbert2yes, but why do the other entries get lost?
When I use SEARCH this isn't so
[14:00]
MichaelDaumPlease see the docu at System.SolrPlugin how and why DataForm fields are indexed using different names. [14:05]
IngridEbert2I've already read the chapter about dynamic fields. but there is no information about my problem.
I reduce the solrsearch to a minium
| *title* | * Used for * | %SOLRSEARCH{"" format="| $topic | $field_Used_for_lst |$n" sort="topic asc" rows="99999"}%
but it's the same problem
[14:08]
MichaelDaumplease make sure the topic is indexed. it seems the index isn't in sync.
how do you index the wiki content?
[14:09]
IngridEbert2I create a new solr index with ./solrindex mode=full optimize=on
but the problem still exists
:-(
[14:18]
MichaelDaum./solrindex topic=Web.Topic would have been sufficient [14:23]
IngridEbert2we have the solrplugin version 1.10.17 installed. may there is a bug? [14:30]
foswiki_irc7I have a noob question (our wiki admin left the company quickly)... how do I change the WIKIWEBMASTER name and info to mine? [14:31]
IngridEbert2we updated a week ago but can't remember if we have the same problem before the update
You can set the WIKIWEBMASTER in the Main.SitePreferences page
[14:31]
foswiki_irc7ok, I'm assuming you add a 'Set WIKIWEBMASTER =' and then login name? [14:34]
IngridEbert2no, i think WIKIWEBMASTER is the contact email address
do you want to get an admin?
[14:35]
foswiki_irc7ah ha! i think I got it
i am logged in as admin
but on all our confirmation pages etc. it pulls in the WIKIWEBMASTER info, which is now defunct since he left
[14:36]
MichaelDaumIngridEbert2, I can't repro the error. The fields come thru just fine. [14:37]
foswiki_irc7thank you so much @IngridEbert2 ! [14:38]
MichaelDaumIngridEbert2, though SolrPlugin 1.10.17 ... that's quite old [14:38]
IngridEbert2MichaelDaum, which solrplugin version do you use? [14:39]
MichaelDaum2.20 [14:39]
IngridEbert2oh [14:39]
MichaelDaumand I am pretty sure I never used three-digit version numbers for it. any local modifications? [14:40]
IngridEbert2I get the number from the page System/InstalledPlugins
System.SolrPlugin (1.10.17, 1.10): Enterprise Search Engine for Foswiki based on Solr
I don't think we do local modifications
but we use the repository of modell aachen
unfortunately this is not available at the moment
[14:43]
MichaelDaumyour repo seems to be outdated
even though. still strange that you get this error.
[14:52]
IngridEbert2I'm not sure if I do something wrong with the update last week. Is there any cache or something that I should delete? [14:53]
MichaelDaumdunno
maybe you are indexing to a different solr server than you are quering from?
[14:55]
IngridEbert2hm I think that can't be possible, the pages I searched for only exist on this system. [15:02]
***IngridEbert2 has left [15:03]
......... (idle for 44mn)
NewToFoswikiHello
:-)
[15:47]
.............................. (idle for 2h28mn)
ixnuI'm trying to install foswiki on Ubuntu 14.04 using the deb package. The install started and asked me various question about where to install and host name and admin user IIRC.
The install then bombs out with some errors
This looks like the critical one
subprocess installed post-installation script returned error exit status 127
Installing on vanilla apache
any quick hacks to make it work?
thanks
subprocess installed post-installation script returned error exit status 127
more info if it helps:
Setting up foswiki (1.1.9-1) ...
Upgrading distributed topics and attachments - skipping files changed via the Foswiki
see /var/log/foswiki/exclude-topics.lst and /var/log/foswiki/exclude-attachments.lst
/var/lib/dpkg/info/foswiki.postinst: 136: /var/lib/dpkg/info/foswiki.postinst: -bd: not found
dpkg: error processing package foswiki (--configure):
subprocess installed post-installation script returned error exit status 127
Errors were encountered while processing:
[18:15]
tsnfooixnu: gac410 isn't around, but he would probably be able to help, as I think he build that package. [18:19]
ixnufoswiki
E: Sub-process /usr/bin/dpkg returned an error code (1)
[18:19]
tsnfooI'm not familiar with dpkg, but that sounds like th post hook script is missing.
Foswiki is actually pretty easy to install manually, so you could always try that if all else fails.
[18:19]
ixnuyea, documentation looks outstanding.
non-ironically ;)
doesn't look too tough
I just like being lazy
esp on Friday
[18:20]
tsnfooLOL [18:21]
ixnuI have an opprotunity to FIANLLY kill Sharepoint and I am prepared to go to whatever lengths necessary [18:22]
tsnfooMy installation process is usually: download, unzip, http://foswiki.org/Support/ApacheConfigGenerator, restart apache [18:22]
ixnuthis is merely a speedbump [18:22]
tsnfooDEATH TO SP [18:23]
ixnuyep, just add that VH file to my config
thanks
[18:23]
tsnfooAlso, I find cpanm is super handy for installing perl deps, if your distro doesn't have good packages. Some of the really good plugins you'll want are built on Perl modules from CPAN. [18:24]
ixnuyea, saw that in the pre'reqs
been a while since I have develed with Perl
[18:24]
................ (idle for 1h19mn)
OK, up and running
thanks for the help
[19:44]
.............................. (idle for 2h25mn)
***ChanServ sets mode: +o Lavr_
ChanServ sets mode: +o Lynnwood_
uebera|| has quit IRC (*.net *.split)
[22:09]
DeanSpicer has quit IRC (*.net *.split) [22:28]
.... (idle for 15mn)
ChanServ sets mode: +o Lavr_ [22:43]
77CAAFXQV has left [22:49]
......... (idle for 40mn)
ChanServ sets mode: +o Babar
ChanServ sets mode: +o Babar
[23:29]
...... (idle for 25mn)
ChanServ sets mode: +o gac410 [23:55]
gac410tsnfoo ... I don't build the debian packages. SvenDowideit takes care of them. There have been other issues reported with ubuntu 14.x I'm wondering if something in the dpkg / apt environment changed. [23:58]

↑back Search ←Prev date Next date→ Show only urls(Click on time to select a line by its url)