#foswiki 2014-11-26,Wed

↑back Search ←Prev date Next date→ Show only urls(Click on time to select a line by its url)

WhoWhatWhen
***gac410 has left [00:22]
.......................... (idle for 2h9mn)
ChanServ sets mode: +o Lynnwood [02:31]
......... (idle for 40mn)
ChanServ sets mode: +o gac410 [03:11]
..................... (idle for 1h40mn)
gac410 has left [04:51]
......................... (idle for 2h4mn)
ChanServ sets mode: +o CDot [06:55]
..................... (idle for 1h40mn)
ChanServ sets mode: +o CDot [08:35]
ChanServ sets mode: +o MichaelDaum [08:46]
................................................... (idle for 4h13mn)
GuilainC1Hi everyone, special question to MichaelDaum: I'm trying to setting up OembedPlugin : I've get my embed.ly api-key, but nothing works what's the setting for the providers (i.e. {OEmbedPlugin}{Providers} variable) ? [12:59]
MichaelDaumGuilainC1, see the default settings comming from lib/Foswiki/Plugins/OEmbedPlugin/Config.spec
the configure interface should have loaded into your LocalSite.cfg already
[12:59]
GuilainC1GuilainC1 is reading it
hum nothing off that is setting up
I install from sven debian package,
GuilainC1 setting up the variable as config.spec
[13:00]
MichaelDaumSven's repo has seen quite a few critical bug reports.
Bugs that only show up in his debian packages
[13:04]
GuilainC1dully noted, and I hope I can be able to help soon...
bin/configure doesn't want to setting up the variable {OEmbedPlugin}{Providers}
I'm going on by the file
[13:16]
whatever Im' setting inside LocalSite.cfg, bin/configure suppress this variable {OEmbedPlugin}{Providers}
unfortunately, I've no time left, so I will see that an other time, thanks for your support, and oembed should work out of the box
[13:27]
MichaelDaumsure thing
quick hack: just copy&paste the providers from Config.spec to LocalSite.cfg
then it works ootb
[13:31]
GuilainC1tha'ts what i've done
and is at this point, that bin/configure suppress it and replace it to undef
but i've to say, when i've try under windows last year, oembed doesn't work ootb too...
[13:32]
andreliHello [13:35]
GuilainC1hello andreli [13:35]
andreliMichaelDaum: We think of a kind of status feed for all foswiki changes.
IIRC you had once some code doing something like this?
[13:36]
MichaelDaumHi andreli
what kind of changs do you refer to? (1) changes on foswiki.org (2) changes on your install
(3) activity streams
(4) micro blogging
[13:37]
GuilainC1MichaelDaum can i suspect library competition, between lib/CPAN and debian perl package ? is it possible ? [13:38]
MichaelDaumGuilainC1, could you rephrase "suspect library competition
"
[13:38]
andreli(3) activity stream [13:39]
MichaelDaumandreli, I once started working on an ActivityStreamPlugin but this is staled for quite some time. no sponsors ;) [13:39]
andreliMichaelDaum: The main goal is to feed a intranet notification center reducing email. [13:40]
GuilainC1is there a possibility, for explain the trouble (disparition of the {providers} variable in LocalSite.cfg) could come from the use of an debian perl package instead of /var/lib/foswiki/lib/Foswiki/lib/CPAN (or something like that- CPAN included in module) ? should I investigate in this way or is stupid ? [13:40]
MichaelDaumGuilainC1, could be. Not sure. I do know that the @INC path in Sven's debian packages differs from the Foswiki standard in some whay
could be related to OEmbedPlugin as it comes with Regexp::Assemble as a fallback when there's no system lib available
[13:44]
GuilainC1I've add regexp::assemble
by the debian package manager, so not use the one provide by the module, could be the reason ?
[13:45]
MichaelDaumother than that I don't think that configure is hampered by any @INC-ish problem
no, thats not the direction to investigate
could be configure simply doesn't like the PERL structure in Config.spec of OEmbedPlugin
[13:45]
GuilainC1I don't know enough the foswiki mechanism, but I think I've something strange here, and I'm normally ootb in a debian manner [13:46]
MichaelDaumandreli, see https://github.com/foswiki/ActivityStreamPlugin ... umpf is it three years already [13:47]
GuilainC1don't worry MichaelDaum, thank for your support, i will spent more time an other day for understood, what's wrong, and report bug if it's bug [13:47]
MichaelDaumGuilainC1, thanks
andreli, reducing email ... thats more micro-bloggish
[13:47]
andreliMichaelDaum: No, it's more increasing the acceptance - or sign up - for notifications while not increasing the amount of email. [13:50]
MichaelDaumah ok. so you mean: reduce notification emails ... sent by Foswiki [13:52]
andreliexactly [13:52]
MichaelDaumnot so much: reduce email communication between people
... which activity streams are supposed to do as well ... in the micro blogging sense
[13:52]
andrelithats tor an other project [13:53]
MichaelDaumyes right. current ASP code hooks into the Foswiki event logger and verbalizes and groups these things in a human readable way [13:53]
***ChanServ sets mode: +o gac410 [13:54]
MichaelDaumsuch as "User A has uploaded image <img> and <a twisty>10 more</a>. " [13:55]
andreliI will have a look into the code. The notification center will be implemented outside of Foswiki, as it ties into other services too. [13:55]
gac410Re : activity, are you talking about your own wiki or Foswiki development? [13:56]
MichaelDaumnote this was just an experiment. I won't consider the current code final. pretty sure it needs a more complete rewrite to add filtering.
gac410, activities in ones wiki.
[13:56]
gac410There is immediate notification plugin. Rather incomplete :( but I was trying to add generic notifiers like irc, tweet, smtp, etc.
Version in extensions / Testing is somewhat functional
Needs a lot of work though
[13:59]
foswiki_irc3Hello. MichaelDaum: Is there any chance to add an attachment to an e-mail, which is sent with the SendEmailPlugin? [14:02]
MichaelDaumfoswiki_irc3, not that I know. missing feature. needs to interact with an uploader as well part of the send email html form.
"send attachment(s) as email" would be a NiceToHave for TopicInteractionPlugin
[14:05]
foswiki_irc3MichaelDaum, Okay thanks
Yeah that would be nice
[14:06]
andreliI will have a look into http://foswiki.org/Extensions/ImmediateNotifyPlugin too. Thanks gac410. [14:10]
gac410Testing not extensions!
And don't expect a very polished experience, I've rather dropped the ball
[14:10]
GuilainC1gac410, is foswiki turn with fcgi ?
I've perhaps found a bug (perhaps !)
[14:19]
gac410Foswiki.org runs on fcgi
Trunk.foswiki.org uses plain old CGI
[14:20]
GuilainC1ok, foswiki.org have checklisttable enable ? [14:25]
gac410No [14:26]
GuilainC1oki, so I will not be able to test in an other location (and other configuration than mine)
my trouble is simple : everything works well, and fast ;) but with checklisttable the add button doesn't work anymore when you are auth, but, it's work one time after a login...
so is unusable :(
[14:39]
gac410Hmm that one is imported from twiki. Looks like it needs a maintainer [14:48]
..... (idle for 23mn)
GuilainC that ext. is from twiki, but doesn't seem to be maintained there either. We need a maintainer here. [15:11]
jastin other words, nobody has taken the time to make it fully compatible with Foswiki
it's probably not that difficult to correct, but I am fairly busy at the moment
[15:12]
GuilainCwell understand, :(, i don't think to have the ability to maintain, I'm so abeginner ;), sad, because it's very useful [15:13]
jastwhat extension is checklisttable from?
a good first step may be to open a Task about this problem, and associate it with that extension
[15:13]
GuilainCbe careful I'm suspect a bug, I'm not sure, and I will prefer to test in an validate foswiki installation with fcgi [15:14]
jastthe install in which you've found the problem is FCGI, too, I guess? [15:14]
GuilainCyes jast, I'm finishing migration from an old foswiki installation (under windows) into a new and fresh debian installation [15:16]
JulianLevensDo you have CheckListPlugin installed and/or CheckListTablePlugin
s/List/list/
[15:16]
GuilainCone of my last step is to setting up an accelerator, fcgi or mod_perl
I've the two installed
and everything works except page with %CHECKLISTTABLE... which suffer of updating content after an "add"
[15:16]
JulianLevensThey both attempt to define the %CLI% macro - that might be an issue [15:17]
GuilainCThat's why, before submitting a bug, I would prefer to test it in a well validate fcgi installation [15:17]
JulianLevensIt might be worth a test to disable ChecklistPlugin and see if the issue goes away on ChecklistTablePlugin [15:18]
GuilainCI precise, everything work very well with normal configuration plain pure perl
and under windows with mod_perl too
I'm ok, have you in mind the syntax for disabled plugin in a topic ?
[15:18]
JulianLevens?debugenableplugins=ChecklistTablePlugin to only enable that plugin (you can add more its a comma separated list) [15:23]
GuilainCthanks, i exactly what i'm searching into my mind...
try in live
[15:33]
first, url stay on viewauth (I don't have made any re-auth between configuration in pure plain perl and fcgi
second, pressing add button, the debugenableplugins isn't kept
(in the url)
[15:38]
JulianLevensI was worried about pressing add button would lose debugenableplugins [15:40]
GuilainCshould i set by using * Set DEBUG...
normally should work isn't it ?
[15:41]
JulianLevensYes that's the next option [15:42]
GuilainClet me try
hum the ___* Set statement doesn't work,
it's a simple timesheet using spreadsheetplugin and the calculation of spreadsheet is still here
[15:43]
JulianLevensDid you use * Set DEBUGPLUGINS = ChecklistPlugin
It's not DEBUGENABLEPLUGIN
You only specify a comma separated list of plugins to disable, not the full list to use
[15:48]
GuilainCheh not, i've use debugenableplugin... :(
it's quite confusing.. :)
do the same, variable ignored
seems we only have DISABLEDPLUGINS
i try with DISABLEDPLUGINS = CheckListPlugin
definitively doesn't works
:(
[15:50]
JulianLevensWell it was worth a quick test; I hope you can discover more and fix it your self :) and if not raise a bug report :(
Just read the docs of ChecklistTablePlugin it knows about and even uses ChecklistPlugin for some features :'(
Should have read the docs more carefully and sooner
[16:00]
GuilainCthank JulianLevens for your support
what do you think, taht under fcgi, my url seems to call the script viewauth
taht = that
is it normal ?
[16:05]
JulianLevensNo I don't think that's right [16:07]
GuilainCit's the only difference i see between checklistplugin which works well
and checklistTablePlugin
in source code, an "add" row in ChecklistTablePlugin add this
<form method="post" action="https://***/foswiki/bin/viewauth/Main/MoveWiki#CLTP_TABLE_0" enctype="multipart/form-data" onsubmit="StrikeOne.submit(this)">
even if I force the use of view, the url isn't changed
no idea where this html code in the source code is construct
and again, why it's work under plain perl and not under fcgi.. ??
I confirm, under plain perl, no viewauth appear...
[16:08]
***ChanServ sets mode: +o gac410 [16:24]
JulianLevensSorry, no more time now, but which web-server are you using? [16:25]
gac410GuilainC I looked at checklistplugin code. Uses lots of global variables, so not surprising there are issues with fcgi :-(
Gotta run bbl
[16:26]
GuilainCoh... I don't have this level of expertises [16:27]
JulianLevensGotta run too [16:31]
***JulianLevens has left [16:31]
GuilainCto finish and for history... mod_perl works well with checklisttableplugin [16:43]
hum speak, little be fast...
.. now it's editchapterPlugin which get an json invalid error
[16:50]
***ChanServ sets mode: +o CDot [17:01]
.......................................................................... (idle for 6h5mn)
cz99Hi Guys, anyone know what the dirs foswiki _empty & _default are for on v1.0.9? we're doing a move onto v1.1.9 and it doesn't have those. are we ok to delete those after the move? [23:06]
...... (idle for 25mn)
***foswiki_irc8 has left [23:31]

↑back Search ←Prev date Next date→ Show only urls(Click on time to select a line by its url)