#foswiki 2015-04-06,Mon

↑back Search ←Prev date Next date→ Show only urls(Click on time to select a line by its url)

WhoWhatWhen
***Rich_Morin has left [00:05]
....................................................... (idle for 4h30mn)
GithubBot[distro] gac410 pushed 3 new commits to master: http://git.io/ve8MC
distro/master c9f0ff8 George Clark: Item9693: Pull TWiki info out from UpgradeGuide....
distro/master 8eed104 George Clark: Item12855: More dependency cleanup....
distro/master ec7b9a0 George Clark: Item12855: Test/update debian pkg requirements
[04:35]
***GithubBot has left [04:35]
GithubBot[distro] gac410 pushed 1 new commit to master: http://git.io/ve8MK
distro/master 428eb64 George Clark: Item12855: Typos more typos.
[04:39]
***GithubBot has left [04:39]
............. (idle for 1h3mn)
ChanServ sets mode: +o CDot [05:42]
....................................................................... (idle for 5h51mn)
ColasHmeStrange, I cannot connect to foswiki.org from France for 3 days now. I can connect on a server in the UK and the US, though
even stranger, the route from France and UK go through the same relays ams-ix.sara.xs4all.net / 0.ae5.xr4.1d12.xs4all.net / te5-4.swcolo2.3d12.xs4all.net but the connection is not made from France (or my ISP, at least)
[11:33]
gmcuhm...
that's weird :)
te5-4.swcolo2.3d12.xs4all.net would be the router on the floor of the datacenter my rack is in
ams-ix.sara.xs4all.net / 0.ae5.xr4.1d12.xs4all.net are the routers i think that xs4all and ams-ix connect to each other
[11:36]
ColasHmenow, this is definitively weird :-) [11:37]
gmcwhere's the traceroute from france going to? where does it end? [11:37]
ColasHme... s ams-ix.sara.xs4all.net / 0.ae5.xr4.1d12.xs4all.net / te5-4.swcolo2.3d12.xs4all.net (end)
traceroute from UK ends the same way
could I be IP-blacklisted?
[11:37]
gmchmm what is your ip?
can you telnet to port 22 from that ip?
[11:39]
ColasHme82.246.4.254 [11:39]
gmci think there's only two ip blacklists on that server.. one is the foswiki one, for spam protection, the other is ssh based
can you try to connect for me now?
[11:39]
ColasHmenope port 22 deosnt respond [11:40]
gmcwell i don't see your ip popping up when monitoring the firewall (blocked requests are logged) [11:41]
ColasHmeActually I have the same beahavior as RaulFR http://irclogs.foswiki.org/bin/irclogger_log/foswiki?date=2015-04-03,Fri&sel=11#l7
I can see translate.foswiki.org fine
[11:41]
gmcthat's on another server alltogether [11:42]
ColasHmeSince RaulFR and me have the problem, it may be the same for all French IPs [11:42]
gmcwell, it does seem to be a problem at the server, not the source
since the traceroute looks good
[11:42]
ColasHmeyup, I first I thought it was my ISP but it reaches your server farm, so.... [11:43]
gmci'm now grepping for your ip in foswiki.org's public_html, to see if that finds anything [11:43]
ColasHmeI will use a proxy, and put the pre-release 1.2 somewhere else for other French people [11:44]
gmccan you try loading up foswiki.org once more for me? i'm tcp-dumping the external interface, see if packets even arrive at the server [11:46]
ColasHmestarting... [11:46]
gmci don't see a thing coming in from 82.246.4.254 w/ tcpdump
(even if it was blocked by the firewall, it would still show up)
so there seems to be an issue in the last-hop router of xs4all i guess...
and this started 3 days ago?
[11:47]
ColasHmemaybe more. I just wanted to download the pre-release just after George email. I dont remember the last time I went to see foswiki.org before [11:49]
gmccan you email me your traceroute? so i can send that along to xs4all when i'm reporting the issue? [11:51]
ColasHmeok... FYI I saw foswiki.org last on 2015-03-29
so the problem occured between ths date dans April 3rd
[11:52]
gmcok, i will get on it
tnx for the info!
[11:54]
ColasHmethanks for your help [11:55]
***Tarbox has left [12:03]
ChanServ sets mode: +o Lynnwood
ChanServ sets mode: +o gac410
[12:13]
.... (idle for 15mn)
gac410g'morning all .. anybody tried the beta?
Sourceforge only shows 4 downloads :(
[12:28]
ColasHmegmc: interesting: I tried http://proxfree.com : it has 2 proxies in France: the Paris one do not see foswiki.org either, but the roubaix one does. [12:32]
gac410Someone else had the same issue the other day ... had to use Tor to gain access [12:33]
ColasHmeyup, seems a wide scale problem for a lot of French IPs. Koen will see with the hoster (the tracroute goes up to the foswiki hoster)
ah a freind in Paris is telling he doesn't see foswiki.org either
[12:34]
gac410Jomo reported issues in Bratislava http://irclogs.foswiki.org/bin/irclogger_log/foswiki?date=2015-03-30,Mon&sel=376#l372
I tried to ping outbound from f.o, but can't use ping from the jail.
[12:36]
ColasHmef.o doesnt seem to answer the ping in any case
mmm tried to go directly to http://foswiki.sourceforge.net/ ... but it redrects me to foswiki.org ???
[12:38]
gac410Not here
PING foswiki.sourceforge.net (216.34.181.96) 56(84) bytes of data.
64 bytes from projects.sourceforge.net (216.34.181.96): icmp_seq=1 ttl=238 time=43.0 ms
Oh... yes it does ... at http leve
[12:39]
ColasHmeyes, http
it messes with the proxy I use, trying others...
[12:40]
gac410uebera||: Hi Markus, I enabled your ID on translate.foswiki.org for translations, not just suggestions. [12:48]
....... (idle for 30mn)
hey all .. I lost track of time this am. Are we having a release meeting? Any beta feedback to report? [13:18]
***ChanServ sets mode: +o Lynnwood_ [13:30]
..... (idle for 23mn)
hardcore has quit IRC (*.net *.split)
leguin.freenode.net sets mode: +o Lynnwood
[13:53]
......... (idle for 43mn)
GithubBot[distro] gac410 pushed 2 new commits to master: http://git.io/veROU
distro/master 50e4572 George Clark: Item13345: CGI qw(-any) used in MailerContrib
distro/master 8b5ab85 George Clark: Item12855: More dependency changes...
[14:39]
***GithubBot has left [14:39]
.......... (idle for 49mn)
ChanServ sets mode: +o Lynnwood_ [15:28]
........................... (idle for 2h12mn)
ChanServ sets mode: +o Lynnwood_ [17:40]
GuilainChi all, foswiki.org seems to be down ? [17:53]
gac410GuilainC: seems to be working from here. I believe gmc opened a support ticket with his ISP due to some routing issues. [17:56]
GuilainCok gac410... dully noted
hoping It will get up here soon
[17:58]
gac410Seems to be locations in France that are blocked at isp for some reason. [17:59]
GuilainCdo you have any idea of the reasons ? [18:02]
gac410not a clue. Could be misconfigured routes, filtering, etc. I'd be more suspicious of a routing issue, but I have nothing that backs that up. Would need to tracert in both directions and see if there is some sort of asymmetrical route that's black holing the return path. [18:04]
.... (idle for 19mn)
hm. I published the 1.2 beta announcement on blog.foswiki.org. But it doesn't show up if not logged in. :P
Needed to be in "category Event" to get homepage ink.
[18:23]
...... (idle for 28mn)
gmcgac410: well, ColasHome mentioned he couldn't reach foswiki.org, and someone else from france also had that issue
GuilainC: you from france?
[18:54]
gac410gmc, you can infer that he's been working on the French translation ;) [18:57]
gmcgac410: i generally only skip through backlogs, not read every line :)
GuilainC: can you do a traceroute to foswiki.org?
and mail me the result?
[19:00]
gac410I should have said I could infer :) As I've been helping him with it. But that really doesn't add any true meaning wrt his location. [19:02]
gmcmany canadians are francophone [19:02]
gac410yes indeed. [19:02]
ColasHmeGuilainC: yes, foswiki.org seems block from most of France. The only location I was able to make it work was roubaix. You can use the temporary web proxy I have set up on a server in the UK if you want: host nahaboo.net port 8888 [19:03]
GuilainCoops was away for lunch, i'm back and start read your msg
so, I'm come from france, and get internet with the "free.fr" isp
ok gmc for the traceroute, let me know your e-mail
thanks ColasHme, I will set up the proxy for foswiki.org
[19:04]
gmcGuilainC: see pm [19:08]
GuilainCi can confirm that i can reach foswiki.org by my phone provider
ok gmc, what's strange, is the last traceroute jump is xs4all.net server... which seems to be yours
by the way, you get e-mail in one min
[19:08]
gmccool, tnx [19:11]
GuilainCgmc done [19:14]
....... (idle for 30mn)
gmctnx! [19:44]
GuilainCthanks ColasHme, proxy works ! [19:47]
gmcColasHme: GuilainC: btw, do you know if your browser is connecting with ipv4 or ipv6?
oh nm, there's no AAAA record for foswiki.org
GuilainC: ColasHme: could you do me a favour and try pinging foswiki.org ?
[19:48]
GuilainCgmc, i use both ipv6 and ipv4, normally ipv6 is prefered [19:53]
gmcGuilainC: never mind that, the dns entry for foswiki.org doesn't have an ipv6 record [19:53]
GuilainCgmc dns is fine, i get 82.94.245.62
but ping give timeout
[19:53]
gmcis that one of you? [19:53]
GuilainCyes me ;) [19:54]
gmccool, can you keep it running? means i do see your packets, but server somehow doesn't want to reply to you [19:54]
GuilainCok
gmc
do that
go
[19:55]
gmcyep, i see packets coming in again..
this is weird...
[19:56]
GuilainCI've try a simple telnet on port 80, without any success :/
for summary, some host on internet can reach foswiki.org some other not without any good reason, aka without have done any configuration in this aim ?
[19:57]
ColasHmegmc: ping timeouts to foswiki.org on all the servers I tried. Even the ones that can see it in a browser [19:59]
gmcColasHme: yeah i've just opened up icmp, like 3 minutes ago [20:00]
ColasHmeping works now from my UL server
s/UL/UK/
[20:00]
gmcoh damn
that can't be right: 82.0.0.0/8 link#5 U 0 904967 em0
(in the routing table :)
[20:01]
ColasHmeGulain: I am also on free.fr, as you and the friend that tested too. Could be a routing problem with free.fr [20:01]
gmcit should work again! [20:01]
ColasHmeyup! my ping just began to work from me! [20:02]
GuilainCping ok [20:02]
ColasHmeand I can see foswiki.org in the browser now [20:02]
gmcnice.. i wonder where that strange route came from.. [20:02]
GuilainCsame here
thanks gmc !
[20:02]
gmci have been updating it late at night recently, i must've typed something wrong
ah.. i've set a bogus ip on the interface apparently, which automaticall created the 82.0.0.0/8 route
and since you were all in 82.0.0.0/8, it b0rked
note to self: don't update foswiki.org late at night again
ColasHme: are you able to delete lines from the irc logs?
[20:03]
Colasyes [20:07]
GuilainCGuilainC is away for several minutes [20:08]
gmcgmc is away for several hours
(sleeping :)
[20:11]
ColasHme'night! [20:12]
gac410gac410 wonders if anyone anywhere actually runs Apache 1.x ... we should remove the Apache 1.x stuff from the dependencies. Mod_perl 1 and Apache::Request [20:24]
....... (idle for 33mn)
GuilainCbye ! [20:57]
................. (idle for 1h21mn)
***ChanServ sets mode: +o Lynnwood_ [22:18]
........ (idle for 36mn)
foswiki_irc0Hi, all. My name is Frank. Is this the place to ask questions if you're having trouble installing Foswiki?
I've installed the beta on A2 Hosting, updated the perl modules, and created the .htaccess files, but I keep getting an internal error - Can't locate CGIpath in @INC
[22:54]
....... (idle for 30mn)
gac410Hi Frank. Sounds like the perl module CGI is not available on your host site.
the "path" is redacted information so that file system structure is not displayed in error messages.
CGI may or may not come with perl automatically. Very latest versions of perl have removed it, so it needs to be installed
foswiki_irc0: Sorry for taking so long ... speaker was muted.
and yes, you're at the right place
[23:26]
foswiki_irc0Thanks! and no problem for the delay. I'll look into CGI, but I'd be surprised if it wasn't there and I run other cgi scripts. [23:31]
gac410If you create bin/LocalLib.cfg (copy it from LocalLib.cfg.txt) And uncomment just one line ... enable ASSERTs and you'll get full stack traces to the browser. [23:32]
foswiki_irc0O.K. That gives me more information. Now I'm getting Can't locate CGI/Session.pm
I thought I installed that earlier, but I'll try again.
[23:36]
gac410yeah that one is pretty important too :) [23:37]
foswiki_irc0It's there. I have version 4.48. [23:38]
gac410hm. that should be fine. [23:38]
foswiki_irc0I just noticed that, according to A2, I need to add this line to the script: use cPanelUserConfig; [23:40]
gac410Hm. you might be able to add it to LocalLib.cfg [23:41]
foswiki_irc0Now I'm getting this:
CGI -any pragma has been REMOVED. You should audit your code for any use of none supported / incorrectly spelled tags and remove them at /perl5/lib/perl5/CGI.pm line 929.
I've never seen that one before. :\
[23:43]
gac410Okay. We fixed that but missed it in one place. Edit lib/Foswiki/Contrib/MailerContrib.pm and remove the qw(-any) on the use CGI statement
CGI version 4.14 decided to do away with the -any option.
You are up to date.... that was released on April 1st.
[23:44]
foswiki_irc0I don't have lib/Foswiki/Contrib/MailerContrib.pm. I do have a lib/Foswiki/Contrib/MailerContrib diretcoty with 7 files. [23:46]
gac410hm... hang on ... let me see where I changed it. Lousy memory.
You don't have lib/Foswiki/Contrib/MailerContrib.pm ???
[23:46]
foswiki_irc0Oh.. sorry... my fault. [23:48]
gac410phew. That was the file in the git diff. :)
-use CGI qw(-any);
+use CGI ();
[23:48]
foswiki_irc0That did it!
I'll continue to play around with it. Thanks!
[23:49]
gac410cool. Have fun. Were you able to add the use cPanelUserConfig; to LocalLib.cfg ? That will be handy to know
and easier than editing every script.
[23:50]
foswiki_irc0I did add it, but without removing it again, I don't know if that helped or not. [23:51]
gac410Thats okay. All the scripts are pretty much identical. They all use setlib.cfg which in turn picks up stuff from LocalLib.cfg [23:52]
foswiki_irc0FYI, I removed the use cPanelUserConfig; from LocalLib.cfg and the problem returned, so putting it there does work. [23:59]

↑back Search ←Prev date Next date→ Show only urls(Click on time to select a line by its url)