#foswiki 2015-07-02,Thu

↑back Search ←Prev date Next date→ Show only urls(Click on time to select a line by its url)

WhoWhatWhen
GithubBot[distro] gac410 pushed 1 new commit to master: http://git.io/vtA8j
distro/master 1d176b5 George Clark: Item9693: Item11737: Fix some minor doc typos...
[00:26]
***GithubBot has left [00:26]
FoswikiBothttp://foswiki.org/Tasks/Item9693 [ Item9693: Documentation updates for Foswiki 2.0 ] http://foswiki.org/Tasks/Item11737 [ Item11737: Direct references to Main, Sandbox and System have crept into the default webs ] [00:26]
gac410hey jomo, really not all that many System reference have crept in. fw is working well using Mysys web. Just checked in the few that were broken, along with some other typos I found [00:36]
............ (idle for 55mn)
RiskRewardI discovered to my amazement today that if you put character emoticons in a topic, the rendered topic displays a matching graphic, i.e. smiley face. I only know one. Where do I find the others? [01:31]
gac410System/SmilieyPlugin [01:31]
RiskRewardThat's not in my documentation. [01:32]
gac410Typo Try Foswiki:System.SmiliesPlugin [01:33]
FoswikiBothttp://foswiki.org/System.SmiliesPlugin [ SmiliesPlugin ] [01:33]
RiskRewardLooks like I had been spelling it wrong too. Thanks! [01:35]
................................................. (idle for 4h3mn)
***ChanServ sets mode: +o CDot [05:38]
....... (idle for 32mn)
GuilainCgac410, I totaly understood you remarks, but perhaps, an priority/vote addressed to new functionality could motivate/lead new developer, due to potential audience. And then for potential user, It enable to the user, to know what's are the priorities of the actual developer/community, and then be sure if what he need as a chance to be released soon... or not. At least for actual developer/"vendor" of foswiki, it enable to know, wh
at other user are waiting for, and then improve by this new potential their proposal by having a better user feedback. But what I really agree with you, is the need of developer, and for that, I know I have to learn perl... :D
[06:10]
***ChanServ sets mode: +o MichaelDaum [06:11]
...... (idle for 29mn)
CDotI have to agree with George. Voting on feature proposals just doesn't work, unless you have a large enough pool of developers that is going to be influenced by the vote. Right now we don't have such a pool of developers.
The major advance this year - unicode core - came about only because jomo volunteered (where he realised it or not) to be tester. Prior to that, I had clearly stated that I wasn't going to work on it without a committed tester at least *3 years* ago.
The point is that voting is pointless. Voting with your feet - actually getting involved and *doing* something - is the only kind of vote that works.
[06:40]
GuilainCyou're experience is speaking, I learn. noted. :D [06:48]
........ (idle for 37mn)
jomoGuilainC: in fact, all this is about two things: 1.) MOTIVATION 2.) Knowlede.
Example: as CDot nicely said, i commited to be a tester but, i tested only things what comes to my mind (e.g. mainly things what i meet when using the FW) Not tested more, simply because: 1.) not comes to mi mind (and didn't got any inputs like - test this and this) - e.g. lack of the knowledge & lack of (external) motivation 2.) havent enough knowledge about the languages - lack of the knowlegde 3.) Myself don't need for example the hebrew an
some other things - LACK OF THE (internal) motivation! (Someone this could call as lazyness) :) :)
[07:25]
............................. (idle for 2h22mn)
CDotYes, knowledge is a factor. Bottom line, though, is that anyone can contribute in *some* way. However the vast majority don't, they take, without ever giving back. [09:47]
....... (idle for 31mn)
KryoStofferHi, I am still having this attachment problem in viewfile, I belive the problem started with this commit: https://github.com/foswiki/distro/commit/e85724a19c26
From the comments in Foswiki::Response::body, it should already be encoded, so what that commit does is to double encode it.
[10:18]
FoswikiBothttp://trunk.foswiki.org/System/PerlDoc?module=Foswiki::Response [10:20]
.................... (idle for 1h37mn)
CDotKryoStoffer: what exactly is the problem?
(I agree that doesn't look right, BTW)
[11:57]
KryoStofferCDot: The attchement get corrupted. [11:58]
CDotcorrupted how? when? on disk? when you view it? when it is saved? [11:59]
KryoStofferIt is correct on the disk, and if I use the CLI interface of viewfile it also is correct. [11:59]
CDotwhat sort of attachment is it? [12:00]
KryoStofferI am testing with a PDF. [12:00]
CDotwhat makes you think it's the write that's the problem?
more speficially, do you know where the call to that write() is coming from?
[12:02]
KryoStofferWell I just dig into to foswiki code less then a week ago, so not 100% sure how everyting is called, but my coruption goes away if remove the encoding in FCGI.
Sorry, should also have mentioned, that I only see the problem if I go via FCGI.
[12:07]
....... (idle for 31mn)
CDotyes, I can see what the problem is. You did well to find it! [12:39]
KryoStofferGreat, would you like me to add my conserns to Item10751, or create a new Issue ? [12:44]
FoswikiBothttp://foswiki.org/Tasks/Item10751 [ Item10751: FastCGIEngineContrib "Wide character..." errors w/UTF-8 Foswiki ] [12:44]
***ChanServ sets mode: +o gac410 [12:52]
CDotKryoStoffer: Item10751 is fine [12:55]
gac410Hey CDot ... I take it another fix for 2.0 is coming :D [12:59]
CDotFastCGIContrib
KryoStoffer: have you tested with your patch?
[13:00]
.... (idle for 16mn)
KryoStofferCDot: I have only tested by reverting that commint, and then try to recreate what is originaly the fault of 10751, but have not been able to recreate that with RC2 and latest FCGI. [13:16]
CDotso you reverted the commit n RC2, and the problem went away? Or something else?
or the problem doesn't exist in RC2, even without your patch?
[13:17]
KryoStofferCDot: Just reverting that commit and the problem whent away in RC2. [13:17]
CDotperfect, that's what I expected. OK, your patch is good to go :-) [13:18]
KryoStofferBut if infact someone is stille having the original issue, there is somewhere else where Response body is not encoded as it should. [13:19]
gac410Hi CDot ... I suppose that this should be motivation to get me to move f.o to RC2 (plus the patch) to give fcgi a better workout :(
Probably what I'll do is build an RC3 for our own use, and install that on f.o
[13:28]
.................................. (idle for 2h46mn)
CDot: Just checking before it gets too late. Are you going to check in the revert... Are other fixes needed? [16:18]
.... (idle for 16mn)
CDotgac410: I will check in. Sorry, had to go out [16:34]
gac410: I need a Task for checking in pseudo-install fixes - do you have one open? [16:45]
gac410none that I know of [16:45]
CDotokely, checked in [16:49]
GithubBot[distro] cdot pushed 3 new commits to master: http://git.io/vqeu1
distro/master c1ab6f5 Crawford Currie: Item12888: badly written test not really failing
distro/master fcda11d Crawford Currie: Item10751: over-enthusiastic encoding
distro/master ff72a0e Crawford Currie: Item12416: make 'all' work, plus make git_excludes less noisy to avoid occluding errors
[16:49]
***GithubBot has left [16:49]
FoswikiBothttp://foswiki.org/Tasks/Item12888 [ Item12888: Unit tests are failing ]
http://foswiki.org/Tasks/Item10751 [ Item10751: FastCGIEngineContrib "Wide character..." errors w/UTF-8 Foswiki ]
http://foswiki.org/Tasks/Item12416 [ Item12416: use pseudo-install to list all available contribs ]
[16:50]
***ChanServ sets mode: +o Lynnwood__ [16:57]
...... (idle for 27mn)
gac410Thanks CDot ... Stuff to do while it's light out, but I'll work on an RC3 & f.o migration tonight. I suspect some of our default extensions won't work on 1.2
I'll install another vhost, and add a local name in my hosts file for now until it's working. probably f200.foswiki.org
[17:24]
........................... (idle for 2h13mn)
jomohm.. some new errors - try edit with wysiwyg http://trunk.foswiki.org/Sandbox/Úň%C3%ADčôďě/ÁťťáčhméňťŤôp%C3%ADč [19:39]
gac410What's supposed to happen? [19:40]
jomothe wysiwig should show the images inline - now shows the broken ones... [19:42]
gac410Ah. okay [19:43]
..... (idle for 22mn)
jomo, if you view the html, any ideas on what is going wrong? Is it double-encoded? [20:05]
jomobecause im on the OSX havent idea ;( - going try to analize [20:07]
.... (idle for 15mn)
yes, after the URI::Unescape it seems to be triple encoded or such and differently the parts, e.g. the filename is differently as the Web/Topic... [20:22]
gac410Okay. Probably something down in Wysiwyt TML2HTML [20:23]
jomobut IIRC this worked (some checkins ago) [20:29]
so, the Web/Topic is double encoded - the image is OK... e.g. when trying simply attach the wide-name image to the plain Sandbox/TestTopic - it shown in WYSIWYG. The problem occured when the web/topic name contains wide chars... [20:38]
gac410Hey CDot ... you around?
Any idea about where wysiwyg would be double-encoding Web/Topic for attachments in the edit window?
looks as though the calls to encode are properly dependent upon $Foswiki::UNICODE
[20:39]
FoswikiBothttp://trunk.foswiki.org/System/PerlDoc?module=Foswiki::UNICODE [20:42]
...... (idle for 25mn)
gac410Jomo, well a *partial* fix ... just tested on t.f.o is to NOT call CGI::unescape on the attachment params.
Try it again, and *some* of the images are fixed. But not all.
Not going to fix it this way though - I don't understand the issue. This one really needs CDot
After you look I'll reverse the change - don't want to have local changes in the repo.
[21:07]
jomothe second image what doesn't fixes has <img src="%ATTACHURLPATH%/%UVALFAKEASCII%.jpg"> - e.g. has a macro in the name... maybe it isn't supported.. [21:09]
gac410No that should be supported.
I think the macros have to be un-escaped to be expanded, but not the text. just guessing.
[21:10]
jomoCDot will knows :) [21:11]
gac410anyway, changes reverted.
in lib/Foswiki/Plugins/WysiwygPlugin/Handlers.pm sub _populateVars, I commented out the CGI::unescape call.
[21:11]
...... (idle for 25mn)
jomominor: the natedit's help references an unexistent image: /System/NatEditHelpText/wikitext.png [21:37]
gac410hm I thought that image was removed. I'll restore it and add it to the manifest
[off} gotta go ... back later
[21:40]
jomo"0
:)
[21:44]
...................... (idle for 1h47mn)
gac410jomo, I sorta have an idea of what's going on, but I'm pretty confused on how to fix it. I've duplicated it locally, copying your files so I coudl data::dumper stuff. [23:31]
jomoFor CDot as for the author will be probably easier... [23:36]

↑back Search ←Prev date Next date→ Show only urls(Click on time to select a line by its url)