#foswiki 2015-11-20,Fri

↑back Search ←Prev date Next date→ Show only urls(Click on time to select a line by its url)

WhoWhatWhen
RiskRewardOK, he's in, thanks. Now back to that email problem. [00:06]
gac410Just try installing that contrib. It only installs a single module lib/CPAN/lib/Authen/SASL/Perl/NTLM.pm And also has a CPAN dependency of Authen::NTML

I don't have access to an exchange server so I've not tested it.
[00:09]
......... (idle for 40mn)
RiskRewardI ended up setting up a custom connector in Exchange for the wiki client. The NTLMcontrib didn't seem to do anything. I'll look into it more, but things are working for now. [00:49]
........................... (idle for 2h14mn)
***ChanServ sets mode: +o gac410 [03:03]
..................................... (idle for 3h3mn)
GuilainC_away is now known as GuilainC [06:06]
.......... (idle for 47mn)
ChanServ sets mode: +o CDot [06:53]
..... (idle for 24mn)
GuilainC is now known as GuilainC_away [07:17]
............................ (idle for 2h16mn)
ChanServ sets mode: +o MichaelDaum [09:33]
......................................... (idle for 3h24mn)
ChanServ sets mode: +o Lynnwood [12:57]
........ (idle for 38mn)
ChanServ sets mode: +o gac410 [13:35]
............. (idle for 1h2mn)
jasthey George, I'm leaving now, just quickly wanted to let you know 02x00 is on the translate server now. I haven't added any Item number to the commit message yet. [14:37]
***ChanServ sets mode: +o CDot [14:40]
gac410Okay Thanks jast! [14:45]
***gmc_ has quit IRC (Ping timeout: 240 seconds) [14:48]
gac410CDot regarding the backdating issue. I did look for options for backdating, but did not find one. Either that or I didn't understand the options. I think I even googled and only could find "Don't do that" for advice.
And in thinking about the extension installer not installing files, that was the first thing I thought of. I *think* I ruled it out, but maybe not. Too long ago :(
[14:54]
............... (idle for 1h13mn)
JacobEtchestesting foswiki:System.VarMETA, and it claims to have a topic argument, but that argument seems to be ignored. When I use %META{"parent" topic="%BASEWEB%.%BASETOPIC%"}% I get the parents of %TOPIC% instead. Am I misinterpreting the documentation? Or is there another way to get all parents of a BASETOPIC efficiently? [16:08]
***ChanServ sets mode: +o CDot [16:16]
foswiki_irc8I have installed foswiki on Ubuntu to act as an intrAnet app. I have the bootstrap screen displayed, but when I click on the "configure" link, I get a gateway timeout. The file it is looking for is there, but it doesn't run (or it's running and can't find something). If I go straight to foswiki/bin/configure, the menu on the left part of the page displays, but nothing in the right side.
I've seen this done, and I know I'm missing something
[16:27]
gac410It sounds like the json script isn't working. If you visit bin/configure directly and trace the NET requests using your browser debug tools, you should see a POST to jsonrpc. See if any of them are failing.
Either that or maybe bootstrap discovered the wrong path. Hover over the configure link on the bootstrap message. Does the URL look correct?
Are you using Apache on ubuntu?
[16:29]
foswiki_irc8It's displaying the path based on /foswiki being the root. We need to access it with the machine IP addres preceding it. Should I amend the path it is looking for?
Yes, apache on Ubuntu
the button at the top of the page shows the correct path to the app
http://192.168.111.245/foswiki/bin/view
[16:31]
gac410How did you generate the apache configuration? Foswiki:Support.ApacheConfigGenerator [16:33]
FoswikiBothttp://foswiki.org/Support.ApacheConfigGenerator [ ApacheConfigGenerator ] [16:33]
foswiki_irc8yes with the generator
vi'd the file under apache and pasted it in
[16:33]
gac410hm ubuntu should be really well tested. That's the OS we use for our VM image, and what most of my testing machines use. [16:34]
foswiki_irc8I tried this back in August and had to give up once I got here. [16:35]
gac410When you used ApacheConfigGenerator, did you click the "Short URLs" button?
Is this machine dedicated for Foswiki? And will you eventually use a hostname, or will it always be by the IP address?
[16:36]
foswiki_irc8I don't recall. Shall I re-run it and replace what is there? [16:37]
gac410could you paste your apache configuration into http://pastebin.com/ (Choose a short lifetime - 1 hour or so ) [16:38]
foswiki_irc8ok, a revision to the apache generator casued something to show up. thanks for the suggestion!
(I had to put in the IP address as the host. Seems obvious, but...)
[16:47]
gac410okay great [16:47]
foswiki_irc8Any advice on things to watch out for during configuration? [16:48]
gac410If you used short URLs, (recommended and the default) your ULR should look like http://192.168.111.245/foswiki (leaving off the bin/view [16:48]
foswiki_irc8yes, it does [16:49]
gac410And you could also have set the path to just '/' so you don't even need the foswiki
(but only if that server is dedicated to foswiki)
[16:49]
***ChanServ sets mode: +o Lynnwood [16:49]
gac410Only thing I can suggest on configure. Probably best to set an Admin password ... under Security & Authentication, Passwords tab. [16:50]
foswiki_irc8Hold on... Only the first screen appearred...
BTW, I DID put the config on pastebin
[16:50]
gac410you need to send me the pastebin URL
if you want me to look ;)
[16:51]
foswiki_irc8http://pastebin.com/XPg6Vrmb
Sorry, it's been quite a few years since I was this deep into the OS...
[16:52]
gac410hm that apache configuration doesn't look right at all.
All the paths using http://192.168... that isn't right. It shoud not have the hostname.
[16:53]
foswiki_irc8Edit it with vi? [16:54]
gac410no. I'd suggest regenerating. Let me go try it with IP address and see what it generates. [16:55]
foswiki_irc8thanks [16:55]
***chipsinchief has left [16:55]
gac410foswiki_irc8: If your server is dedicated to foswiki, I'd use something like this. No vhost, This one is apache 2.4
http://foswiki.org/Support/ApacheConfigGenerator?vhost=;port=;dir=/var/www/foswiki;symlink=;pathurl=/;shorterurls=enabled;engine=CGI;fastcgimodule=fcgid;fcgidreqlen=;apver=2;confighost=;configip=;configuser=;loginmanager=Template;htpath=;errordocument=UserRegistration;errorcustom=;disablephp=on;blockpubhtml=;blocktrashpub=;controlattach=;blockspiders=;foswikiversion=2.0;apacheversion=2.4
That is the shortest URLS. Your URL would be 192.168..../ (no foswiki or bin needed)
[17:03]
foswiki_irc8It's not dedicated to it... We run Kimai timekeeping and PDF processing. [17:04]
gac410Same web server?
ie http://192.168..../kimai for the kimai timekeeping
I should have been more specific. If your *apache web server* is dedicated to foswiki. Other non-http stuff doesn't matte.r
[17:04]
foswiki_irc8yes
so paste that in?
[17:06]
gac410You cannot really do vhosts when just using an IP. so dedicated apache sounds right. You should be able to click that url if your irc client allows. [17:07]
foswiki_irc8I did a right click into another window. It's in place. Do I need to restart to apache after making the update? [17:09]
gac410restart or reload
service apache2 reload
[17:09]
foswiki_irc8looking a lot better this time... [17:12]
gac410great [17:14]
foswiki_irc8Is there something critical I should be looking for in the configuration set up? I see sever warning icons, but I don't see a need to change anything [17:19]
gac410No, the warnings just suggest things to check. Like setting an admin password, configuring email, etc. [17:20]
foswiki_irc8If the mail server is on another host, does that cause problems? [17:20]
gac410Generally the are probably good to consider each warning, but not all need to be handled For ex, if you never will import old Foswiki 1.x data, you can ignore some.
If your web server itself is already set up to send mail (for ex cronjob messages, root messages, etc) then all you should need to do is to enter the webmaster email address and click the autoconfigure button.
We should detect the already existing sendmail or ssmtp ,
If not, then you need to fill in the email server hostname, mail.yourhost.com, or I suppose 192.168.x.x, and probably a user and password
[17:21]
LynnwoodMichaelDaum - if you're around this today, I'm noticing minor odd behavior in SolrPlugin after having just updated it (along with NatSkin et al). If one enters a term in the top-right searchbox and then hit return, one is taken to WebSearch, but the search term provided does not get entered into the search field, nor is it included in the ajax call that renders the search results.
The searchbox pass urlparam "search" to WebSearch but it appears that the ajax call is looking for "#q=search term"
any thoughts on what might have changed appreciated
[17:25]
MichaelDaumHi Lynnwood [17:27]
Lynnwoodhey there [17:28]
MichaelDaumthe search box uses an urlparam when SolrPlugin is _not_ installed
and otherwise a #q=search anchor
[17:28]
Lynnwoodah... ok
that would explain perhaps
that gives me lead... just need to determine why wrong search box was being loaded.
[17:28]
jastin older versions of SolrPlugin, a url param was used, too [17:31]
MichaelDaumvery old SolrPlugin [17:32]
Lynnwoodso... presummably viewtopbar.solr.tmpl should be loading [17:33]
MichaelDaumnot with natskin [17:33]
Lynnwoodjust topbar.nat.tmpl? [17:34]
MichaelDaumy [17:34]
Lynnwoodthat's odd then... cause that's the one that i was using.... Guess i need to compare it to the distribution. [17:35]
should solr-searchbox.js be getting loaded?
(it's not)
[17:40]
................ (idle for 1h18mn)
JacobEtches%META{"parent" topic="%BASEWEB%.%BASETOPIC%"}% lists the parents of %TOPIC% and not BASETOPIC. Am I misinterpreting the documentation? Or is there another way to get all parents of a BASETOPIC efficiently? [18:58]
gac410looking ... may take a bit
META is more for use in templates, displaying the current topic. Try for ex: %QUERY{"'System.DocumentGraphics'/META:TOPICPARENT.name"}%
Detailed in Foswiki:System.QuerySearch ... the fields are in common in %QUERY and %SEARCH type=query
[19:02]
FoswikiBothttp://foswiki.org/System.QuerySearch [ QuerySearch ] [19:05]
JacobEtchesgac410: Thanks, but isn't that only the immediate parent? [19:06]
gac410%META would be the same thing. Hm Not sure if there is an easy way to follow the tree of parents. ... thinking... [19:06]
JacobEtches%META gives all parents, with a separator (default is >), as shown in breadcrumb [19:08]
gac410hm learn something every day. [19:09]
JacobEtchesit's a really useful piece of information for making topics aware of their location in the site map
but I can't find a simple way of generating it in a topic
don't want a lot of overhead
[19:09]
gac410JacobEtches: ... it seems to be workig here. What release of foswiki are you using? [19:18]
JacobEtches1.1.4 and 1.1.9
let me double check 1.1.9
[19:18]
gac410hm I'd have to go back and try them I'm testing on 2.0.3 [19:18]
JacobEtchescan you copy your syntax?
maybe I'm doing something stupid
1.1.9 is the same
[19:19]
gac410BASEWEB is %BASEWEB% BASETOPIC is %BASETOPIC%
%META{"parent" topic="%BASEWEB%.%BASETOPIC%"}%
... and then I included that topic elsewhere to see the parent change.
[19:21]
JacobEtchesgac410: thanks, that's exactly the behaviour I wanted, but for some reason I'm not getting it. [19:22]
gac410Not working on 1.1.9 [19:25]
JacobEtchesRats.
Thanks for taking the time to check for me.
[19:26]
gac410Even viewing the TestInclude, ohh,.... maybe I didn't set a parent
Doh.... let me keep testing
No definitely not working I get the parent of the included topic.
[19:26]
JacobEtchesSo it's not me.
Thanks again. Any alternatives spring to mind?
[19:28]
gac410Not really, Probably building something with QuerySearch? I don't really know. Upgrade to 2.0.3? ;) [19:31]
JacobEtchesI know...
That's the obvious solution. But I suspect will not be time saving.
[19:31]
gac410no. It is a pretty big upgrade effort. But so far feedback has generally been good.
The jump to UNICODE though takes some work.
[19:32]
JacobEtchesGood to hear. Thanks for your help! [19:33]
LynnwoodIs NatSkin not in github?
i can't seem to find it...
[19:41]
gac410https://github.com/foswiki/NatSkin [19:42]
Lynnwoodok. i just found it also... still trying to find my way around. [19:43]
GithubBot[distro] FoswikiBot pushed 1 new commit to master: http://git.io/v4Noj
distro/master 85ad568 Vadim Belman: Item13505: Translations updated using Weblate (Ukrainian)...
[19:45]
***GithubBot has left [19:45]
FoswikiBothttp://foswiki.org/Tasks/Item13505 [ Item13505: Translations for Foswiki 2.0.x / 2.1.0 ] [19:45]
gac410working fine here.
vrurg: jast just added the Release 2.0 branch into weblate. If we need to release a 2.0.4, it will come from there. We probably missed your last translations.
I might be able to sync up the .po files, but don't want to break anything ...
[19:48]
vrurggac410: you can pick up what's in the repo now. I might add few changes today but not much probably.
No rush, everything must be done in the best manner. :)
[19:55]
gac410okay. [19:57]
vrurgWould be nice to have it in the master to merge it into my branch. This would give me the chance of polishing the translation. Some phrases are looking good in weblate but being put into context turns ugly. [20:02]
***ChanServ sets mode: +o Lynnwood [20:04]
gac410weblate should be in sync with master, Release01x01 and Release02x00 branches in git. What I'm concerned with is the Releas02x00 branch missed translations for the last few days.
I'm just not sure if I can take the master uk.po, copy it over the Release02x00 uk.po, push it and import it successfully back into weblate.
[20:04]
vrurgWhy not? If it's not about technical issues then I see no reason why not to do it. [20:07]
gac410Actually looks like Release02x00 uk.po is about 5 days behind.
-"PO-Revision-Date: 2015-11-15 01:03+0200\n"
+"PO-Revision-Date: 2015-11-20 19:06+0200\n"
[20:07]
vrurgGeorge, let's put it this way: Ukrainian isn't the most popular translation anyway. It won't play any signifact role in popularizing Foswiki. What I do is solely because I love the language and want it be represented in best possible way.
But if it lags behind in production releases – it's totally ok.
[20:10]
gac410I pulled the master uk.po into the Release02x00 branch. They *should* be identical, since no real work has been done on the Release02x00 branch.
I'm about to push. If it goes boom ... jast will have some work ;)
[20:11]
GithubBot[distro] gac410 pushed 1 new commit to Release02x00: http://git.io/v4NHv
distro/Release02x00 78c3f2d George Clark: Item13505: Sync uk translation from master
[20:12]
***GithubBot has left [20:12]
vrurgOk, then I stop transferring newer translation in weblate and focus on fixing fuzzy and finishing with untranslated. [20:13]
GithubBot[distro] FoswikiBot pushed 1 new commit to master: http://git.io/v4NHg
distro/master 7b33f62 Vadim Belman: Item13505: Translations updated using Weblate (Ukrainian)...
[20:13]
***GithubBot has left [20:13]
gac410Nope. I broke it ... [20:13]
vrurgvrurg can do nothing else until receives an important call [20:13]
gac410damn. Release02x00 is now unable to pull or push or rebase. Failed to rebase our branch onto remote branch Foswiki/Distribution release 2.0.
Okay that needs Jast to fix.
[20:14]
vrurgEverything is good about git except it's fragility. But it's the price tag for flexibility... [20:15]
gac410It should be really easy for jast to fix. Just need the command line to resolve. The "pushme" buttons on weblate don't do it.
Because you've been changing it, (I didnt' realize that) and I wholesale copied over the master translation to Release02x00, things are screwed.
hm. I wonder if I do a reset HEAD^ to remove my commit, then force push it to github. .. but I don't think I want to try that.
I'm afraid I can only make it worse.
[20:16]
vrurgYou won't. Hard reset simply will revert to some consistent state. There is no changes to be saved – all important ones are in the master. Then copy it over again – and voilà! [20:20]
gac410okay let me try. locally I'll do a git reset HEAD^ --hard, on Release02x00 branch. Then push it to github. Probably have to force.
Then pull on weblate and see if it goes back in sync.
That sound reasonable?
[20:22]
vrurgYeps.
Just avoid forcing.
[20:23]
GithubBot[distro] gac410 force-pushed Release01x01 from b72dbb6 to 1c3ed01: http://git.io/v4NF0 [20:24]
***GithubBot has left [20:24]
vrurgIf hard reset doesn't do it properly – better let it be fixed manually.
Ok, too late... :D
[20:24]
GithubBot[distro] FoswikiBot pushed 2 new commits to master: http://git.io/v4NFF
distro/master 7b33f62 Vadim Belman: Item13505: Translations updated using Weblate (Ukrainian)...
distro/master b6e5aeb Vadim Belman: Item13505: Translations updated using Weblate (Ukrainian)...
[20:25]
***GithubBot has left [20:25]
FoswikiBothttp://foswiki.org/Tasks/Item13505 [ Item13505: Translations for Foswiki 2.0.x / 2.1.0 ] [20:25]
gac410Okay everything is in sync. [20:25]
vrurgHurray! :D [20:26]
gac410gac410 now leaves well enough alone. [20:26]
vrurgThanks gac410 . You saved me some good amount of time. [20:27]
.......... (idle for 49mn)
LynnwoodWeird... i just can't get foswiki.org to load [21:16]
...... (idle for 26mn)
gac410 - I'm looking at github changes associated with "Item13617: fixed default topictitle implementation" [21:42]
FoswikiBothttp://foswiki.org/Tasks/Item13617 [ Item13617: Error in default topictitle implementation. ] [21:42]
Lynnwoodopps
wrong one
Item13619: Remove RevComment from templates
[21:42]
FoswikiBothttp://foswiki.org/Tasks/Item13619 [ Item13619: RevCommentPlugin not compatible with Foswik 2.0 ] [21:43]
LynnwoodSo i understand that it was removed because it is not compatible with 2.0. I'm having to add it back to NatEditPlugin because site is using it (and we're still using 1.1.9)
But i'm curious about it's future. Is it fundamentally incompatible with 2.0 or just needs to be fixed for 2.0.
?
[21:44]
gac410No, it should be compatible.
The changes I made were backwards compatible, but you need to add a skin to augment it.
Definitely tested on 1.1.9 and 2.0
in the Extension topic: For a Foswiki 1.1 system, Set SKIN = revcom11,pattern
and... For a Foswiki 2.0 system, Set SKIN = revcomment,natedit,pattern
For Nat skin, I'm guessing either revcomment,nat or it might need adjustments.
[21:49]
Lynnwoodok
thanks so much
[21:52]
gac410If you have some specific suggestions for natskin, please open a task ;)
Ah... http://foswiki.org/Extensions/RevCommentPlugin has comments about "other skins" and what it needs.
the main change I made was to rename the formfield from 'comment" to "revcomment". Unfortunately the new CommentPlugin was picking up and applying revcomments as comments because of the collision
[21:55]
Lynnwoodyep.. i get what's happening now. [21:57]
gac410Much cleaner this way, avoids the %IF statements sprinkled through the core templates for a non-default extension. [21:58]
Lynnwoodyes.
veerry goood ;-)
[21:58]
gac410btw, in Extensions/Testing is a PatchRelease01x01Contrib. ... It backports a few 2.0 features, and also patches all the perl deprecations and things broken by the new CGI
I've tested it on 1.1.0 thru 1.1.9. but it really needs another set of eyes or two.
Also I'll probably release 1.1.10 this weekend, now that CDot confirmed that the test failures are not significant.
[21:59]
Lynnwoodon the new CGI - where does that show up? Is it included as part of latest apache or something else? [22:01]
gac410No it's a CPAN module. It will badly break foswiki 1.1 [22:01]
Lynnwoodi haven't run into any issues with it yet. [22:02]
gac410configure won't run - param() used in list context, and module wont even load use CGI qw(-any); ... any pragma is deprecated [22:02]
Lynnwoodah i have seen that now... [22:02]
gac410And distros are picking up the new CGI because some of it is security patching. The param() in list context is a security change.
For 1.1, I remove all the -any references, and just disable the list context warning. 2.0 handles the security change and now uses multi_param where appropriate, or scalar param() if a single variable is needed.
the security flaw is subtle, no idea if we are *actually* vulnerable. but it's published. say you do SomeFunction( $rrequest->param('blah'), $someOtherVar )
The attacker can "shift" the $somOtherVar out by passing url blah=1;blah=2. poof ... param() returns a list, and shifts the arguments to someFunction
2.0 completely closes that. patched 1.x / 1.1.10 turns off the warnings.
maybe a routing issue? I'd offer to ping, but f.o jail has ping blocked. so I can't trace from the server outbound
Try a tracert or tracepath ... see where it stops.
[22:02]
Lynnwoodgood idea. i just tried pinging from an external server and it worked. [22:11]
gac410perl 5.23 is nasty. Can't use { in regex now without escaping it. So ever darn regex that tries to match SOMEMACRO{ or META:{ dies. [22:12]
Lynnwoodoh gawd [22:13]
gac4101.1.10 and 2.0.3, and the PatchRelease01x01Contrib fix it. But lots of extensions will need TLC [22:13]
Lynnwoodregarding foswiki.org, it traces to some server/router for charter (my ip) but seems to stall there.
so weird... never seen this before.
[22:16]
gac410I'm on charter business internet here. [22:16]
Lynnwoodgoes from boone, to hickory, to atlanta and then stalls [22:17]
gac410I go from oxfr.ma nwtw.ct asbh.va unas.mo, and then off to other providers. [22:20]
Lynnwoodsure enough... i tried the ip as well and same thing. Bounce through several nodes but then stalls in atlanta.
i have to assume it will sort itself out...
[22:23]
gac410yeah. I suppose you could open a ticket with charter, but that is rather futile. [22:27]
Lynnwoodi can reach it again...
ok. long day. i'm off
[22:36]
gac410g'night [22:37]
Lynnwoodsame to you! thanks for the help [22:41]
............. (idle for 1h2mn)
GithubBot[distro] FoswikiBot pushed 1 new commit to master: http://git.io/v4AAJ
distro/master f068d82 Vadim Belman: Item13505: Translations updated using Weblate (Ukrainian)...
[23:43]
***GithubBot has left [23:43]
FoswikiBothttp://foswiki.org/Tasks/Item13505 [ Item13505: Translations for Foswiki 2.0.x / 2.1.0 ] [23:43]
GithubBot[distro] FoswikiBot pushed 1 new commit to Release02x00: http://git.io/v4AAk
distro/Release02x00 2b562fa Vadim Belman: Item13505: Translated using Weblate (Ukrainian)...
[23:43]
***GithubBot has left [23:43]
geetar has left [23:57]

↑back Search ←Prev date Next date→ Show only urls(Click on time to select a line by its url)