#foswiki 2016-04-26,Tue

↑back Search ←Prev date Next date→ Show only urls(Click on time to select a line by its url)

WhoWhatWhen
itogreetings! i'd like to disable a shortcut on a topic/page. what should i enter in 'Edit topic preference settings' to disable the %Y% shortcut? i couldn't find the info in the documentation.
^^^ it's messing up strftime() in sqlplugin...
[02:28]
.......................................... (idle for 3h28mn)
***ChanServ sets mode: +o CDot [05:58]
.... (idle for 15mn)
ChanServ sets mode: +o MichaelDaum
ChanServ sets mode: +o Lynnwood
[06:13]
........ (idle for 35mn)
jastito: * Set Y =
((multiple of) three spaces, as always with preferences)
though that will expand %Y% to the empty string
if you want to avoid expansion, use %<nop>Y%
though it's possible that that will mess up your SQL, too
[06:49]
....... (idle for 32mn)
***ChanServ sets mode: +o Lynnwood [07:22]
............................. (idle for 2h23mn)
GithubBot[FeedPlugin] MichaelDaum pushed 1 new commit to master: https://git.io/vwgX9
FeedPlugin/master 9af5625 MichaelDaum: Item14057: fixed docu; fixed discover parameter
[09:45]
***GithubBot has left [09:45]
FoswikiBothttps://foswiki.org/Tasks/Item14057 [ Item14057: typos in docu; "discover" parameter is nonfunctional ] [09:45]
.......... (idle for 45mn)
itojast: tnx! unfortunately your hunch was right.
%SQL{"select strftime('%<nop>Y%<nop>m%dT%<nop>H%<nop>M%S', datetime('now'))"}% seems to mess up the sqlplugin too.
[10:30]
jastanother thing to try: %!Y%, but I'm not sure if that's actually processed differently [10:31]
MichaelDaumwrap it into <literal>%SQL ... </literal> [10:31]
jast<literal> does not affect macros, does it?
only TML rendering
[10:31]
GithubBot[FeedPlugin] MichaelDaum pushed 1 new commit to master: https://git.io/vwgQk
FeedPlugin/master 873f427 MichaelDaum: Item14058: added support for non-unicode engines
[10:44]
***GithubBot has left [10:44]
FoswikiBothttps://foswiki.org/Tasks/Item14058 [ Item14058: encoding problems on a non-unicode foswiki engine ] [10:44]
..... (idle for 20mn)
itonope :-( neither %!Y% nor '<literal>%SQL...</literal>' seem to do the trick (regardless if the shortcuts %Y%, %m%, %H% are disabled or not). [11:04]
MichaelDaum%SQL{"%ENCODE{"your query"}%" decode="url"}%
%SQL{"... %25Y%25..." decode="url"}%
[11:10]
.... (idle for 19mn)
itoMichaelDaum: tnx! :-) %SQL{"select strftime('%25Y%25m%dT%25H%25M%S', datetime('now')) as datetime" decode="url"}% does the trick! (with or without disabled shortcuts) [11:31]
MichaelDaumyay :) [11:32]
...... (idle for 29mn)
***ChanServ sets mode: +o Lynnwood__ [12:01]
.......... (idle for 46mn)
ChanServ sets mode: +o Lynnwood [12:47]
andreliHi, fighting with some stubborn cache situation. Is there any unfortunate conflict between Foswiki cache and DBCache known?
In my topics preferences I set CACHEABLE to off, but the DBQUERY does not update!
[12:52]
foswiki_irc9Hello!
I can't create a new Topic. The Form appears but i can't submit it
[12:59]
***ChanServ sets mode: +o Lynnwood [13:15]
ChanServ sets mode: +o gac410 [13:24]
uebera||foswiki_irc9: are you referring to your own installation or foswiki.org? [13:30]
foswiki_irc9My own foswiki. Its running on Ubuntu
I can click in the WebLeftBar on "Create new Topic" and insert Topic name or chosse template but if i want to submit it the button "submit" is only a normal text and i can't click it. The same is with the cancel button
[13:33]
gac410foswiki_irc9: sounds like javascript might be blocked? Or a templates issue? Is this a new install or an upgrade. [13:40]
foswiki_irc9Javascript works... if I make a new topic over the "new" button (on the top right) it works. It is a new installation with migrated Webs from an old installation
in apache error.log i get an error: "view: Use of uninitialized value in string eq at /var/lib/foswiki2/lib/Foswiki/Users/TopicUserMapping.pm line 574., referer: http://foswikidevsrv/foswiki2/bin/view/Main/WebHome" Login is over apacheLdap
[13:42]
gac410"New button on top right???" what skin are you using. That doesn't sound familiar. [13:44]
foswiki_irc9I got NatSkin installed [13:46]
gac410CDot ... Do you have time to look at the UserRegistration process on Foswiki.org? For some reason I always get a strikeone validation redirect. But it works fine locally, even using copies of the customized registration page.
foswiki_irc9: Sorry, I can't help with NatSkin. .. I'd say ask MichaelDaum but he doesn't seem to be around right now.
[13:46]
foswiki_irc9Oke - Thanks ! I will give a try and disable NatSkin [13:48]
gac410CDot ... I'll release 2.1.1 this weekend after seeing the logs rotate on the 1st. ... just hoping there is not a lurking bug in registration. [13:49]
foswiki_irc9@gac410 With pattern it works... so it seems a problem with NatSkin - Thanks [13:53]
gac410MichaelDaum might have some testing versions available of NatSkin to install.
Look at the extensions in Foswiki:Extensions/Testing.WebHome
[13:53]
FoswikiBothttps://foswiki.org/Extensions/Testing.WebHome [ WebHome < Extensions/Testing < Foswiki ] [13:54]
foswiki_irc9No NatSkin [13:55]
gac410foswiki_irc9: The thing with NatSkin is not the skin but the very large number of other extensions that it depends on. So it might be one of the extensions NatSkin uses, rather than the skin itself. Probably best to wait for advice from Michael, or someone else who uses NatSkin. [14:02]
foswiki_irc9I'm not in hurry ;) The number of extension is really huge... Don't know if i need them all [14:07]
gac410yeah. NatSkin is really great! But the complexity can be daunting at times. [14:08]
foswiki_irc9by the way. If i launch tools/depencies i got followed string: "Foswiki::Plugins::JQueryPlugin version >= 7.00 required-- installed version is 03 Feb 2016" Can i ignore that or where can I find Version 7 ? [14:09]
FoswikiBothttps://trunk.foswiki.org/System/PerlDoc?module=Foswiki::Plugins::JQueryPlugin [14:09]
gac410hm Sounds like a bug in a dependency file. I think 3 Feb 2016 is very recent.
hm strange. If I look at the dependency report on f.o, it shows Foswiki::Plugins::JQueryPlugin 7.04 installed for
EditRowPlugin: JQuery
Used by: EditRowPlugin, NatEditPlugin
[14:09]
foswiki_irc9i downloaded the plugin from http://foswiki.org/Extensions/JQueryPlugin [14:13]
gac410Ah..... Okay. Foswiki.org is running the 2.1.1 RC1
Right, we are "ahead" of the released extensions. See Foswiki:Extensions/Testing/JQueryPlugin
[14:13]
FoswikiBothttps://foswiki.org/Extensions/Testing/JQueryPlugin [ JQueryPlugin < Extensions/Testing < Foswiki ] [14:14]
gac410If the logs rotate successfully on Saturday night, I'll be releaseing 2.1.1 on Sunday and will upload all the new extensions right after. [14:15]
foswiki_irc9Awesome thanks ;) but that didn't fix my Topic issue :D...
may I delete the "Create Topic" button in the left bar and the users create new topics over the "New" Button
[14:16]
gac410What release did you upgrade from? ... just curious if you did the unicode/utf8 conversion and how it went. [14:20]
foswiki_irc9Foswiki-1.1.9, Plugin API version 2.2
All webs are migrated by the bulk_copy
[14:21]
gac410nice [14:23]
foswiki_irc9Has MichaelDaum a mail adress or something ? [14:26]
gac410He is almost always on irc round this time.
FoswikiBot: seen MichaelDaum
[14:28]
FoswikiBotgac410: MichaelDaum was last seen in #foswiki 2 hours 56 mins ago saying "yay :)". [14:28]
foswiki_irc9I'm such a lucky guy :D
One last question. Is it a problem to copy the main web of the old release? I've done that for the groups - Or is this also covered by the bluk_copy
[14:28]
gac410You should be able to copy Main without issues. The really critical one to NOT copy is System web.
The reason to use bulk copy is to convert any iso-8859 or cp1252 or whatever characters into utf-8. If topics are plain ascii, they you don't really need bulk_copy (or CharsetConverterContrib
[14:31]
jastanother reason is to switch to a different store implementation (e.g. the new default PlainFileStore in foswiki 2) [14:33]
gac410Oh... yes indeed correct. Oops.
One warning about PlainFile ... Never "touch" a plain file store file. The .txt or .pfv files. The change history depends on the file system timestamps being accurately preserved and consistent.
[14:33]
foswiki_irc9Oke but PlainFile is Best practise ? [14:37]
jastwhere I work we use it for all new wikis [14:37]
gac410foswiki_irc9: ... PlainFile is new, faster, and our default. RCS is old but very thoroughly "broken in", used by many many implementations.
So I can't say for sure if one really is the best practice. Much depends on your operation.
[14:39]
foswiki_irc9honestly I have no clue ... I'm working with foswiki for 3 days now [14:45]
jastjust use PlainFileStore, you'll be fine [14:46]
gac410+1 [14:47]
jastbulk_copy is a bit quirky at times but that only affects migration, not normal operation [14:47]
foswiki_irc9Allright thanks ! [14:50]
AndreR_No i have a Name :D
*now
[14:52]
jastwelcome back :) [14:53]
AndreR_Thanks! [14:53]
***uebera|| has quit IRC (Quit: ZNC) [15:05]
ChanServ sets mode: +o MichaelDaum [15:19]
............................. (idle for 2h20mn)
gac410Ah MichaelDaum ... you're back. Someone earlier was having trouble with natSkin on 2.1 ... the left bar create a new topic rendered with a un-clickable un-styled create button.
I was rather useless for advice.
[17:39]
MichaelDaumneeds JQueryPlugin from testing [17:45]
gac410He did try that but it didn't help
Though maybe he didn't do it right.
Anyway he knows to look for you if he comes back :D
[17:45]
MichaelDaumplus they probably applied the wrong SKIN setting
must be SKIN = nat
nothing else
[17:46]
gac410right. No natedit. [17:46]
MichaelDaumand no pattern either. otherwise you get a strange sidebar navigation ... as the error report indicates [17:46]
gac410He was trying to migrate a 1.1.9 system. He installed new, and then bulk_copied the webs.
If he comes back and you are not around I'll try to remember to mention the SKIN setting
[17:47]
MichaelDaumthanks a lot
have to leave again
c.u.
[17:47]
gac410okey.
cu
[17:48]
........ (idle for 37mn)
MikeofManyAny ideas on why one would get a 500 internal service error when trying to register a new user? [18:25]
uebera||MikeofMany: On foswiki.org?
In that case, just try again (more gently)...
[18:32]
MikeofManyon a new install of foswiki 2. [18:32]
uebera||Hm... did you look at the server logs? Are you using ldap related plugins, ...? [18:34]
MikeofManyno ldap plugins, server logs and foswiki logs are not really helpful
error client called /var bin register line 29 refererer userRegistration..
[Tue Apr 26 11:34:02 2016] [error] [client 10.10.6.243] \tError::subs::try('CODE(0x6211e0)', 'HASH(0x1544a00)') called at /data/www/wiki/lib/Foswiki/UI.pm line 500, referer: https://cidc-wiki.net/System/UserRegistration
[18:36]
uebera||For the record: which version of Perl, which OS are you using? [18:44]
MikeofManyperl 5.10.1 centos 6.5 not upgraded to 7
so 6.7 centos
[18:45]
uebera||I'm not using centos (Lavr?), but we had a number of reported cases with "500" errors in the recent past--maybe the logs (http://irclogs.foswiki.org/bin/irclogger_log/foswiki) contain a similar case...
E.g., see http://irclogs.foswiki.org/bin/irclogger_log/foswiki?date=2016-02-06,Sat&sel=4#l0
...points to https://foswiki.org/Tasks/Item13945
[18:49]
gac410We still test all the way back to 5.8.8, so it *should* be working on 5.10. Item13945 is only a config tool error. Doesn't impact normal operation. [18:52]
FoswikiBothttps://foswiki.org/Tasks/Item13945 [ Item13945: Software error with Perl 5.10. Can't find Ascii Unicode entity. ] [18:52]
MikeofManyI found a few tasks that were close but didn't seem correct [18:53]
gac410Try registering with email disabled. That would identify if it's an email related issue. [18:54]
MikeofManygac410, will do one moment
Yes, apparently it is.
[18:54]
gac410hm lib/Foswiki/UI.pm line 500, ... is a catch-all ... "should never get there" ;)
It does a "dump" ... are there more lines in error.log associated with that tError::subs::try(' ... message. If so, please use http://pastebin.com for large traces
[18:56]
MikeofManyIt is apparently related to this other error I'm getting, foswiki is not reading the correct perl mod for email::mime just a second on the dump [18:58]
gac410What email configuration do you have in your bin/configure. "mailprogram" or one of the Perl versions? [18:58]
MikeofManyNET::SMTP is mail method [18:59]
gac410yeah. it might not be a old perl, but related to out of date CPAN modules. Unfortunately centos is notorious for keeping perl "stable" meaning obsolete. :D [18:59]
MikeofManyand have this error on mail basic settings Email::MIME 1.863 installed Version 1.903 required for Required for Email Support Email::MIME version >= 1.903 required -- installed version is 1.863
fun part I have /usr/local/share/perl5/Email/MIME.pm
Installed: 1.937
but in /usr/share/perl5/Email/MIME.pm I have 1.863 from centos installed
I haven't found how to point foswiki (or this install of apache) to the specific path
[18:59]
gac410Ah... Foswiki might be searching the lib path wrong. Check your System.FoswikiServerInformation @INC Library Path
It's configured in bin/LocalLib.cfg which is an optional configuration file.
Around line 41. (Template in bin/LocalLib.cfg.txt) Anything you add to that statement (and uncomment) ... gets added to the front of the @inc path
[19:01]
MikeofManywhich I didn't setup.
ugh.
[19:03]
gac410Right. 99% of the time it's not needed [19:04]
MikeofManyyeah, localsite I got not localib. [19:04]
gac410LocaLib is in bin. LocalSite is in lib.
gac410 has to step away ,... sorry
[19:04]
MikeofManygot the locallib template open. [19:05]
gac410So something like @localPerlLibPath = ( '/usr/local/share/perl5', ); [19:11]
MikeofManywhen I mod this and save as Locallib.cfg do I need to so something beyond refresh the configure web page? [19:11]
gac410Unless you are using fast_cgi or mod_perl, just enable mail and try again ... You can check your System.FoswikiServerInformation to see if it's there. [19:13]
MikeofManyyeah, no dice.
LocalLib I put this in: @localPerlLibPath = ( '/usr/local/share/perl5', );
[19:20]
..... (idle for 24mn)
one problem after another. now it's just not even trying. [19:45]
gac410, no worries thanks for the help you've been able to give. appreciate it [19:53]
gac410If you can get Lavr
Lavr's attention ... he's a centos user
[19:53]
MikeofManygood to know. thanks! [19:54]
....... (idle for 31mn)
***ChanServ sets mode: +o Lynnwood__ [20:25]
MikeofManyCan't locate object method "header_raw" via package "Email::MIME::Header" at /usr/share/perl5/Email/MIME/Header. [20:27]
gac410Mike, yes I think that's another out of date CPAN module. [20:35]
MikeofManyIt's another one I have loaded up in /usr/local/share/perl5 but foswiki is reading the out of date one in /usr/share/perl5 [20:36]
gac410What is the @INC path listed in System.FoswikiServerInformation [20:36]
MikeofManybut is that the same as the locallib.cfg line? [20:37]
gac410If you got the locallilb.cfg set correctly, the library you added should be the first entry in the @INC dump
need to confirm that the setting you made "took"... Dumb question, but did you remove the # comment character from the start of the line?
[20:38]
MikeofManyNo worries. yeah removed the # so it's @localPerlLibPath = ( '/usr/local/share/perl5', );
and the ServerInformation: @INC Library Path /usr/local/share/perl5
.
[20:40]
gac410Ah... do you have centos configured with "Mandatory Access Control" ... ie SELinux? That might block access to libraries [20:41]
MikeofManyI .. think I have it disabled.. just a sec
yup, disabled.
[20:41]
gac410And just to confirm. the module is in /usr/local/share/perl5/Email/Mime.pm (no other intermediate directories)
Hm hang on ... let me see where Email::MIME::Header comes from . Maybe it's a different module
[20:42]
MikeofManyYup /usr/local/share/perl5/Email/MIME/Header.pm
Installed: 1.937
[20:43]
gac410Okay. What version of Email::Simple is installed. It's used by Email::MIME::Header and provides the header_raw method [20:46]
MikeofManyThanks.. didn't find that info on cpan.org hmm just a sec [20:46]
gac410Darn. we don't list it in our dependencies because we use it indirectly. And installing Email::MIME probably "brings it in" but it may have been satisfied by an older version in your system. [20:47]
MikeofManyif perldoc is to be beleived, 2.210 for Email::Simple [20:48]
gac410Hm strange. I've got 2.206 installed. And Email::Simple::Header has a header_raw method. damn. [20:53]
MikeofManythere. Email::Simple::Headder doesn't and it's listed individually as 2.005 in the path that foswiki is using. [20:54]
gac410Ah ha... So install that one in your /usr/local/share/perl5 directory [20:54]
MikeofManydone and testing.
sweet emails are goign out, and registration mods are working. Thanks gac410 really appreciate it.
[20:54]
gac410Looks like it would make sense to add those modules to our Dependencies file so that at least it points out issues [20:56]
MikeofManyAgreed.
ugh gotta run
[20:57]
gac410Centos libemail-mime-perl is just too old. Well good luck... glad you got it going,. [20:57]
Anyway, 2.206 is the minimum version of Email::Simple::Header. That's where they added the header_raw method. [21:02]
........ (idle for 37mn)
GithubBot[distro] gac410 pushed 1 new commit to Release02x01: https://git.io/vwaHM
distro/Release02x01 983e4f7 George Clark: Item13883: Email::Simple has a minimum rev
[21:39]
***GithubBot has left [21:39]
FoswikiBothttps://foswiki.org/Tasks/Item13883 [ Item13883: Documentation changes for master and 2.1 ] [21:39]
GithubBot[distro] gac410 pushed 1 new commit to master: https://git.io/vwaHp
distro/master 383a62d George Clark: Item13883: Merge branch 'Release02x01'
[21:40]
***GithubBot has left [21:40]

↑back Search ←Prev date Next date→ Show only urls(Click on time to select a line by its url)