#foswiki 2016-04-27,Wed

↑back Search ←Prev date Next date→ Show only urls(Click on time to select a line by its url)

WhoWhatWhen
***gac410 sets mode: +v FoswikiBot [00:03]
........................................................ (idle for 4h35mn)
gac410 has left [04:38]
..................................... (idle for 3h4mn)
ChanServ sets mode: +o MichaelDaum [07:42]
..... (idle for 22mn)
AndreR2Hello MichealDaum
I've got an problem with NatSkin. If i want to create a new Topic from the LeftBar link It get to the WebNewTopic page where I can insert Topic Name and chosse Template. But the buttons "Create" and "Cancel" aren't buttons rather than normal text. So i can't click them
[08:04]
MichaelDaumHi AndreR2.
normally in NatSkin there is no "create a new topic" link in the leftbar
so what did you set the SKIN preference setting to?
NatSkin doesn't even use any leftbar. it's called sidebar there (as it could be left _or_ right)
[08:10]
AndreR2Could be that I ment the Sidebar. It's the bar wich the toolbox is located [08:12]
MichaelDaumwhat did you set the SKIN preference setting to? [08:13]
AndreR2you mean this one ? : * Set SKIN = nat,pattern [08:15]
MichaelDaumthats wrong
Set SKIN = nat
in SitePreferences
[08:15]
AndreR2Okey... now my webs are gone [08:17]
MichaelDaumsee the bottom of the page
compare your settings with https://demo.michaeldaumconsulting.com
[08:18]
AndreR2i see...
Could I show my webs in the side bar too ?
[08:21]
MichaelDaumhow about you put them into the horizontal menu?
at least a selection of them
the idea goes like this:
horiz menu: navigate among webs
sidebar: navigate within a web
[08:26]
AndreR2Sounds good ... Could you give me a hint how to do that [08:28]
MichaelDaumyes sure
the site's menu is defined in SiteMenu
the default is located in the System web ... like this: https://demo.michaeldaumconsulting.com/bin/view/System/SiteMenu
to define your own one create a topic SiteMenu in your Main web ... like this https://demo.michaeldaumconsulting.com/bin/view/Home/SiteMenu
this will override any default shipped with the skin
have a look at the docu for WebComponents ... https://demo.michaeldaumconsulting.com/bin/view/System/NatSkin#WebComponents
the menu is defined as a simple bullet list of links which can optionally be nested in multiple levels to create drop-down menus.
[08:29]
AndreR2Would it be possible tho show all webs with permissions ? For Example User A gets webs 1, 2 and 3 shown. but User B has only permission to web 2 and 1 and 3 are hidden [08:36]
MichaelDaumuse %FLEXWEBLIST for that
to render a bullet list of all webs automatically
inside SiteMenu
[08:38]
AndreR2I'll give a try ^^ [08:42]
MichaelDaum:D [08:44]
AndreR2I'm working with foswiki for 3 days now :D.. Could take time [08:45]
yeah :D Don't know how - but it works ^^ [08:58]
.... (idle for 16mn)
MichaelDaumexcellent [09:14]
AndreR2Thanks a lot gro├čer Herrscher und Meister [09:15]
................................ (idle for 2h35mn)
***ChanServ sets mode: +o CDot [11:50]
.......... (idle for 47mn)
AndreR2Got another bug... My WYSIWYG editor is missing [12:37]
.... (idle for 17mn)
***ChanServ sets mode: +o gac410 [12:54]
..... (idle for 24mn)
AndreR2is there an option to completely disable wysiwyg per user ? [13:18]
gac410Yes, Set NOWYSIWYG = 1 in the user's profile topic. [13:18]
AndreR2Strange... WYSIWYG is only working in IE ... [13:29]
***ChanServ sets mode: +o Lynnwood [13:35]
gac410Check your configured JQuery versions ... bin/configure extensions, JQuery settings. [13:37]
AndreR2Only JQuery or JQueryPlugin [13:38]
gac410Under general settings {JQueryPlugin}{JQueryVersion}: and {JQueryPlugin}{JQueryVersionForOldIEs}:
They generally should be the "default" ... there was a bug in the unreleased version, One Old IE version was spelled jqery not jquery, not sure if that made it into the testing version.
[13:39]
AndreR2Version is 2.2.2 and for old IEs 1.12.2
I have the test JQueryPlugin installed. (7.01). May i go back to the Released version
[13:41]
gac410I think MichaelDaum_ said the new version was needed with natskin.
In any event, the testing version++ will become released hopefully on sunday .
I doubt it's the version of the plugin. Are there any javascript errors with non-ie browsers?
[13:42]
AndreR2I get errors from Content Security Policy
"script-src http://foswikidevsrv 'unsafe-eval'")
[13:45]
gac410Ah... CSP enforcement. I don't think that's enabled in default foswiki. MichaelDaum_ ... Any ideas?
I think an optional extension enables CSP controls. May need some tuning.
[13:45]
AndreR2so IE ignores CSP / hasn't support for that and thats the cause ? [13:49]
gac410That's my guess. I thought MichaelDaum_ implemented CSP in an extension. I'm having trouble finding it.
Do you have Foswiki:Extensions/SecurityHeadersPlugin installed?
[13:51]
FoswikiBothttps://foswiki.org/Extensions/SecurityHeadersPlugin [ SecurityHeadersPlugin ] [13:52]
***ChanServ sets mode: +o Lynnwood__ [13:52]
AndreR2I'm on it - but went is some trouble
The Config.spec for SecurityHeadersPlugin is more recent than the latest configuration. You should run 'import extension settings' and then save the configuration.
[13:53]
gac410Okay. That's a button right on the tab with that error.
Did you just install it, or did you have it installed?
[13:54]
AndreR2I installed it right now [13:55]
gac410I've never used it. ... just downloaded it to take a look. If you did not have it already installed, then It probably was not the issue.
I was just trying to figure out how/why your browser was encountering CSP enforcement. Unless it's some other browser extension or setting.
And I remembered Michael had released that extension. Didnt' konw if it was pulled in automatically with nat skin.
[13:55]
AndreR2Tested it on Firefox / chrome and IE. Only IE works [13:59]
gac410No idea AndreR2 ... I use firefox day-to-day, and chromium (on linux) ... no IE there obviously ... Never have encountered CSP issues. [14:00]
AndreR2Could this be some Apache config thing ? [14:01]
gac410I don't think so. I suppose there might be some way to insert headers from apache, but nothing that we suggest. [14:02]
AndreR2Got it
so in chrome it works now. Firefox crys on
[14:04]
gac410If you use the net trace, you can look at the http headers to see the various headers set by SecurityHeadersPlugin, or inserted by apache
I enabled SecurityHeadersPlugin and it added a bunch of headers. For ex: content-security-policyconnect-src 'self'; default-src 'none'; font-src 'self'; frame-src *; img-src 'self' data:; media-src *; object-src *; report-uri /bin/rest/SecurityHeadersPlugin/report; script-src 'self' 'unsafe-eval'; style-src 'self' 'unsafe-inline'
[14:07]
AndreR2add 'unsafe-inline' to script-src was th soultion for Chrome [14:10]
gac410And boom .... wysiwyg now failing with Content Security Policy: The page's settings blocked the loading of a resource at self ("script-src http://... mydomain.com 'unsafe-eval'"). [14:10]
AndreR2Yes - thats my error [14:12]
gac410well disabling that in the security headers settings makes it much worse.
Was your apache inserting those headers?
[14:13]
AndreR2no - [14:17]
gac410Strange that you would be getting errors then without that extension. Unless something in Nat extensions is adding those headers. [14:18]
AndreR2Not even the wildcard method works [14:19]
gac410Since you didn't have it installed, I suggest disabling that extension.
and then checking the browser errors again.
[14:20]
AndreR2Please kill me
Disabled it and no it works ?!
So it didn't worked -> Installed Plugin -> Enable it -> Do some config -> disable plugin... makes a lot of sense
[14:21]
gac410Okay. well I did get it working with the security headers plugin, by setting {Http}{ContentSecurityPolicy}{'script-src'}: to 'self' 'unsafe-eval' 'unsafe-inline' [14:25]
AndreR2it has to be 'self 'unsafe-eval' unsafe-inline' [14:25]
gac410But why you were getting CSP failures before you installed that extension I have no idea. Right. [14:25]
AndreR2Thats how computers work :D [14:26]
gac410Which makes sense because foswiki still has a lot of inline javascript. One of the things we are gradually working on. [14:26]
AndreR2Sounds nice! Looking forward to it. [14:33]
***ChanServ has quit IRC (*.net *.split) [14:43]
verne.freenode.net sets mode: +o ChanServ [14:55]
.......................................................... (idle for 4h49mn)
Lynnwood__Anyone know a way to find broken links in a web. I.e. WikiWords for non-existent topics. [19:44]

↑back Search ←Prev date Next date→ Show only urls(Click on time to select a line by its url)