#foswiki 2016-08-09,Tue

↑back Search ←Prev date Next date→ Show only urls(Click on time to select a line by its url)

WhoWhatWhen
RiskRewardHi, I'm having some trouble with access control. I'd like to keep out one group, but let all others in. I added the denied group to "DENYWEBVIEW", and left ALLOWWEBVIEW empty, but now no-one can see the web. [01:13]
gac4102.x or 1.1 [01:14]
RiskReward2.x [01:14]
gac410Okay. Try setting ALLOW to * along with the DENY for the group
Though what you described should work.
[01:14]
RiskRewardThink I've found the problem. For some reason I was automatically a member of the denied group. [01:16]
gac410Ah... That would do it :) [01:16]
RiskReward(embarrassing) [01:17]
gac410no big deal. Sometimes you have to describe the problem to someone to discover the issue. [01:17]
RiskRewardThanks. [01:18]
gac410vrurg, it looks like the Foswiki config is no longer picking up the defaults from the Spec. I've been trying to get past bootstrap and finding one undefined $Foswiki::cfg entry after another.
PasswordManager, LoginMmanager AuthScripts ...
[01:22]
.......................................... (idle for 3h26mn)
***gac410 has left [04:48]
................ (idle for 1h18mn)
ChanServ sets mode: +o CDot [06:06]
..... (idle for 24mn)
ChanServ sets mode: +o MichaelDaum
MichaelDaum changes topic to: Logs: http://irclogs.foswiki.org/bin/irclogger_log/foswiki - Slack: https://foswiki-slackin.herokuapp.com/
MichaelDaum changes topic to: Logs: http://irclogs.foswiki.org/bin/irclogger_log/foswiki - Slack: https://foswiki-slackin.herokuapp.com/ - Bugs: https://foswiki.org/Tasks
[06:30]
........................ (idle for 1h57mn)
foswiki_irc3Is it possible to make global categories? [08:28]
.................................................... (idle for 4h16mn)
***ChanServ sets mode: +o gac410 [12:44]
........ (idle for 39mn)
FoswikiOnSlack<dunners> Michael, you there?
<nuddlegg> Hi @dunners
<dunners> Hello Michael, managed to get the theme on my foswiki install. A lot cleaner that the previous skin. Just wanted to ask a question about why I have some code appearing.
<dunners> See the above image. I have this code appear in every page.
<nuddlegg> That's an error in the current NatSkin. There's code from ClassificationPlugin that slipped in. Next version will fix this.
[13:23]
<dunners> Thank you for verifying, much appreciated. [13:34]
....... (idle for 34mn)
***ChanServ sets mode: +o CDot [14:08]
.......... (idle for 47mn)
ChanServ sets mode: +o Lynnwood [14:55]
..... (idle for 20mn)
FoswikiOnSlack<nuddlegg> +1
<lynnwood.brown> thanks. i was actually trying to drag it into my profile.
[15:15]
.......................................................................... (idle for 6h8mn)
vrurggac410: Hi, can you provide me with more details on what's happening? [21:24]
gac410Sure. I'm running plain old apache cgi. "git clean -fdx ... ./pseudo-install developer
hit up the default webhome, and it crashes
Log: http://pastebin.com/hctPB6xM
i think you looked at / fixed the "can't locate object method secure" previously.
But after that the "undefined" errors. appear to be because Foswiki.spec has not been processed? The Foswiki::cfg hash has lots of undefined stuff
Each one I fix by adding a || blah default, and another one fails.
[21:26]
....... (idle for 31mn)
By the way ... those two "unexpected pass" tests have been happening a long time, not sure about the 3rd one though. I don't understand the issue, I've looked at them a couple of times. [22:02]
....... (idle for 34mn)
***ChanServ sets mode: +o gac410 [22:36]
........ (idle for 38mn)
vrurggac410: Could it be that unexpected passes are related to short URLs? Like in my case even /view is omitted.
Regarding the CGI – do test it via Plack::Handler::CGI or with CGI engine?
BTW, the log isn't accessible on pastebin. Looks like it expired.
[23:14]
gac410Whoops ... sorry, I only posted it for 1 hour. Yes it's related to short URLs.
Sorry ... I was AFK eating supper
I think I'm testing with CGI engine. Apache web server.
Here is log again . 24 hour lifetime this time around,.
http://pastebin.com/s9nUhE5A
I have no idea how to test with Plack::Handler::CGI ... Apache runs the view script using CGI, and nothing is configured yet, so I assume it's the plain old CGI engine.
(unless you are talking about using plackup ,.. yeah I've used that, but have to reconfigure apache to be a proxy :(
[23:22]
vrurgI mean http://search.cpan.org/dist/Plack-0.9979/lib/Plack/Handler/CGI.pm
Though it would require replacing all bin/ scripts to be replaced.
[23:27]
gac410I have no idea. I start apache and visit mywebsite.com which runs the view script.
I have one apache server config and I switch the github checkout between master, Release, your branch, etc.
[23:27]
vrurgI didn't work with CGI engine lately. Frankly saying, it's neglected by me. [23:29]
gac410I try to keep my "server" stable, and switch between releases, so I can duplicate issues on various branches. [23:30]
vrurgPerhaps as it is all about PSGI now I shall replace the scripts... [23:30]
gac410yeah moving onto Plack and dumping the old engines would be good. [23:31]
vrurgI would try. Had different plans for today but that's gonna be fun! ;) [23:32]
gac410;) [23:32]
.... (idle for 18mn)
vrurgBootstraping isn't plackup compatible. FindBin detects plackup and proposes totally incorrect bin dir. Ok, that's not a big deal whatsoever. [23:50]

↑back Search ←Prev date Next date→ Show only urls(Click on time to select a line by its url)