#foswiki 2016-10-19,Wed

↑back Search ←Prev date Next date→ Show only urls(Click on time to select a line by its url)

WhoWhatWhen
gac410vrurg: are you around?
Looking for hints on how to supply POSTDATA to an unit test post
[00:08]
............ (idle for 59mn)
vrurg: I suspect I'm missing how to add POSTDATA into the createNewFoswikiApp. I've tried including it as a requestParams initializer, and also a engineParams initialAttributes ... Both seem to be ignored.
gac410 throwing in towel for now.
[01:07]
***ChanServ sets mode: +o SvenDowideit [01:16]
......... (idle for 41mn)
gac410vrurg, I think Request::JSON is pretty badly broken for POSTDATA. It's missing a "clearer" for jsondata, fixed that, and it seems to just ignore the POSTDATA, so it never gets parsed. [01:57]
............................... (idle for 2h34mn)
***gac410 has left [04:31]
............................. (idle for 2h24mn)
ChanServ sets mode: +o CDot [06:55]
.............................................. (idle for 3h49mn)
sanders77hi is anyone here ? [10:44]
uebera||Someone will always be listening. Just ask away and be a bit patient (be sure to watch the logs as well)... ;) [10:47]
sanders77thanks. i´am newbie on foswiki. i installed the natskin plugin and now i have no idea how to activate it for my site
where i have to add this
* Set SKIN = nat
[10:49]
uebera||sanders77: see https://foswiki.org/System/Skins#Activating_Skins
("You can set the skin for the whole site (via SitePreferences), a single web (via its WebPreferences topic) or topic, for each user individually, or even per request")
[10:51]
sanders77thanks. hm natskin is not listed in the skinbrowser. it is listed under extensions in configure
i added set skin to the siteprefs but nothing changes
ok i got it sorry. but no everything looks pretty corupt
[10:57]
uebera||Did you check your error logs? Also, there's http://foswiki.org/Support/NatSkin which lists a number of FAQs. [11:00]
sanders77i feel ashamed, where can i find the logs [11:01]
uebera||No worries. According to the channel topics, the logs are here: http://irclogs.foswiki.org/bin/irclogger_log/foswiki :) [11:02]
sanders77i meant the error logs sorry [11:03]
and there are only 2 natskins installed, customato and jazzynote. is this correct? [11:11]
uebera||sanders77: Apart from your web server's log files, Foswiki configure has a setting $Foswiki::cfg{Log}{Dir} (stored in <basedir>/lib/LocalSite.cfg) which determines where your logs are stored.
I don't use NatSkin atm, so I wouldn't know how many default/example configurations are contained. If this is not explained elsewhere, your best bet would be to ask the author (MichaelDaum).
[11:15]
............... (idle for 1h14mn)
stefan_slighti have a question about skin/css customization - i allready successfully created a css to manipulate a test topic. that worked great. with one non-practical side effect that i had to change/reupload the attachment for every adjustment i made.. iam doing this on my local testsetup - so i have full access to my files..
is it possible/save to just change the css-file in the data section?
if i understood it correctly for a new skin i only have to create a new view.myname.tmpl file - that seemd to work - but where can i store the css for this skin? do i have to create a Topic in the System Web somehow?
[12:32]
.... (idle for 17mn)
***ChanServ sets mode: +o Lynnwood
ChanServ sets mode: +o gac410
[12:51]
ChanServ sets mode: +o Lynnwood [13:00]
sanders77how can i change the color of a web in the left navbar. my webs have all a grey rectangle [13:07]
stefan_slightsanders77: on the webstart page there is a link to webname/WebPreferences page.
there you can change the color.
its the '* Set WEBBGCOLOR = #0ff3ff' line. if you are not familar with the the syntax have a look at http://foswiki.org/System/PreferenceSettings
the #ff00ff is the color in hex value: first two digits are red then green than blue.
[13:14]
sanders77many thanks stefan
i ve created some webs and all have access restricted to admingroup so no base user can create topics. is this the normal behaviour ?
[13:22]
how can i give by default non admin users the rights to create and edit topcis [13:29]
gac410sanders77: It depends upon which web you use as the template web when creating a new web. IIRC, it copies the preferences from there.
The _default web in WebPreferencs has * Set ALLOWWEBCHANGE = %USERSWEB%.AdminGroup
So you should be able to edit that _default web preferences, and set that one to empty, but set * DENYWEBCHANGE = %USERSWEB%.WikiGuest if you want all logged in users to be able to change
I'm not sure how NatSkin does it, but in the default PatternSkin, the ManagingWebs create wizard lets you chose any web for the template. So once you have a web with the desired settings, you can use that as the template.
[13:31]
vrurggac410: Good morning, just saw your messages regarding POSTDATA. Will need to investigate. I didn't take any special care of this. [13:41]
sanders77thanks gac410 [13:41]
gac410Hi vrurg, I worked on it for a while last night, and got lost. I suspect that configure just doesn't exercise that particular path. [13:41]
sanders77is the default web prefs that one under system - web preferences ? [13:41]
gac410vrurg, as the missing "clearer" setting causes a hard fail when trying to process POSTDATA [13:42]
vrurggac410: I guess so too or I'd be stumped over this. A test case is needed to work on.
I'm busy with work now, will come back for this later.
[13:43]
gac410sanders77: It may be different in NatSkin, but System.ManagingWebs lets you choose a template web. Though the code does process the WebPreferences overriding somethings. My memory is a bit hazy [13:43]
sanders77i am not using natskin right now. thanks [13:44]
***ChanServ sets mode: +o Lynnwood__ [13:46]
sanders77i cant find the _default template settings.. i am some kind of lost [13:47]
gac410Okay. To access the _default web, you need to put that in the URL directly as an admin. yoursite.com/_default/WebPreferences or whatever your url prefix is set to.
And the Web Create code has the "ALLOWWEBCHANGE = setting "hard coded" to the current user, Allowing a new web some "set up time" before it is opened up for general access.
[13:52]
sanders77ok many thanks :) [13:53]
gac410So if you create as "admin" then the ALLOWWEBCHANGE is set to AdminUser, If you are "JoeUser", then it is set to that.
But other settings do get copied from the _default.
So I added DENYWEBCHANGE = WikiGuest to my _default template. That got copied. But ALLOWWEBCHANGE still got set to my current user. giving you a "temporary lockdown" of the new web.
[13:53]
sanders77ok i killed allowebchange and added the deny...guest but the new web has now all of this settings, the allow admin and the deny guest [13:56]
gac410As I said ... the ALLOWWEBCHANGE is set in the perl code that copies the web, to the "current user" ... If you are logged in as admin, then that's what you get.
No way to disable that feature without patching the code :(
[13:57]
sanders77ah now i understand but .. or not
so the webs have always to be edited for the access you need after creation ?
[13:57]
gac410After you create a web, the "results" of the create includes a link to WebPreferences topic where you can edit it to remove the restriction if you want ...
It looks that way, yes. and on busy sites, it's probably a good safety, it probably ought to be configurable, but in current code it's not. :(
[13:58]
sanders77ok thanks.. ! [14:00]
...... (idle for 28mn)
gac410vrurg, it's a bit of a catch22 as the test case was busted too. If you want, I'll check in some changes to the test case that I believe manages to submit the POSTDATA,
Give you something to start with, though I have no idea if this is the correct path through the code.
[14:28]
vrurggac410: I'll try to work on it on my own. Would save some time, perhaps. [14:30]
GithubBot[distro] gac410 pushed 1 new commit to Item13897: https://git.io/vPSx2
distro/Item13897 dd0cf5d George Clark: Item13897: Experimenting with JSON fixes...
[14:38]
***GithubBot has left [14:38]
FoswikiBothttps://foswiki.org/Tasks/Item13897 [ Item13897: Implement ImproveOOModel proposal. ] [14:38]
gac410vrurg, this shows where I was heading with the changes. I'll let you try to figure it out, I'm pretty much out of ideas now. ;) [14:39]
.................. (idle for 1h29mn)
FoswikiOnSlack1<tddesma> Does anyone know how to get foswiki authentication working with Secure LDAP? [16:08]
***ChanServ sets mode: +o CDot [16:17]
ChanServ sets mode: +o Lynnwood [16:25]
.......................................... (idle for 3h27mn)
ChanServ sets mode: +o Lynnwood__ [19:52]
.... (idle for 18mn)
ChanServ sets mode: +o Lynnwood [20:10]

↑back Search ←Prev date Next date→ Show only urls(Click on time to select a line by its url)