#foswiki 2016-10-24,Mon

↑back Search ←Prev date Next date→ Show only urls(Click on time to select a line by its url)

WhoWhatWhen
***ChanServ sets mode: +o Lavr [01:32]
......... (idle for 43mn)
ChanServ sets mode: +o gac410 [02:15]
.............................................................................................. (idle for 7h46mn)
stefan_slightHello @all :-) [10:01]
.......................... (idle for 2h9mn)
***ChanServ sets mode: +o gac410 [12:10]
.............. (idle for 1h7mn)
stefan_slightsomeone here that knows something about LDAP? [13:17]
i have the 'funny' thing that my dev install works fine with our office LDAP. but the intranet server installation does not. i have compared (with the git diff command) the both LocalSite.cfg files and in the LDAP section they are identically. [13:22]
....... (idle for 31mn)
***ChanServ sets mode: +o CDot [13:53]
.... (idle for 19mn)
ChanServ sets mode: +o Lynnwood [14:12]
................ (idle for 1h16mn)
ChanServ sets mode: +o Lynnwood__ [15:28]
.... (idle for 19mn)
ChanServ sets mode: +o Lynnwood [15:47]
............................................................................... (idle for 6h34mn)
foswiki_irc5Hello
I am having trouble with the user name after one logs in - "Hi, <wikiname."
[22:21]
gac410LDAP? [22:22]
foswiki_irc5Currently, I am seeing email id without "@" in there
Yes gac410
No matter what I do, I am not able to change what shows up in the "Hi..." section
[22:22]
gac410I'm not sure how the mapper is configured to generate a wikiname from a login.
Bad time of day to get LDAP help :(
[22:23]
foswiki_irc5There are a few config settings which appear straightforward
Yeah, I know you mentioned that you are not an expert on LDAP
[22:23]
gac410There are a few dev's that are familiar with ldap, but they are in europe, so you are coming online asking while they are probably sleeping. [22:24]
foswiki_irc5some setting are like $Foswiki::cfg{Ldap}{LoginFilter} = 'objectClass=user'; $Foswiki::cfg{Ldap}{UserScope} = 'sub'; $Foswiki::cfg{Ldap}{LoginAttribute} = 'sAMAccountName'; $Foswiki::cfg{Ldap}{MailAttribute} = 'mail'; $Foswiki::cfg{Ldap}{WikiNameAttributes} = 'cn'; $Foswiki::cfg{Ldap}{NormalizeWikiNames} = 1; $Foswiki::cfg{Ldap}{NormalizeLoginNames} = 1; [22:24]
gac410Just digging through some of the sample LDAP configurations in Support web, I see one comment $Foswiki::cfg{Ldap}{WikiNameAttributes} = 'givenName, sn';
https://foswiki.org/Support/Question1310
[22:29]
foswiki_irc5Yes, what is driving me crazy is the changing those parameters is affecting nothing [22:30]
gac410Probably need to clear the LDAP Cache
The mapping is all cached when ldap is first accessd.
[22:30]
foswiki_irc5I am clearing this /var/www/foswiki/working/work_areas/LdapContrib
Or the files in here
[22:30]
gac410If you are using fcgi, it might also be in memory.
I gotta run ... sorry, trying to cook supper.
[22:31]
foswiki_irc5unfortunately, I ran into problems with fcgi and I am currently on cgi [22:31]
.............. (idle for 1h9mn)
FoswikiOnSlack<mikeofmany> Without messing with ldap integration or anything like that, any ideas why a single user would have to continually reset their password? Permissions on their user file are the same as everyone else’s as far as I can tell, but this user isn’t the creator of the page it’s the “BaseUserMapping_###" [23:40]
gac410BaseUserMapping users should not have passwords in the password manger at all.
which base user are you having trouble with?
er... I don't think I understood the question now that I read it again.
[23:41]
FoswikiOnSlack<mikeofmany> The user’s name is JohnP it isn’t a baseuser. but I think I’m misleading myself cause if I look at my user.txt it says I am the author, just looked at someone else’s and the author is BaseUserMapping_222 which is the same as JohnP’s so I don’t think that is an issue.
<mikeofmany> permissions are the same, but when JohnP tries to log in, he always has to reset his password.
[23:44]
gac410BaseUserMapping_222 is the RegistrationAgent iirc. That has nothing to do with the reset issues. But I have no idea why a user would have to reset password like that ...What "PasswordManager" are you using? [23:55]

↑back Search ←Prev date Next date→ Show only urls(Click on time to select a line by its url)