#foswiki 2016-11-21,Mon

↑back Search ←Prev date Next date→ Show only urls(Click on time to select a line by its url)

WhoWhatWhen
***Deaygo has quit IRC (Ping timeout: 256 seconds)
colas has quit IRC (Ping timeout: 246 seconds)
[00:17]
...... (idle for 27mn)
favioflamingo has quit IRC (Read error: Connection reset by peer) [00:45]
..... (idle for 23mn)
ColasNahaboo has quit IRC (Ping timeout: 248 seconds) [01:08]
...................................... (idle for 3h7mn)
vrurg has quit IRC (Quit: vrurg) [04:15]
..... (idle for 20mn)
gac410 has quit IRC (Quit: Leaving.) [04:35]
............... (idle for 1h13mn)
GuilainC_away is now known as GuilainC [05:48]
............... (idle for 1h14mn)
ChanServ sets mode: +o MichaelDaum [07:02]
.... (idle for 15mn)
GuilainC is now known as GuilainC_away [07:17]
................ (idle for 1h19mn)
ChanServ sets mode: +o MichaelDaum [08:36]
.... (idle for 15mn)
SvenDowideit_ has quit IRC (Ping timeout: 256 seconds)
ChanServ sets mode: +o SvenDowideit_
[08:51]
................................ (idle for 2h37mn)
stefan_slightGood Morning @ all (or whatever time is for you ;-) )
i try to adapt the 'ManagingWebs' Form to a custom one that only allows the user to set Name and Summary. i have just copied the source to a new topic and played around -
on thing i found now is that i have to specify a WEBBGCOLOR - but i would like to leave it empty so that the parent web color will be used..
is this possible?
[11:28]
......... (idle for 44mn)
***ChanServ sets mode: +o CDot [12:15]
uebera||stefan_slight: Why not test simply it out yourself? As explained in System.DefaultPreferences, the WEBBGCOLOR setting is usually stored in <yourweb>.WebPreferences where you can remove it.
s /test simply/simply test/
(i.e., uncomment the "* Set")
[12:20]
..... (idle for 22mn)
***ChanServ sets mode: +o Lynnwood [12:43]
..... (idle for 21mn)
ChanServ sets mode: +o Lynnwood__ [13:04]
stefan_slightuebera||: my goal is that the the form to creat a new web does not need to specify a color.
but currently if i leave the WEBBGCOLOR out i get a error message: Attention Color == has an invalid format ...
so the form verifyer wants to have a color. and than i have to manually delete it after the creation.. :-(
[13:13]
uebera||Hm. Have you tried to add WEBBGCOLOR to FINALPREFERENCES so that it cannot be overridden? In that case, the value you enter should not matter. [13:22]
..... (idle for 20mn)
stefan_slighthm - i would like to have it overriddable if for some reason needed - my intention was that only the defaults for a new web are no specified color..
i have just written some 'guide' to what to delete/change after web-creation.. so i think its fine now..
(the user has to change the permissions - there the tool also sets defaults i can't override otherwise...
[13:42]
uebera||stefan_slight: The last thing you could try (w/o changing the current code) would be to modify the template for the web; if it's enough to modify the "* Set WEBBGCOLOR =" in there (i.e, "* #Set WEBBGCOLOR"), you get the desired behaviour. Populating the form with the parent's web color is not trivial, though.
(make that '* #Set')
[13:52]
........................ (idle for 1h58mn)
***ChanServ sets mode: +o gac410 [15:51]
zak256Is it normal, that the WYSIWYG editor is started when clicking on "Edit", even when SKIN=natedit,pattern is set in System.DefaultPreferences ?
(No, in System.WebPreferences, SKIN is not set at all.)
(Neither in my users' preferences.)
[15:54]
gac410Yes, natedit is the "framework", plus an enhanced wiki text editor. You can turn of wysiwyg with the NOWYSIWYG setting [15:58]
zak256Yes I know natedit is something between the WYSIWYG and no buttons at all, and just some helper buttons which create wiki syntax.
I mean, when clicking Edit the "full" WYSIWG editor is loaded
[15:59]
gac410Yes. the natedit skin is not "just" the nat editor. So Edit gives you wysiwyg, and the edit wikitext button gives you natedit, [16:00]
zak256When clicking "Edit wiki text" I get the helper buttons for wiki syntax which I believe is natedit [16:00]
gac410right. That's how it works. [16:00]
zak256Ah, ok. [16:00]
***zak256 has left [16:06]
.................. (idle for 1h29mn)
GuilainC_away is now known as GuilainC [17:35]
.......... (idle for 46mn)
gac410CDot: Could you review the patch in Item14218 ? If appropriate I'll pull it into the 2.1.3 patch release. Thanks. [18:21]
FoswikiBothttps://foswiki.org/Tasks/Item14218 [ Item14218: EditRowPlugin: "edit button does not work when using Internet Explorer" ] [18:21]
CDotgac410: aye, it's fine [18:22]
gac410Okay great thanks, I'll get it applied. [18:23]
CDotgac410: ligament or cartilage? [18:28]
gac410:D No thanks [18:31]
CDotawwwww..... [18:31]
................ (idle for 1h16mn)
gac410Thanks GuilainC [19:47]
........ (idle for 38mn)
vrurggac410: [off] Don't know if you'd be here tomorrow, so joining everybody else here in finger crossing. [20:25]
............. (idle for 1h0mn)
gac410thanks vrurg, I should be around tomorrow - day of waiting.
btw, did you ever work out what was going on with MichaelDaum's issue on stderr and postdata?
If there is any risk, probably better to revert for 2.1.3
Though if we get a good beta going, hopefully all will be revealed ;)
[21:25]
vrurgOnly got time today to work on it. Preliminary conclusion: dumb CGI works differently when created with or without filehandle parameter. When hf supplied it thinks that it's being restored from a file and reads all of it as if it's HTTP parameters – including the uploaded file body.
The result is terrifying.
[21:29]
gac410yikes. [21:29]
vrurgvrurg is thinking of duping STDIN. Shall do the trick. [21:29]
gac410well no hurry - /me is not going to be doing much for the next few day I don't think [21:30]
vrurgThis is a challenge now. These stupidities drives me crazy. [21:34]
gac410Hopefully the psgi/plack layers replacement for cgi will make everything much better. [21:35]
vrurgI hope too. Unfortunately, have no time to test fcgi plack handler. [21:36]
gac410At this point it's SMOT ... simple matter of time. ;) [21:36]
vrurgOk, I'm back to debuggin. Komodo is a huge help as a debug tool. [21:40]
***GuilainC is now known as GuilainC_away [21:40]
vrurgThis is proven by code: CGI doesn't read multupart unless no initializer is supplied to the constructor. In other words, CGI is not compatible with environments where communication doesn't use STDIN. Old stupid dinosaur. Really doomed to extinct. [21:44]
gac410tbh the need to capture those debug messages for the email wizard is such a low priority, it's really simpler/safer, lets just do what current release does and skip capture altogether if engine is fcgi [21:50]
vrurgLet me see if STDIN duping works. If it doesn't then nothing else would help. It's not much time. [21:50]
gac410okay [21:51]
................ (idle for 1h16mn)
vrurggac410: I'll commit a patch which is more like reverting back to 74d590a. There is seemingly no way to dup STDIN so that FCGI gets a copy to be tied while others would use the untied handle. So, it shall be kept as is. [23:07]
gac410okay thanks vrurg [23:08]
vrurgWhat is confusing is that I was trying to fix lost postdata caused by 74d590a. But the current code being practically the same works on my setup with both bin/configure and file uploading. [23:10]
gac410might depend on cgi or fcgi versions. [23:11]
vrurgIf you discover any issue with it – then revert to the original. The combination of FCGI/CGI is too fragile to rely on non-standard (to they view) approaches.
When it was failing it was the same versions.
Anyway...
[23:11]
gac410okay. I'm hoping that a beta actually gets some use. We've had a few I swear nobody tested :( [23:12]
GithubBot[distro] vrurg pushed 1 new commit to master: https://git.io/vXx2o
distro/master f635056 Vadim Belman: Item14221: Trying to get the postdata and $request->param() working again....
[23:21]
***GithubBot has left [23:21]
FoswikiBothttps://foswiki.org/Tasks/Item14221 [ Item14221: Regression: writing to STDERR is broken under FastCGI ] [23:21]
vrurgOne more try: uploads work, configure works. Let's see what Michael gets on his setup... [23:25]
gac410there is something different on his setup - like with the changes for the Request::JSON, it broke on his setup. Anyway... gotta eat. [23:26]

↑back Search ←Prev date Next date→ Show only urls(Click on time to select a line by its url)