#foswiki 2017-01-11,Wed

↑back Search ←Prev date Next date→ Show only urls(Click on time to select a line by its url)

WhoWhatWhen
GithubBot[TagMePlugin] gac410 pushed 1 new commit to master: https://git.io/vMRxC
TagMePlugin/master 80dc3da George Clark: Item13916: More unicode fixes...
[03:08]
***GithubBot has left [03:08]
FoswikiBothttps://foswiki.org/Tasks/Item13916 [ Item13916: TagMePlugin need switch for utf8 when it used Foswiki::Func::saveFile|readFile. ] [03:08]
GithubBot[TagMePlugin] gac410 tagged 2.2 at f92c897: https://github.com/foswiki/TagMePlugin/commits/2.2 [03:16]
***GithubBot has left [03:16]
gac410TagMePlugin 2.2 released - fixes Unicode issues with Web, Topic and Tag names. [03:26]
....... (idle for 30mn)
***ChanServ sets mode: +o gac410 [03:56]
................. (idle for 1h23mn)
gac410 has left [05:19]
..................... (idle for 1h42mn)
ChanServ sets mode: +o MichaelDaum [07:01]
............ (idle for 59mn)
foswiki_irc9Hi, is there anyway to disable WikiWords by default? [08:00]
MichaelDaumfoswiki_irc9, yes. add " * Set NOAUTOLINK = on" to your SitePreferences.
I don't like WikiWord autolinking either and have disabled it on my day2day wiki also
[08:11]
***ChanServ sets mode: +o cdot
colas has quit IRC (Ping timeout: 256 seconds)
ColasNahaboo has quit IRC (Ping timeout: 272 seconds)
[08:13]
................................................ (idle for 3h57mn)
ChanServ sets mode: +o Lynnwood [12:14]
............ (idle for 56mn)
ChanServ sets mode: +o OliverKrueger [13:10]
.... (idle for 16mn)
zak256Is there something convenient to write into a search string, when you do not need any search string? e.g. if you just need all topic="MyPage*" and no further restriction?
Up to now I write %SEARCH{"'true'" topic="..." ...}%
[13:26]
........ (idle for 38mn)
foswiki_irc8Hi! A newb question. Foswiki informs me about updates for 1 plugin. When checking it's the ToolTipPlugin. But it's not being upgraded. Neither through bin/configure or with the tools/extensioninstaller. When examining the ToolTipPlugin.pm-file I see that there are two variables. $VERSION and $RELEASE. The $RELEASE shows the same version as shown to be a new version when using bin/configure to update... Any ideas? [14:04]
zak256I guess it is important to know, which Foswiki version and which ToolTipPlugin version you have. [14:07]
foswiki_irc8Foswiki-2.1.2. Copied from ToolTipPlugin.pm: $VERSION = '$Rev: 1340 1357 (14 Dec 2008) $'; $RELEASE = '1.5'; [14:08]
zak256That seems to be the latest version: http://foswiki.org/Extensions/ToolTipPlugin
Apparently the notification is either wrong or misleading.
[14:09]
foswiki_irc8That is my thought also.. any ideas how to solve it? [14:12]
zak256No. When did the message appear? Directly after a new installation? [14:13]
foswiki_irc8Yes [14:13]
zak256Then I have no idea unfortunately. Maybe someone else here knows the upgrade detection better. If it is not too complicated you might try to install it again using fresh resources. The LocalConfig.cfg can be saved before. [14:15]
foswiki_irc8A lot of migration from TWiki has been done, so I would rather not redo it.
I'm not sure if the plugin is even used, so I'm going to grep some tooltipplugin-variables. Maybe I can disabled it.
[14:15]
zak256Maybe there went something wrong while doing this? Perhaps there is some old file from TWiki? [14:16]
foswiki_irc8From what I can see there shouldn't be any issues with the merge from TWiki. I've only copied data and pub-directories. But from what I have seen the plugin isn't used. So i'm uninstalling/disabling it.
Thank you zak256 for your help
[14:27]
zak256No problem. [14:28]
***ChanServ sets mode: +o gac410 [14:32]
gac410Hi all .... anyone familiar with PGP around? [14:33]
zak256That depends on what Question you have... ;) [14:33]
gac410I upgraded my gpg key in December - going to a longer key, Signed my new key with the old one, and afaik I supersceded it, I did not revoke the old one.
Someone opened a task asking for the old foswiki packages to be re-signed with my new key.
I thought this should have left the old signatures valid for that point in time, and only new packages would need to use the new key
If the poster is right, I need to go back and re-sign every package I releasaed under the old keys going back to 1.1.0, That doesn't seem right.
[14:34]
zak256How is he trying to validate the packages?
Of course you can verify the signatures against several keys.
The old packages are of course not signed with your new key, if he searches for a signature that matches the new key.
[14:36]
gac410Item14264 [14:38]
FoswikiBothttps://foswiki.org/Tasks/Item14264 [ Item14264: Installation package is signed with a revoked key ] [14:38]
gac410He says: ,,,is signed with the revoked key 0x2B40DFFFF287C07B (revoked 2016-12-08). It seems the key is superseded by 0x86A2870C25C98409 [14:39]
zak256Ah... he writes, that the key has been revoked... [14:39]
gac410I have to go look.. I followed the debian published procedure to migrate to the 2048 bit keys. I didn't think I revoked the old one. Maybe I did :( [14:39]
zak256You should be able to check easily... let me check...
"gpg --list-keys" should print out the keys in your keyring and write the status.
for example: pub 1024D/ABCDEF 2010-06-18 [expired: 2015-12-31]
[14:40]
gac410Yeah it says revoked. I must have screwed up. [14:41]
zak256:-/
If the revoked key wasn't published somewhere where you do not have access, and you have a backup somewhere of your key, you might be able to save something,
[14:41]
gac410gac410 demonstrating ignorance ... If a package was signed prior to the revocation date, isn't that still a valid use? [14:43]
zak256But usually, revoked keys shouldn't be restored someway. [14:44]
gac410No, It's all been pushed to the mit keyserver [14:44]
zak256Well... if you recognize that your key has been compromised, a revocation should reflect possible badly signed files as well.
But I guess there are possibilities to re-sign several packages again with a new key.
[14:45]
gac410I've got github tags and release packages signed going all the way back to Foswiki 1.1.0 Yeesh.
Yeah I can re-sign the current release, that should be easy enough.
gac410 learns something ... the hard way ... all too often :(
[14:45]
zak256It should be possible to sign a package with a simple script. Then all you need to do is run that script for all the packages. Isn't that possible?
With not so much effort I mean.
[14:46]
gac410Oh the signing is easy. it's more downloading all to re-sign. I don't have everything local, especially the vmware images But anyway, people really should not be going back to the old versions - they have known security issues anyway.
I'll re-sign 2.1.2 ... that should be enough.
thanks zak256 .... I need to go find and re-read the howto on gpg keys and figure out where I misunderstood things.
[14:48]
zak256downloading and uploading should be scriptable as well ;-) But maybe you're right. [14:49]
gac410Other than december. last time I touched my gpg keys was 2004. So not something that stays in memory [14:50]
zak256I re-new my keys every year and extend the expiration date.
But I have to look up the commands as well everytime.
[14:50]
gac410Y I have to do that with my certificates - but with startcom now questionable, and cacert not widely accepted, letsencrypt and automatic regeneration is a godsend. [14:54]
zak256Yes... letsencrypt is still on my TODO list as well.
But last time I checked, I could not provide a different port.
[14:55]
gac410gac410 cheated and let uebera|| do all the heavy lifting on foswiki.org, and then plageri.... er researched is scripts ;) [14:56]
zak256Ah... is there something convenient to set as SEARCH parameter, in a query search where you only have some topics you want to find?
I use %SEARCH{"'true' topic="Prefix*" ...}% for now, but think it doesn't seem right.
[15:02]
gac410topic="prefix*" is a good thing to use. That is the initial filter of topics fetched from store. So can have a huge performance boost. [15:03]
zak256Yes I do that. I meant what do I place in the actual search parameter. I couldn't simply omit it the last time I tried... [15:04]
gac410Even if you search for a specific topic name, you should also include the topic= parameter ... search isn't really smart in that situation.
Ah. I think I've seen SEARCH{"1" or "." ... not sure if there is a good rule of thumb
[15:04]
zak256Okay. I try that next time. [15:05]
MichaelDaumHey guys. We had a donnation to the Foswiki Association e.V. from a company called u-blox AG. I am going to write a thank-you email on behalf of the community. [15:10]
gac410Excellent MichaelDaum Do you know anything about them? I saw the emails the other day. [15:10]
MichaelDaumcheck out their website at https://www.u-blox.com [15:11]
gac410cool. [15:14]
***tuor has quit IRC (Quit: WeeChat 1.5) [15:26]
ChanServ sets mode: +o Lynnwood__ [15:34]
MichaelDaumOliver might know. [15:36]
gac410The new gpg signatures for foswiki Release 2.1.2 have been uploaded to sourceforge and github. [15:38]
uebera||: Do you have some time to work on the blog instance? Where do we stand. Anything I should be doing? [15:43]
uebera||I've deployed the new certificate, i.e., https://blog.foswiki.org now displays the maintenance message. Once Michael provides us with a copy of the blog instance, we can start to evaluate it locally. [15:47]
gac410Don't we need to build a foswiki install on .../www/blog.foswiki,org? And install plugins, etc. [15:49]
uebera||Depends on what Michael provides; see Monday's release meeting log, the blog uses new code (not everything might be public yet). [15:50]
gac410ah... okay [15:50]
uebera||Maybe you can chat on #foswiki-admin about that (if you prefer to set it up from scratch and only copy the payload). [15:51]
zak256In a query search, is it possible to use regex like this for example %SEARCH{"parent.name ~ 'Pages[0-5]'" ...}%
I couldn't make it work yet...
[15:58]
gac410zak256: ~ is a wildcard match, not a regex.
try =~ which makes it a regex
[16:10]
zak256Great! Another mystery solved. Thanks gac410. [16:18]
MichaelDaumu-blox' smtp server rejects incoming emails to our donator ... hm [16:20]
zak256...wait. It doesn't work yet unfortunately. I tried Myfield=~"MyValue[2]", but no results, while without ~ and "MyValue2" it works. [16:22]
foswiki_irc0Hi, I'm having trouble setting up foswiki [16:31]
gac410zak256: I don't do much with query search, not sure what's going on. Anyone else? ... (and I need to step away for a while. ) [16:32]
foswiki_irc0for some reason foswiki is telling me 'localsite.cfg is missing or is unreadable'
anyone available?
[16:39]
zak256Check permissions of the file for the user who runs foswiki. [16:42]
foswiki_irc0I set full read/write permissions for all users for the foswiki directory [16:43]
zak256In my installation the file is called "LocalSite.cfg" (uppercase L and S) maybe that's it. [16:44]
foswiki_irc0yeah, I tried searching for that and couldn't find it
was that inside the root directory?
[16:45]
zak256LocalSite.cfg needs to be placed in the lib directory [16:45]
gac410LocalSite.cfg should be created when you follow the bootstrap link to bin/configure and save your configuration.
Until the it will be missing / unreadable.
I you are not getting a usable configure, and see an un-styled login and the localsite.cfg message, it may be that you are not resolving or are blocking the javascript required to run configure.
[16:46]
foswiki_irc0okay, I just couldn't find the save button lol
it was in the top right corner
[16:54]
........ (idle for 39mn)
foswiki_irc9I tried changing the default favicon for foswiki but it's not working [17:34]
zak256Maybe a browser refresh is necessary. [17:35]
foswiki_irc9I changed the default favicon inside /foswiki/pub/System/ProjectLogos and now it just doesn't show anything
I just tried refreshing and it's still not working
[17:37]
zak256Maybe SHIFT+Refresh?
Or the icon is somehow malformed/too big/wrong format or something?
[17:43]
gac410Try opening the browser tools and look at the requests that the browser is issuing - does it "get" the file okay? [17:45]
foswiki_irc9@gac410 do you know how I would do that on firefox? [17:46]
gac410in the hamburg menu - Developer - Network tool. At least on linux, the shortcut is Ctrl-Shift-Q [17:48]
foswiki_irc9Well it doesn't show the favicon that I put in the ProjectLogos directory, is it possible to have too large a favicon?
the favicon.ico that I am trying to use is 361kb while the default favicon is 1.4kb
[17:52]
zak256361kb for a favicon?! :-O [17:53]
foswiki_irc9I converted a png to ico format [17:54]
zak256Maybe this will help you: http://stackoverflow.com/questions/2268204/favicon-dimensions
What are the dimensions?
[17:54]
gac410favicon.ico should be really small - 16x16 typically
if you have imagemagick on your server, "identify favicon.ico" for ex:
identify ./pub/System/ProjectLogos/favicon.ico
./pub/System/ProjectLogos/favicon.ico ICO 16x16 16x16+0+0 8-bit sRGB 1.41KB 0.000u 0:00.000
[17:58]
foswiki_irc9I ran identify favicon.ico and it shows 16x16 [18:01]
gac410Your new one? And it's 361K Something is wrong there. [18:01]
foswiki_irc9alright I changed that favicon to a much smaller favicon
and for some reason it's still not working
[18:06]
zak256I'm off. Have a nice evening everyone. [18:07]
gac410So a couple of things This is completely outside of foswiki. It's a file that the browser fetches directly. You can also test just by pointing a url to yoursite/pub/path/to/favicon.ico
IIRC browsers do attempt to cache / optimize this as it's an extra request for every visit to the site.
[18:08]
foswiki_irc4alright I restarted firefox and it's still missing the favicon [18:15]
gac410Did you try to access the file directly? yoursite/pub/path/to/favicon.ico [18:17]
foswiki_irc4I don't know what url to use [18:17]
gac410yoursite.com/pub/System/ProjectLogos/favicon.ico
or it might be /foswiki/pub/...
[18:18]
foswiki_irc4I checked it, and it shows the favicon that I'm trying to use [18:18]
gac410hm okay. Did you Set FAVICON in any of your WebPreferences or Main.SitePreferences
If you display the "source" of the page, you should see a link to the icon foswiki is telling the browser to use. ie <link rel="icon" href="/pub/System/ProjectLogos/favicon.ico" type="image/x-icon" />
control-U and look a few lines down. Link should be towards the top after a few meta lines
[18:21]
foswiki_irc4I see the link, when I click it, it says 'Object not found: The requested URL was not found on this server' [18:26]
gac410How is the url different from the one you tested [18:26]
foswiki_irc4okay... the problem was that I omitted /foswiki from the url, so the url was localhost/pub/System/ProjectLogos/favicon.ico
it's working now
[18:29]
gac410okay great [18:29]
foswiki_irc4thanks for the help [18:30]
gac410sure, glad to help. [18:30]
***alexlist has quit IRC (Quit: Coyote finally caught me) [18:35]

↑back Search ←Prev date Next date→ Show only urls(Click on time to select a line by its url)