#foswiki 2017-03-29,Wed

↑back Search ←Prev date Next date→ Show only urls(Click on time to select a line by its url)

WhoWhatWhen
GithubBot[distro] gac410 pushed 1 new commit to master: https://git.io/vSONq
distro/master 88088d7 George Clark: Item5969: Add support for IPv6 addresses in sq bracket links....
[02:31]
***GithubBot has left [02:31]
FoswikiBothttps://foswiki.org/Tasks/Item5969 [ Item5969: Support IPv6 addresses in Square Bracket links ] [02:31]
........ (idle for 38mn)
***ChanServ sets mode: +o Lynnwood [03:09]
.................... (idle for 1h36mn)
gac410 has left [04:45]
................... (idle for 1h30mn)
GithubBot[distro] MichaelDaum pushed 1 new commit to master: https://git.io/vS3Tf
distro/master 40c0ec3 MichaelDaum: Item14356: fixed default for content type
[06:15]
***GithubBot has left [06:15]
FoswikiBothttps://foswiki.org/Tasks/Item14356 [ Item14356: Content type lost when loading from page cache ] [06:15]
GithubBot[distro] MichaelDaum pushed 1 new commit to Item14288: https://git.io/vS3TU
distro/Item14288 5077adc MichaelDaum: Merge branch 'master' into Item14288
[06:16]
***GithubBot has left [06:16]
FoswikiBothttps://foswiki.org/Tasks/Item14288 [ Item14288: rewrite to support pluggable edit engines ] [06:16]
.... (idle for 16mn)
***ChanServ sets mode: +o cdot [06:32]
.... (idle for 17mn)
ChanServ sets mode: +o MichaelDaum [06:49]
........ (idle for 39mn)
ChanServ sets mode: +o cdot [07:28]
cdotfoswikibot: seen MichaelDaum [07:28]
FoswikiBotcdot: MichaelDaum was last seen in #foswiki 39 mins 19 seconds ago joining the channel. [07:28]
......... (idle for 43mn)
***ChanServ sets mode: +o cdot [08:11]
...... (idle for 28mn)
cdotMichaelDaum: minor type https://foswiki.org/Tasks/Item14357
^type^typo
[08:39]
MichaelDaum:D [08:46]
AndreRGood Morning
Since I updated LDAP_Contrib Plugin there isn't the extension settings tab.
And foswiki is loading for ever
[08:46]
................................ (idle for 2h35mn)
***ChanServ sets mode: +o cdot [11:23]
................... (idle for 1h32mn)
GithubBot[DBIStoreContrib] cdot pushed 1 new commit to master: https://git.io/vS31n
DBIStoreContrib/master 8b413ad cdot: Item14359: remove call to start()
[12:55]
***GithubBot has left [12:55]
FoswikiBothttps://foswiki.org/Tasks/Item14359 [ Item14359: Typo ] [12:55]
...... (idle for 28mn)
***ChanServ sets mode: +o gac410 [13:23]
......... (idle for 41mn)
gac410Hi cdot, MichaelDaum ... In Item5969, I checked in a change to make [...] IPv6 addresses work inside [[squab]] links. It is only active if Regexp::IPv6 is installed. [14:04]
FoswikiBothttps://foswiki.org/Tasks/Item5969 [ Item5969: Support IPv6 addresses in Square Bracket links ] [14:04]
MichaelDaumgac410, +1 [14:04]
gac410It's a single commit, so easy to revert. Just keep an eye out for any strangeness rendering [[squab]] links. It works by lifting out anything that looks like an [abcd:...] IP v6 address first, then renders squabs, then puts them back.
So if Regexp::IPv6 accidentally matches any [[squab][links]] then it would break that rendering.
uebera|| got the Regexp::IPv6 installed on t.f.o, and the links appear to be rendering okay now.
[14:05]
........... (idle for 54mn)
jmk0In 1.1.9 I notice that the code (lib/Foswiki/Prefs/Stack.pm) still has mentions of FINALPREFERENCES but the _default web template does not. Is this something that has been deprecated? [15:01]
gac410No, FINALPREFERENCES are set for important settings that you don't want overridden. By default used in SitePreferences [15:02]
jmk0ok, thanks [15:03]
........... (idle for 50mn)
GithubBot[distro] MichaelDaum pushed 1 new commit to Item14288: https://git.io/vSs3N
distro/Item14288 35b3c2e MichaelDaum: Item14288: make insert-table work...
[15:53]
***GithubBot has left [15:53]
FoswikiBothttps://foswiki.org/Tasks/Item14288 [ Item14288: rewrite to support pluggable edit engines ] [15:53]
........... (idle for 52mn)
***ChanServ sets mode: +o cdot [16:45]
........... (idle for 50mn)
jmk0Why does %WEB% separate webs from subwebs using / instead of . ? e.g. %WEB%=Main/SubWeb instead of %WEB%=Main.SubWeb [17:35]
gac410Actually that's the correct syntax. the dot is only supposed to separate web from topic. Slash elsewhere [17:36]
jmk0ah ok [17:36]
gac410it does work between web & subweb in some cases, but it can be ambiguous.
You could have both a subweb named "Subweb" and a topic named "Subweb" for ex
[17:37]
jmk0you can use a reference without a topic name? Does it implicitly resolve to WebHome (or whatever the main page topic is set to) [17:39]
gac410It should, yes.
The testing and parsing on all that can be a real bear.
[17:39]
jmk0i bet [17:40]
gac410See https://github.com/foswiki/distro/blob/master/UnitTestContrib/test/unit/RequestTests.pm#L135 for some examples that are tested. [17:42]
....... (idle for 34mn)
cdot, have you noticed that the new tinymce seems a lot slower to initialize? I have not really timed anything, but it just seems to have more of a delay when entering edit. [18:16]
cdotau contraire, it seems a lot faster to me, even to the extent that I have started to use it [18:18]
gac410what browser? [18:18]
cdotthe Foswiki part has been trimmed down to the bone, now, so any remaining performance issues are likely in either TMCE or the TML->HTML conversion
been testing mainly in Chromium, but also in Firefox
[18:18]
gac410anyway, it was just a "feeling", I mainly use firefox. maybe it's just me. ;) [18:19]
cdotif you want to benchmark, I would look at the WysiwygPlugin part of the loop (which can be nicely isolated)
I did rewrite the list parsing code, but my changes should make it faster, not slower.
[18:20]
gac410It may be other stuff as well. fcgi, caching, etc. [18:21]
.... (idle for 18mn)
master: Edit a page - 263 requests, 3237 KB, 11 Seconds
Release02x01: Edit same page - 93 requests, 2347 KB, 4.97 Seconds
It's a simple page with 15 or so bullets.
[18:39]
It's very consistent and repeatable. With cache disabled, plain old cgi system. master issues almost 3x as many get requests, and takes over twice as long to initialize the editor [18:49]
.......... (idle for 45mn)
cdotgac410: no idea, I'm afraid. There are fewer files loaded explicitly by FW, so the extra loads have to be coming from the likes of TMCE plugins. [19:34]
gac410yes. That seems to be the bulk of the loads. lots of tmce plugins. [19:35]
cdotbig, complicated edit on my server has 111 loads, and takes 775ms [19:36]
gac410They don't have much in the way of support comments that I could find. One search on performance only found 4 hits. One asking if there was a way to bundle all the loads - no answer. And one for performance drugs. Well monitored community ;)
Strange. I'm just running from a git checkout on my laptop. Way more than 111 loads. And it's a simple page. Just some bullets of ipv6 addresses.
[19:36]
cdot111 requests, 367KB transferred (Chromium)
same page on 55, 113 requests, 2MB transferred (nothing in the cache there), startup in 1.35s
^55^FF
[19:38]
gac410Loading an empty page. (Create a new topic from Sandbox). 263 requests 12.23 seconds. (Using developer tools -> performance tool [19:40]
cdotabout half the requests are jquery plugins, the other half are TMCE [19:40]
gac410Hm hundreds of requests are all internal to tmce, One is /pub/System/TinyMCEPlugin/tinymce_dev/js/tinymce/classes/AddOnManager.js many many .js files from similar locations. [19:42]
cdotoh, you are using _dev? Why? [19:43]
gac410hm I seem to be running the _dev version. what is causing that?
I have no idea ... magic?
[19:43]
cdotyes. If you have FOSWIKI_ASSERTS on it will use _dev. [19:43]
gac410I'm just running a default master checkout with a mostly default bootstrapped ... Ah... yes I have ASSERTS enabled.
Asserts disabled. 103 requests, 5 seconds. So that brought it way down.
(reloading the editor on an empty page)
[19:43]
cdotstill, 5 seconds? that's a lot
try loading again, now your cache is full
[19:45]
gac410Plain old cgi, local to my laptop. Apache. 8 processors .. [19:45]
cdotsame-ish, except I'm on a core i7 desktop monster so CPU is ridiculously fast [19:46]
gac410most of the js does not get cached. gifs and css get 304s but all the js is 200 But I don't have mod_expires enabled [19:47]
....... (idle for 34mn)
interesting, chrome seems **much** faster. With a fcgi site, and caching, mod_expires, etc. all active, edit takes 93 requests, 525ms to initialize. Same conditions, firefox takes almost 3 seconds. [20:21]
............... (idle for 1h12mn)
foswiki_irc2hello, attempting to upload an attachment in the WYISWYG editor does not work. The dialog box expands after clicking "Upload", but the file does not upload.
i am running version 2.1.3.
is this a known issue?
[21:33]
gac410not that I've seen ... I'll give it a quick try on foswiki.org [21:34]
foswiki_irc2i'll try there also. [21:34]
gac410Worked fine here: https://foswiki.org/Sandbox/TestUploadFailure ... Entered edit. Clicked paperclip, Upload tab, uploaded LICENSE, changed to link tab and inserted the link.
Is it a very large file you are trying? Do you see any javascript errors reported?
[21:37]
foswiki_irc2it worked on foswiki.org in my testing too. it's an issue on my side. need to do more debuging.
no, tried the same file on foswiki.org and was successful.
[21:38]
gac410we do have a large size limit on f.o, so extensions and the like can be uploaded Foswiki default is 10000 iirc [21:39]
foswiki_irc2this error is generated on my site: Uncaught TypeError: Cannot read property 'validation_key' of undefined [21:39]
gac410hm validation_key has to do with the strikeone XSS protection. [21:40]
foswiki_irc2file size is 86KB
i'm testing with Chrome
didn't work with Firefox either
thanks for helping
[21:40]
gac41010000K so 86k ought to work.
Is your site configured for strikeone? {Validation}{Method} is the configuration key.
[21:41]
foswiki_irc2a bit more from the js error:
at Object.submit (attach.js:1) at HTMLFormElement.<anonymous> (attach.js:1) at HTMLFormElement.dispatch (jquery-2.1.1.js:2) at HTMLFormElement.elemData.handle (jquery-2.1.1.js:2)
let me check
[21:43]
FoswikiBotlet me check is Moo is in EPEL [21:43]
gac410FoswikiBot: forget let me check [21:43]
FoswikiBotgac410: I forgot about let me check. [21:43]
gac410The bot sometimes gets a bit talkative. ... no idea why [21:44]
foswiki_irc2chatty bot
it is set for strikezone
strikeone
[21:44]
gac410okay. that's the default. So that *should* be working Is everything else workiing - can you preview, save&continue, etc ... [21:49]
foswiki_irc2save & continue, yes. preview is not an option. [21:49]
gac410No preview button? Are you using NatSkin? or the default PatternSkin ... Buttons should be [save] [Save & continue] [Preview] [Add Form] [Cancel] [21:51]
jmk0gac410: regarding the conversation wrt subwebs, when you create a web using System.ManagingWebs, it explicitly states that subweb syntax is Existingweb.Newweb [21:59]
gac410Yes, that's what that particular form needs. I think I even opened a task saying our documentation and forms are very inconsistent. It's pretty confusing for sure. [22:00]
jmk0:) [22:01]
gac410Item12930 [22:02]
FoswikiBothttps://foswiki.org/Tasks/Item12930 [ Item12930: Inconsistencies in how subwebs are referenced ] [22:02]
foswiki_irc2i tried to open preferences and receive a path error. there is a perl module issue i need to resolve -- Can't locate auto/Image/Magick/AutoOrient.al in @INC
i enabled TopicInteractive ImageGallery and ImagePlugin, and there must be an issue with ImageMagick
[22:03]
jmk0lots of deferrals ;-) [22:04]
gac410That must be an extension foswiki_irc2. ... ah beat me to it. Yes. ImageMagick / PerlMagick can be painful to get installed. [22:04]
foswiki_irc2ubuntu 12.04
imagemagick is installed with standard packages, but AutoOrient may not be included.
[22:05]
gac410no idea .. I'm not familiar with that. ubuntu 12.04 is getting pretty old by now. Maybe it has an old version of imagemagick [22:06]
foswiki_irc2right, need to get that resolved first.
i'll fix it, then return if i'm still experiencing a problem.
thanks for your help
[22:07]
gac410yw. I doubt that the imagmagick and the validation / js error are in any way related [22:08]
foswiki_irc2ok, but still want to get that fixed first. [22:09]

↑back Search ←Prev date Next date→ Show only urls(Click on time to select a line by its url)