#foswiki 2017-04-25,Tue

↑back Search ←Prev date Next date→ Show only urls(Click on time to select a line by its url)

WhoWhatWhen
***alexlist has quit IRC (Quit: Coyote finally caught me) [00:00]
......................................................... (idle for 4h43mn)
rouilj has quit IRC (Ping timeout: 245 seconds) [04:43]
................................. (idle for 2h42mn)
ChanServ sets mode: +o MichaelDaum [07:25]
............................................................. (idle for 5h3mn)
ChanServ sets mode: +o gac410 [12:28]
.......... (idle for 45mn)
ChanServ sets mode: +o Lynnwood__ [13:13]
............................. (idle for 2h21mn)
GithubBot[JQTablePlugin] cdot pushed 1 new commit to master: https://git.io/v9qQZ
JQTablePlugin/master f4e08fd cdot: Item13239: 3 years in waiting-for-release is not healthy
[15:34]
***GithubBot has left [15:34]
FoswikiBothttps://foswiki.org/Tasks/Item13239 [ Item13239: some javascript errors ] [15:34]
....... (idle for 33mn)
gac410vrurg: are you around? I have a freebsd question [16:07]
***ChanServ sets mode: +o cdot [16:08]
cdotfoswikibot: seen gac410 [16:09]
FoswikiBotcdot: gac410 was last seen in #foswiki 1 mins 30 seconds ago saying "vrurg: are you around? I have a freebsd question". [16:09]
gac410hi cdot [16:09]
cdotgac410: is strikone switched off on f.o? [16:09]
gac410I hope not ... [16:09]
cdotnot seeing any validation codes in forms... [16:10]
gac410just checked - it's set to "strikeone" in bin/configure [16:10]
cdotlooking at /bin/login. There used to be a strikeone input field on that form, but it's gone [16:13]
gac410maybe a cache issue? I looked at the create a new task form. validation missing, issued ?refresh=cache and then it's there ??? [16:15]
cdotI keep seeing Use of uninitialized value $val in pattern match (m//) at /usr/share/perl5/HTTP/Cookies.pm line 123, <STDIN> chunk 3 when perl build.pl upload [16:16]
gac410I think the page cache isn't supposed to cache the validation keys to the db, but they should get added in later ... not sure on that one though. [16:17]
cdotno, it isn't
I don't understand this error deep in the guts of LWP::UserAgent, though :-(
[16:17]
gac410not sure on the unitialized $val either. I vaguely recall seeing something like that Was that strange issue related to setting parameters in the build.pl script? [16:18]
cdotah... maybe
ah yes, it looks supect
hmm, yes, that's it. Need to work out why, now
[16:18]
gac410I've never had to do any tweaks in that module. It just "works" if the default is taken.
anyway vrurg, when you get a chance:
I'm trying to help someone with a freebsd system. Foswiki 2.1.3, our shebang "/usr/bin/env perl" doesn't work. 404 not found. Had to rewriteshebang it to /usr/local/bin/perl.
I thought the /usr/bin/env perl was supposed to be universal and accommodate stuff lilke this.
[16:20]
cdotaha, it's because the UPLOADTARGETSCRIPT is set to an invalid URL
$build->{UPLOADTARGETSCRIPT} = 'http://foswiki.org/bin';
which used to work....
[16:22]
gac410(should be https. You'll get redirected I think for any action that would modify something) [16:23]
cdotnow it 302's to https [16:23]
gac410snap [16:23]
cdothum. SHould LWP follow 302's? [16:23]
gac410lwp does not support https out of the box. Thre is a separate perl module required. [16:24]
cdotah yes, it must, cos I'm getting the right page back, but with a strange cookie jar
y, that's probably it
[16:24]
gac410gac410 just plays 20 questions for all uploads, and doesn't bother with trying to override the defaults. [16:24]
GithubBot[JQTablePlugin] cdot pushed 1 new commit to master: https://git.io/v9qAZ
JQTablePlugin/master c7f14ef cdot: Item13239: 3 years in waiting-for-release is not healthy
[16:26]
***GithubBot has left [16:26]
FoswikiBothttps://foswiki.org/Tasks/Item13239 [ Item13239: some javascript errors ] [16:26]
cdotyou are right to do so; I added the support for enterprise users who wanted to maintain local Extensions dirs [16:27]
gac410ah. gotcha [16:27]
cdotand have used it that way - once!
BTW I just spent 2 hours tracking down a bug.... that Micha had fixed back in 2015. He had checked in the fix, but left the task in "Waiting for Release" state, and there it lingered.
would be a good idea to do some talent spotting, and see if any other tasks are similarly held up.
13999
[16:27]
gac410See http://foswiki.org/Tasks/NeedsResolution
Searches for tasks with checkins, but not closed.
But not sure if it covers non-default extensions.
I do review that before each release.
[16:31]
cdotgotcha, that's useful [16:32]
gac410darn.... some iso-8859-1 encoding has crept into the System.UpgradeGuide. [16:41]
.... (idle for 15mn)
GithubBot[distro] cdot pushed 2 new commits to master: https://git.io/v9qju
distro/master 9205ace cdot: Item14323: George's suggested doc updates
distro/master 6f8e46e cdot: Merge branch 'master' of https://github.com/foswiki/distro
[16:56]
***GithubBot has left [16:56]
FoswikiBothttps://foswiki.org/Tasks/Item14323 [ Item14323: Update to latest TinyMCE version ] [16:56]
.............. (idle for 1h5mn)
GithubBot[SafeWikiPlugin] cdot pushed 1 new commit to master: https://git.io/v9mqm
SafeWikiPlugin/master 83e77b2 cdot: Item14355: prep for release
[18:01]
***GithubBot has left [18:01]
FoswikiBothttps://foswiki.org/Tasks/Item14355 [ Item14355: Missing Attachment template expects too many params ] [18:01]
.... (idle for 19mn)
***ChanServ sets mode: +o cdot [18:20]
...... (idle for 29mn)
GithubBot[distro] gac410 pushed 1 new commit to Release02x01: https://git.io/v9mZH
distro/Release02x01 b1517ff George Clark: Item13883: Use Entities, not utf-8 characters...
[18:49]
***GithubBot has left [18:49]
FoswikiBothttps://foswiki.org/Tasks/Item13883 [ Item13883: Documentation changes for master and 2.1 ] [18:49]
GithubBot[distro] gac410 pushed 1 new commit to master: https://git.io/v9mZF
distro/master 15b1936 George Clark: Merge branch 'Release02x01'
[18:50]
***GithubBot has left [18:50]

↑back Search ←Prev date Next date→ Show only urls(Click on time to select a line by its url)