#foswiki 2017-05-04,Thu

↑back Search ←Prev date Next date→ Show only urls(Click on time to select a line by its url)

WhoWhatWhen
gac410Ah ha. Check that it's enabled in configure [00:00]
TarunI could kill myself for missing this
it is all resolved
Wonderful
[00:00]
gac410;) Don't do that. Excellent. [00:01]
Tarunthank you very much
Appreciate your time
[00:01]
gac410Now. dependencies. The ones listed as optional for NatSkin ... you might want to evalueate if you want any of them.
Glad to help. just watching tv / reading
[00:01]
TarunIt looks like it is rendering fine
do you do this as a hobby?
just curious - can't believe that there's such a helpful resource here
[00:01]
gac410y. I'm retired. better than watching tv. [00:02]
Tarun:-)
I appreciate what you're doing for the community
[00:02]
gac410I do a small amount of consulting as well. But mostly hobby. [00:03]
TarunIf you ever come to San Jose
I would love to treat you to a coffee!
[00:03]
gac410I used to ... ages ago. Worked for Wellfleet / Synoptics / Bay Networks / Nortel ... well Santa Clara, but close enought. [00:04]
TarunAh, I'm with A10 Networks...
load balancing, CGN, ddos mitigation and stuff
we've been using foswiki internally
and I just took over
[00:04]
gac410anyway. glad to help. keeps my tech skills somewhat active. [00:05]
Tarungotcha
see you
good night, and thanks one last time
[00:05]
gac410see you... good night. yw. [00:05]
***Tarun has quit IRC (Quit: Page closed) [00:05]
.... (idle for 15mn)
GithubBot[distro] gac410 pushed 1 new commit to Release02x01: https://git.io/v9umo
distro/Release02x01 59a1339 George Clark: Item13883: BuildContrib documentation out of date...
[00:20]
***GithubBot has left [00:20]
FoswikiBothttps://foswiki.org/Tasks/Item13883 [ Item13883: Documentation changes for master and 2.1 ] [00:20]
GithubBot[distro] gac410 pushed 1 new commit to master: https://git.io/v9umi
distro/master 5b3dcf5 George Clark: Item13883: BuildContrib documentation out of date...
[00:20]
***GithubBot has left [00:20]
.................. (idle for 1h26mn)
ChanServ sets mode: +o Lynnwood
Lynnwood_ has quit IRC (Ping timeout: 240 seconds)
[01:46]
GithubBot[distro] gac410 pushed 3 new commits to Release02x01: https://git.io/v9uCa
distro/Release02x01 a50cf6a cdot: Item13766: cosmetic fix to CSS, thanks FlorianSchlichting
distro/Release02x01 6ee15aa cdot: Item13339: icons were getting stuck even after problems resolved due to poor management of the level tags
distro/Release02x01 9fa750c cdot: Item13954: fix spurious error message. Was cosmetic, as analysis surmised.
[01:49]
***GithubBot has left [01:49]
FoswikiBothttps://foswiki.org/Tasks/Item13766 [ Item13766: EditRowPlugin columns widths are jumping to wider size when you hoover the mouse over the table ]
https://foswiki.org/Tasks/Item13339 [ Item13339: Warning or errors icons in configure get stuck unless page is reloaded ]
https://foswiki.org/Tasks/Item13954 [ Item13954: Extensions with "pluggable" components cause errors: No such value {Store}{Implementation} ]
[01:49]
***nixdork has quit IRC (Quit: EliteBNC free bnc service - http://elitebnc.org/) [02:03]
vrurggac410: New extension DBConfigExtension has just stored it's first config into a database. [02:08]
gac410cool [02:08]
vrurgIt actually means that I'll soon be ready to hand over the work into community hands. It would only be a matter of documenting things.
Then the people will be terrified because there is no taint checks, no configure support for the new specs format, no translations... And few more 'no'...
Anyway, time for the the late dinner. cu!
[02:09]
gac410yikes.
cu
have a good evening
[02:10]
vrurgYikes, yes. But I'm not an almighty one, unfortunately. Didn't hope to get the extension done by the end of May, even... Good evening you too! [02:11]
........ (idle for 35mn)
GithubBot[distro] gac410 pushed 1 new commit to Release02x01: https://git.io/v9u8G
distro/Release02x01 dc8f3ac George Clark: Item13907: Report the list of extensions to update.
[02:46]
***GithubBot has left [02:46]
FoswikiBothttps://foswiki.org/Tasks/Item13907 [ Item13907: Report of required update is lacking information ] [02:46]
GithubBot[distro] gac410 pushed 1 new commit to master: https://git.io/v9u8R
distro/master 6873fac George Clark: Item13907: Merge branch 'Release02x01'
[02:49]
***GithubBot has left [02:49]
.... (idle for 15mn)
ChanServ sets mode: +o Lynnwood [03:04]
hvxgr has quit IRC (*.net *.split) [03:11]
................ (idle for 1h18mn)
gac410 has left [04:29]
.................... (idle for 1h35mn)
ChanServ sets mode: +o cdot [06:04]
........... (idle for 51mn)
GuilainC is now known as GuilainC_away [06:55]
............................ (idle for 2h15mn)
VickiBrown1 has quit IRC (Quit: Leaving.) [09:10]
.............................. (idle for 2h29mn)
ChanServ sets mode: +o gac410 [11:39]
.......................... (idle for 2h6mn)
colas has quit IRC (Read error: Connection reset by peer) [13:45]
gac410 sets mode: +v [LOGGER_FOSWIKI]
gac410 sets mode: +v FoswikiBot
[13:50]
......... (idle for 41mn)
Lynnwoodg'day folks. Following an upgrade of a site to 2.1.3 I found a application function that worked in earlier version failed in the latest and greatest version. Specifically the failure related to an INCLUDE that referenced itself in certain conditions. I know that there has been for some time code that prevented this kind of setup to generate a deep recursion but it appears that the newest code is somewhat more strict than the old version.
To complicate matters more, I have other similar functions that do still work and I have not yet figured out what's different about the two cases causing one to work and the other to fail. I'm wondering if anyone if familiar enough with the code related to what triggers the warning "Can't INCLUDE {topic reference} repeatedly, topic is already included" so I can better understand how to avoid it.
For what it's worth, having INCLUDES include conditional statements that call themselves are sometimes useful for tracing a recursive relationship.
well, well... I guess I just found the answer for myself.
[14:31]
gac410Looking at the code, it has not changed in a long time that I can see. [14:38]
Lynnwoodyea, i suspect not. Line 167 of INCLUDE.pm: " if ( $this->{_INCLUDES}->{$key} || $count > 99 ) {"
So probably, some _other_ condition has changed in my topic function that resulting in this ceiling being hit whereas it didn't before.
interesting...
[14:39]
gac410There is a small difference in 1.1 vs 2.x where it builds the key of the hash for comparison ... not sure how significant
-    $key .= $control->{_sArgs}; (2.x)
+    $key .= $args; (1.1)
[14:41]
Lynnwoodhow do you do those comparison so quickly? in git? [14:43]
gac410yes. git diff Release02x01:core/lib/Foswiki/Macros/INCLUDE.pm Release01x01:core/lib/Foswiki/Macros/INCLUDE.pm
and "git log -L204,214:lib/Foswiki/Macros/INCLUDE.pm" which displays the changes just for the code in that line range.
[14:43]
Lynnwoodthanks. very useful [14:47]
ah... i found the issue. It relates back to the FORMFIELD issue I brought up yesterday... or more specifically the temporary hack i used to try to work around that.
...makes sense now.
[14:59]
gac410cdot and MichaelDaum have not been around today, so can't ask about the spaces in formfield names. :( [15:00]
LynnwoodI was just looking at that again. (you may have seen i posted task a little while ago) [15:01]
gac410Just looking now. A simple hack might be to add a line to lib/Foswiki/Macros/FORMFIELD.pm after the line "my $formField"
$formField =~ s/\s//g; # remove embedded spaces.
Though I think the real fix is probably deeper. as it should impact QUERY as well.
[15:04]
..... (idle for 20mn)
Lynnwoodagreed. I thought about mentioning that in my task
I may try out your hack
[15:25]
gac410So a couple of questions. you might add to your task: An example of the Form definition for the field. An example of the %META from the topic where the field is instantiated, and then examples of the FORMFIELD and QUERY macros that fail. [15:28]
Lynnwoodsure enough
thanks
[15:28]
gac410You might read CDots comment to Item2097 [15:30]
FoswikiBothttps://foswiki.org/Tasks/Item2097 [ Item2097: FORMFIELD is not working as in TWiki due to chaneg in storing of form data ] [15:30]
gac410And Item12090 has some comments about embedded spaces. [15:32]
FoswikiBothttps://foswiki.org/Tasks/Item12090 [ Item12090: Field name -with description- in Forms not working properly ] [15:32]
Lynnwoodfor what it's worth. Your hack worked.
:-O
:-)
[15:33]
That's excellent. Solved a couple of issues for me.
OK, i'll go back and enhance that task.
[15:39]
gac410I'm not sure that the fix will be accepted. The comments in the other task seem to state that field names should not contain spaces. ... if I read them correctly [15:40]
LynnwoodBoy... you're correct. He makes his position pretty clear in Item2097.
And I kind of agree. It never actually occurred to me to used the spaced version of the field name in FORMFIELD and when a user pointed it out to me, i was kind of surprised it worked earlier. But that's just like users... to break things by trying something that seems kind of intuitive.
one of my personal aphorism from doing this work: it's nearly impossible to make things idiot-proof because there's no end in idiots' ability to come up with novel ways to break things.
[15:48]
gac410Or. "I made it idiot proof, and someone invented a better idiot" ;) [15:52]
Lynnwoodgreat! [15:52]
gac410Though really in some cases innovative features arise out of unanticipated use. [15:53]
Lynnwoodoh dear.... just got a call from my son. He's feeling bad so i need to go pick him up from school.
for sure.
[15:53]
gac410good luck [15:53]
LynnwoodI'll return to this later. [15:54]
Just reading through the doc for VarFORMFIELD and DataForms, it's really not made clear that the field "name" is specifically the non-spaced version.
It really doesn't distinquish between field name and title. I understand the distinction because of being familiar with the meta data but the distinction is really not clear in the docs themselves.
i.e. the distinction exist in the code but not the docs themselves.
gotta go...
[15:59]
gac410y [16:03]
............................ (idle for 2h18mn)
foswiki_irc6Hello!
This is Tarun =)
Browsing through my foswiki installation yesterday, I noticed that any page with attachments doesn't render properly
the page itself loads correctly
however, at the bottom, where visible attachments are listed
shows a permanent loading sign - much like the iphone loading sign
I was wondering if someone could help me out with this...
as far as I can tell, it's something to do with NATskin
because when I try pattern skin, the attachments load up just fine
[18:21]
....... (idle for 32mn)
***GuilainC_away is now known as GuilainC [18:58]
............ (idle for 57mn)
foswiki_irc7Awesome, I got the email functionality working on Windows Server too now [19:55]
..................... (idle for 1h43mn)
***GuilainC is now known as GuilainC_away [21:38]

↑back Search ←Prev date Next date→ Show only urls(Click on time to select a line by its url)