#foswiki 2017-05-21,Sun

↑back Search ←Prev date Next date→ Show only urls(Click on time to select a line by its url)

WhoWhatWhen
***GuilainC is now known as GuilainC_away [00:06]
......... (idle for 41mn)
gac410 sets mode: +v [LOGGER_FOSWIKI] [00:47]
........................... (idle for 2h10mn)
Lynnwood_ is now known as Lynnwood
Lynnwood has quit IRC (Quit: My iMac has gone to sleep. ZZZzzz…)
[02:57]
......................... (idle for 2h4mn)
jmk0 has quit IRC (Ping timeout: 260 seconds) [05:02]
.............................. (idle for 2h28mn)
GuilainC_away is now known as GuilainC [07:30]
................................ (idle for 2h37mn)
vrurg has quit IRC (Ping timeout: 268 seconds) [10:07]
................................ (idle for 2h39mn)
ChanServ sets mode: +o gac410 [12:46]
.................. (idle for 1h26mn)
ChanServ sets mode: +o MichaelDaum [14:12]
.................. (idle for 1h29mn)
ChanServ sets mode: +o Lynnwood [15:41]
............... (idle for 1h14mn)
Rich_Morin has quit IRC (Ping timeout: 240 seconds) [16:55]
..................................... (idle for 3h1mn)
colas has quit IRC (Remote host closed the connection) [19:56]
.... (idle for 18mn)
daemonhey all
just trying to configure email
how do I tell it that I do not need a username or password
[20:14]
...... (idle for 27mn)
I told my mail server to just 'always accept' if its from my wiki :)
but it is a little upset when it tries to auth
[20:41]
hmm who was I talkingto before
gac410, Hey there sorry for the direct message but I figured everyone had the channel idle at the bottom of there irc client ;) any idea ^
[20:53]
gac410Hi daemon, I'm not really sure. If you leave the user/pass blank, I'd expect that it would try it unauthenticated. [20:55]
daemongac410, it literally won't let you
it resets them to 'admin' and whatever the default pass is :P
[20:55]
gac410hm let me try that. [20:55]
daemonoooh hold on
it just let me set them blank
lets see if she will send an email
oh yes also .. how do you remove users
the section in the documentation is broken
[20:57]
gac410no, you are correct I think. I just tried a quick test wihtout user/pass and it rejected it. I don't think my server requires auth inside.
gac410 looking at the code
[20:58]
daemon:) [20:59]
gac410Okay I think it's the autoconfigure that is broken. Set the hostame:25, leave user & pass empty, and then in advanced settings, enable email, Set the method to Net::SMTP and then try to send an email ... You don't have to actually save the config. [21:00]
daemonhold a sec I need to find out howto remove a user first; my test email' is used on its account
and I only allow 1 user per email
lol
[21:01]
gac410hm just backspacing all the characters out of USERNAME and PASSWORD should work [21:02]
daemonhold a sec how can I remove a user; (the documentation is broken for it)
then I can test the email ;)
https://foswiki.org/System/ManagingUsers#Removing_User_Accounts
No permission to view RemoveUser
all the rest of the page is fine oddly
[21:02]
gac410What do you mean remove a user. Oh... you need to be in the admin group. Or signed in as the superadmin user [21:03]
daemonyep I am [21:03]
gac410but in bin/confgure in email tab there is a button to send a test email. You should not need to remove any users or register to test the configuration [21:04]
daemonMail was accepted for delivery to Wiki Administrator <wiki@tmp.group> from "Wiki Administrator" <wiki@tmp.group>. Be sure to check any SPAM and Bulk-email folders before assuming that delivery has failed.
the email server dropped it but it did send
2017-05-21 22:04:35 1dCY1j-0000sf-3U == wiki@tmp.group R=remoteuser T=remote_smtp defer (-1): remote_smtp transport called with no hosts set
appears the 'test' sent an email with no TO:
[21:04]
gac410No permssion to view RemoveUser That's really strange.
No... The test email should use a To: and From: as the same address. The configured WikiAdmin email.
[21:05]
daemonah thats why
https://itsosticky.com/5nur1v
[21:06]
gac410If your email won't accept that, there is an expert setting [21:06]
daemonyour likely signed in as an admin or so
let me create a email box for the wiki
or should I forward it to my normal user
hmmm..
well normally I suppose people won't email the board robot anyhow
[21:06]
gac410See the expert parameter on Email tab: Wiki Agent Email:{Email}{WikiAgentEmail} Allows to override the from: address.
Defaults to the WikiAdmin address if not specified.
[21:07]
daemonI will just add the user can play about with mail config later
2017-05-21 22:08:15 1dCY5H-0000tZ-Gj => wiki <wiki@tmp.group> R=localuser T=local_delivery
2017-05-21 22:08:15 1dCY5H-0000tZ-Gj Completed
perfect
[21:08]
gac410On the no Permission to view. Can you view System.RemoveUser directly? [21:08]
daemonI have no exclimation marks AT ALL in my configuration now :)
let me check
assuming I am correct that the full link is
https://wiki.tmp.group/Main/System.RemoveUser
Access Denied
Attention
The "Main/System" w
... etc
[21:09]
gac410No... temp.group/System/RemoveUser or System.RemoveUser
(either works in URLs. Web.Topic or Web/Topic
[21:10]
daemonhold on I just got confused which web browser and url I was in then
that works perfect thank you
[21:10]
gac410System.RemoveUsers is set to: Set DENYTOPICVIEW = WikiGuest So any logged in user should be able to view the topic, and the %INCLUDE from ManagingUsers should have had the same restriction.
Maybe that browser wasn't actually logged in.
[21:11]
daemonperfect
got the email the second I hit register
code/validation worked :)
and a nice confirm email
finally have it all setup
[21:12]
gac410Great. I'll take a look at the AutoConfigureEmail wizard - It *should* have fallen back and tried to connect without authentication. [21:13]
daemoninteresting warning from exim mailer though [21:13]
gac410Though that scenario is becoming pretty rare nowadays. [21:13]
daemon2017-05-21 22:12:26 no IP address found for host 2a01 (during SMTP connection from wiki.tmp.group [2a01:4f8:150:64cd::1:100])
why the hell is it looking at the first block of my v6 host
bizzare
probably because I have told it relay_from_host 2a01:4f8:150:64cd::1:100
it must be using a different auth route than the rest of mail
[21:13]
gac410Cant' help much with exim. My servers here run postfix. [21:14]
daemonoh also https://tmp.alt.group should work with normal internet non ipv6 now
err
https://wiki.tmp.group
now time to see how long it takes for a search robot, spammer or other net threat
one tried to use the mail server as a relay within SECONDS of me starting it
literally <10 seconds
[21:14]
gac410must not have propagated tmp.alt.group fully yet. I get a NXDOMAIN when I dig it. [21:16]
daemonas an aside on the https://itsosticky.com/1w3mz2l
wiki.tmp.group ;)
I got it mixed up
but on that page I just linked ^ it might be nice to either auto forward to the mainboard or have a link to it, there actually is not one on the page
I can head to my profile or wikiusers but not the main board
[21:16]
gac410strange; dig wiki.tmp.group gets NOERROR status, but the A record is empty. [21:18]
daemonshould'nt be
but it would be perfectly valid to just have a AAAA
likely why its saying noerror
wow your nameservers are slow though
I changed the A record quite a while ago
[21:18]
gac410dig wiki.tmp.group @8.8.8.8 is also an empty A record [21:20]
daemonhetzner# host wiki.tmp.group 8.8.8.8
wiki.tmp.group has IPv6 address 2a01:4f8:150:64cd::1:100
ahhh hold on
did I just give an A for the tmp.group
I bet I did ...
there we go
would have never noticed, thank you gac410
got a very colourful domain setup with all the mail stuff
https://itsosticky.com/1wxcate
never had so many different TXT records lol
yikes google was fast
hetzner# host wiki.tmp.group 8.8.8.8
wiki.tmp.group has address 176.9.48.196
now time to learn foswiki's editing format
[21:21]
oooh I think I broke something
I was looking at page cacheing; clicked enabled (but did not save it)
now configure won't load
Foswiki detected an internal error - please check your Foswiki logs and webserver logs for more information.
Can't locate object method "new" via package "Foswiki::PageCache::DBI::Generic"
[21:33]
FoswikiBothttps://trunk.foswiki.org/System/PerlDoc?module=Foswiki::PageCache::DBI::Generic [21:34]
gac410That's not supposed to happen. [21:35]
daemonhttps://wiki.tmp.group/Configure
no idea why its even trying to load it; I did not even enable the bloody thing lol
[21:35]
gac410my local dns server is really slow to clear it's cache. [21:36]
daemonfixed it
forced apache to restart
so reload the config
[21:36]
gac410Ah. running fcgi? [21:36]
daemonfcgid
yep
[21:36]
gac410still though, it should not have saved the config, even in memory. [21:36]
daemonit must triggers some sort of attempt load
I am using RC1 perhaps its not been fully tested yet
mind you, either way ... should not even let me enable it if that module is not enabled/present
[21:37]
gac410Well I tried it here, though I'm not on fcgi. I'm running from git checkout of RC1+ [21:38]
daemonif I had saved the config would have had to go into it manually
if you like when your nameserver updates, I could let you login mine and trigger it (if it would be helpful)
[21:38]
gac410What it's supposed to do is if you enable something, a checker should put up a warning that there is an issue.
I'll poke at it a bit. But we are going to build 2.1.4 probably tonight or tomorrow. I just want to tweak the fcgi docs a bit. It's been running stably on foswiki.org for a week.
[21:40]
daemonyeah works great here too :)
I really like your automated config generater
I still wonder if I would have been better doing what I was gonig to and using nginx
used*
[21:41]
gac410I was going to look at the autoconfig issue you encountered. but that server probing code is really complex Last minute changes in that area are probably not a good idea.
We have several sites on nginx. I don't use it, but others are real fans of it.
[21:42]
daemonas the jail/container I made was just for foswiki nothing else I figured I would use what your project classed as 'stable'
no reason to make it more difficult with something I am not used to and all :)
[21:42]
gac410I'd say that nginx, lightppd and apache are all stable. But apache probably has the widest number of devs using. Nginx 2nd, and lighttpd probably a distant 3rd [21:43]
daemonoh no I did not mean stable as in 'stable code/service' I meant stable as most highly tested; original development platform
most documented
all the httpds now days are more than capable od handling almost anything
[21:44]
gac410I use apache with plain old cgi for most of my dev work as I'm constantly switching between versions using "git checkout" and restarting the daemons for each change would get annoying. [21:44]
daemonha I bet :) [21:45]
gac410gac410 goes to fire up a vm with apache / fcgi and see if he can recreate the cache issue. [21:46]
daemonif you like I can tar up my installation and send it over
let me know should be around a few hours
[21:47]
gac410No that's okay. It's probably more related to a missing dep. I'll try it on our official VM. I think that's apache 2.4 + fcgi and page cache is disabled. So you just enabled the page cache, and then browsed away from configure without save? [21:48]
daemonerm let me check make sure I can recreate
yep not sure if I turned it on AND off
but turning it on (and not saving)
click anywhere else in configure
or reload
Foswiki detected an internal error - please check your Foswiki logs and webserver logs for more information.
Can't locate object method "new" via package "Foswiki::PageCache::DBI::Generic"
it will act like its enabled and saved
[21:49]
gac410okay. I'll see what happens. Config changes in the GUI shoulid not be "live" but live in a different "local " perl variable. [21:50]
daemonok reading through the BeginnersStartHere doc, I am legendarily bad at anything design related, I just lack any ability to create anything that looks pretty; lets hope foswiki can correct for it lol [21:51]
gac410Could you check to see if your system has perl DBI installed dpkg -s libdbi-perl [21:57]
daemonroot@wiki:/usr/local/www/foswiki # pkg info | grep dbi
root@wiki:/usr/local/www/foswiki #
nope
[21:58]
gac410okay. I'll remove that from our vm and see if that can recreate the issue. [21:58]
daemonchrist it feels nice to have a real email [21:59]
gac410yup. recreated. Thats not good. [22:00]
daemonat least you can take solice in the fact its pretty damn rare to not have DBI installed
even I expected something dragged it in when you asked
[22:00]
gac410Y. Probably why nobody has reported it before. And I still don't understand why an un-saved config setting is doing this. [22:05]
daemonperhaps there are pre-requisites for pagecache
well obviosuyl there are
but in the process of checking for them DBI is being loaded
[22:08]
gac410Still. unsaved config parameters are *not* supposed to be "live" other than in configure. So somehow it's leaking into the persistent Foswiki::cfg{} hash resident in fcgi.
This is probably over my head. And our primary config developer is away for a couple of weeks.
[22:09]
daemonthe fact that it can happen is worrying as it shows potential for other problems, but luckily not an urgent threat
just drop him an email when he gets back from sun bathing :)
[22:11]
gac410;) [22:12]
daemonI really damn like this theme; think I mentioned it a few days ago its so damn clean looking [22:12]
gac410That's good as most of the other skins have been subject to much bit-rot. Other than the NatSkin ... that's under very active develpment [22:13]
daemonI am suprised this wiki does not get more attention [22:15]
gac410So anyway, the root cause is that configure is somhow allowing temporary config settings to become active. But Foswiki.pm line 2125 or thereabouts could be much more forgiving if the Cache code fails to load. [22:17]
daemonit also only seems to effect the foswiki//Configure namespace it does not for instance effect anything anything in Main/
anyhow, thank you for the fast response with the email problem; time to crawl to in bed not much else can be done till googles nameserver cache catches up :)
[22:23]
***GuilainC is now known as GuilainC_away [22:29]
gac410g'night. I'll fix the cache crash for 2.1.4. at least make it more forgiving Thanks. [22:29]
...... (idle for 27mn)
QBFreakI'm doing battle with JQueryPlugin's Chili plugin, trying to add another language to the syntax hilighting
so I created the new js recipie file, added it to the list in plugins/chili/jquery.chili.init.js (and the uncompressed version)
but no luck when I try to use it
naturally the website for Chili is lacking in any doc at all
[22:56]
gac410y chili iirc has stagnated. At one point there was a proposal to use something other than chili [23:00]
QBFreakyeah, I noticed a lot of the commits were quite old [23:01]
gac410Foswiki:Development/ReplacementForChili [23:02]
FoswikiBothttps://foswiki.org/Development/ReplacementForChili [ ReplacementForChili ] [23:02]
QBFreakthat discussion seems equally stale :) [23:06]
hmm, this looks maintained at least: https://highlightjs.org/ [23:16]

↑back Search ←Prev date Next date→ Show only urls(Click on time to select a line by its url)