#foswiki 2017-10-11,Wed

↑back Search ←Prev date Next date→ Show only urls(Click on time to select a line by its url)

WhoWhatWhen
***ChanServ sets mode: +o Lynnwood__ [02:10]
.... (idle for 18mn)
ChanServ sets mode: +o Lynnwood [02:28]
............... (idle for 1h13mn)
GithubBot[distro] gac410 pushed 1 new commit to Item14506: https://git.io/vdrIT
distro/Item14506 42c2485 George Clark: Item14506: Reset and Change are working. Still needs work...
[03:41]
***GithubBot has left [03:41]
FoswikiBothttps://foswiki.org/Tasks/Item14506 [ Item14506: Implement ImprovePasswordResetProcess ] [03:41]
GithubBot[distro] gac410 pushed 1 new commit to Item14506: https://git.io/vdrIn
distro/Item14506 868047c George Clark: Item14506: Fix a typo.
[03:48]
***GithubBot has left [03:48]
..... (idle for 24mn)
ChanServ sets mode: +o Lynnwood [04:12]
........................................................................................................... (idle for 8h54mn)
ChanServ sets mode: +o Lynnwood__ [13:06]
ChanServ sets mode: +o gac410 [13:15]
............ (idle for 57mn)
ChanServ sets mode: +o Lynnwood [14:12]
....................... (idle for 1h51mn)
zak256We have an old script in the bin directory. In httpd.conf it was defined <FilesMatch "^(myscript).*"> SetHandler cgi-script </FilesMatch>.
So now I setup FastCGI in the new wiki, I changed FilesMatch to LocationMatch.
But still I get "Missing or illegal web name" when accessing a link with this script.
The Web/Topic path: 'myscript/some/parameters' has missing components, or contains invalid characters.
I guess the script has to be updated somehow?
[16:03]
............ (idle for 58mn)
***zak256 has left [17:02]
........ (idle for 37mn)
ChanServ sets mode: +o Lynnwood [17:39]
................................. (idle for 2h44mn)
gac410hey vrurg ... Found something interesting. See Foswiki:Support.Question1901 Aux is a "reserved word" in windows. So Foswiki::Aux::MuteOut is a no-go on windows [20:23]
FoswikiBothttps://foswiki.org/Support.Question1901 [ FoswikiAuxMuteOut ] https://trunk.foswiki.org/System/PerlDoc?module=Foswiki::Aux::MuteOut [20:23]
gac410yeesh. whadda mess. So Foswiki 2.1.3 and 2.1.4 cannot run on Windows. [20:26]
.............................. (idle for 2h29mn)
ping vrurg ... you around? [22:55]
....... (idle for 30mn)
vrurggac410: now I am. Hi! [23:25]
gac410howdy vrurg. Someone today reported a issue in 2.1.3 ... Aux is a reserved directory name in windows. [23:26]
vrurgNow I see the message... Damned windows! [23:26]
gac410Anyway, I was trying to figure out where to rename it. I was wondering maybe Foswiki::Sandbox::MuteOut ??? [23:27]
FoswikiBothttps://trunk.foswiki.org/System/PerlDoc?module=Foswiki::Sandbox::MuteOut [23:27]
vrurgSame is related to con, com and few other device names used in this (don't wanna call is OS) since it's MS-DOS infantry. [23:27]
gac410y.
Or back to Foswiki ::Util::MuteOut
[23:27]
vrurgI use Aux for v3 too. Would be good to find some common solution. [23:27]
gac410I just checked cpan. There are NO modules found that use ::Aux:: in the module name. So I gues someone figured out that restriction a while back :D
Util Auxiliary Auxi ... :P
[23:28]
vrurgAnd someone got it in a hard way. I remember people were freezing the whole windows by using Con in a way.
Auxiliary is the best but very long. I'm "tasting" Util. Foswiki::Util::Callbacks, Foswiki::Util::Holder...
[23:30]
FoswikiBothttps://trunk.foswiki.org/System/PerlDoc?module=Foswiki::Util::Callbacks https://trunk.foswiki.org/System/PerlDoc?module=Foswiki::Util::Holder [23:31]
vrurgAuxi is weird. If no other alternatives then Util is the best. [23:32]
gac410y. I think Util may be best. Auxiliary it too much typing [23:33]
vrurgOk, I'm renaming it in my branch. [23:34]
gac410I have to fix it for 2.1.5, so we need to be consistent. We already have Configure::Util The only other place I could think of for MuteOut would be part of Sandbox. [23:34]
vrurgConfigure::FileUtil? [23:35]
gac410Oh... that's right, CDot deleted Util, and I needed File, so put it back as FileUtil [23:36]
vrurgToo bad of me, never used Sandbox. Considering if making MuteOut its submodule looks good. [23:39]
gac410Sandbox already has functionality to run external programs and capture the output. I'm not sure why I couldn't use it when you wrote MuteOut to fix it. [23:40]
vrurgvrurg is trying to guess it too.
The major difference is that MuteOut works with just any call. $mute->exec(sub { say "something"; } ) will have "something" in captures stdout.
Sandox works with command line only.
[23:42]
gac410Ah... That makes sense.
I'm working on rewriting our password reset code to be more secure ... Send a crypto token granting one-time login to access password change. This way a user cannot reset someone elses passwords.
But I've got a really vexing problem. Seems so simple. Net->sendEmail() When I use it in UI::Password, it cleanly reports errors (like bad email domain) But when exact same code is used in a REST Handler, it dies.
[23:44]
vrurgI saw you telling Michael about the problem. Still no solution? [23:50]
gac410well I moved on to other parts... figured I'd go back to it.
Spent yesterday redesigning the topics themselves to get rid of the | tml | tables | for layout.
So I figure I'll polish up a bunch of the branch, and then dig into it again.
Once I get the branch ready for evaluation ... and a decision on whether to merge it for 2.2, I'll beg for help debugging the behavior... And in the meantime maybe I'll trip over the soolution. ;)
[23:50]
vrurgNot sure if I could join the rescue team. Too many docs, too little time. :( [23:54]
gac410no prob... Hopefully Micha will have some time by then.
Anyway... So Util is your solution? I'll rename it for 2.1.5
[23:56]

↑back Search ←Prev date Next date→ Show only urls(Click on time to select a line by its url)